Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 10:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1C в медицине  (Прочитано 1463 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн serkus

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-14
  • Сайт: 
  • Профессия: Ученик 1С
Прошу помощи! У меня нестандартная для 1С ситуация: использование программы в поликлинике для учета выписанных пациентам льготных рецептов и возврат аптеками отпущенных для учета. Наш программист (средней квалификации) написал мне конфигурацию, но некоторые недоработки все-же исправить не может. Помогите довести программу до должного уровня. Заинтересовавшихся прошу за подробностями обращаться в ЛС. Я работал с программой раньше, немного знаком с конфигуратором и немного с программированием. Заранее благодарен.


Оффлайн serkus

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-14
  • Сайт: 
  • Профессия: Ученик 1С
Re: 1C в медицине
« Ответ #1: 15 Апр 2013, 09:11 »
// Процедура розрахунок кількості рецептів
Процедура РозрахуватиРецепти()

Спр=СоздатьОбъект("Справочник.Пацієнти");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
   _свл=Спр.Ена*Константа.Еналаприл+Спр.Ліз*Константа.Лізиноприл+Спр.Біс*Константа.Бісопролол+Спр.Мет*Константа.Метопролол+Спр.Неб*Константа.Небівалол+Спр.Ніф*Константа.Ніфідіпін+Спр.Амл*Константа.Амлодипін;
   Спр.СВЛнаРік=_свл; // подсчет расчетной суммы на год
   _кри=0;
   Если (ПустоеЗначение(Спр.Еналаприл)=0) Тогда
      _кри=_кри+1;   // посчет рецептов по каждому препарату
   КонецЕсли;
   Если (ПустоеЗначение(Спр.Лізиноприл)=0) Тогда
      _кри=_кри+1;
   КонецЕсли;
   Если (ПустоеЗначение(Спр.Бісопролол)=0) Тогда
      _кри=_кри+1;
   КонецЕсли;
   Если (ПустоеЗначение(Спр.Метопролол)=0) Тогда
      _кри=_кри+1;
   КонецЕсли;
   Если (ПустоеЗначение(Спр.Небівалол)=0) Тогда
      _кри=_кри+1;
   КонецЕсли;
   Если (ПустоеЗначение(Спр.Ніфідіпін)=0) Тогда
      _кри=_кри+1;
   КонецЕсли;
   Если (ПустоеЗначение(Спр.Амлодипін)=0) Тогда
      _кри=_кри+1;
   КонецЕсли;
   Спр.КРвиписаних=_кри;
   Спр.Записать();   
КонецЦикла; 

КонецПроцедуры 


Теги: справочник 
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 212
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal