Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 22:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: По скидкам  (Прочитано 3539 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте, подскажите вот у меня ТЧ Услуга, есть колонка, скидки, но скидки ставятся на каждую строку услугу, если там 15 услуг. можно ли разом как нибудь их проставить на все услуги?


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: По скидкам
« Ответ #1: 10 Апр 2013, 15:46 »
Какая программа?

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
Re: По скидкам
« Ответ #2: 10 Апр 2013, 15:49 »
1с 8.1 Рарус

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: По скидкам
« Ответ #3: 10 Апр 2013, 16:13 »
1с 8.1 Рарус

какой из? http://rarus.ru/1c-rarus/

В общем не важно. Где то в шапке документа должна быть кнопка установки скидок. Ищите ее.

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
Re: По скидкам
« Ответ #4: 10 Апр 2013, 16:44 »
Мне кажется что не важно какой там из списка, к примеру я создам на форме ПолеВвода для скидки, а что писать в при при выборе и изменения?
Процедура пвСкидкаПриВыбора
Для каждого строка из Услуги цикл
Строка.СкидкаНаТовар = ПвСКидка.Значения;
КонецЦикла
КонецПроцедуры

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: По скидкам
« Ответ #5: 10 Апр 2013, 23:32 »
Наверное там где то нужно процент считать

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Re: По скидкам
« Ответ #6: 11 Апр 2013, 09:05 »
Создаете команду на форме УстановитьСкидкуДляВсехТоваров
&НаКлиенте
Процедура УстановитьСкидкуДляВсехТоваров(Команда)

Для каждого ТекТовар Из Объект.Товары Цикл

ТекТовар.Цена = ТекТовар.Цена - ТекТовар.Цена*Объект.Скидка/100;
//Где Объект.Скидка - ваша скидка в %

КонецЦикла;

КонецПроцедуры

Добавлено: 11 Апр 2013, 09:23

это если форма управляемая, на обычной не знаю как

Последний раз редактировалось: Besart; 11 Апр 2013, 09:23. Причина: Объединение сообщений

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
Re: По скидкам
« Ответ #7: 12 Апр 2013, 10:30 »
печально(
Добавлено: 12 Апр 2013, 13:28

Может я не так обьяснил? в ТЧ Услуги добавляют услуга, но им приходиться делать на каждую строку добавлять скидку. Хотят что бы можно было разом добавить скидку на все услуги которые выбрали в ТЧ услуги

Последний раз редактировалось: Zverff; 12 Апр 2013, 13:28. Причина: Объединение сообщений

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: По скидкам
« Ответ #8: 12 Апр 2013, 15:13 »
Процедура КнопкаДобавитьВсемСкидки(Элемент)
   
   Перем тСкидка;
   Если ВвестиЧисло(тСкидка,"Введите скидку для всех строк!",5,2) Тогда
      Для каждого Стр Из ТабличнаяЧастьУслуги Цикл
         Стр.Скидка = тСкидка;
      КонецЦикла;
   КонецЕсли;
   
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 332
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal