Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2018, 11:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получить значение реквизита с типом Хранилище Значения  (Прочитано 2518 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн grand1k

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-10
  • Сайт: 
  • Профессия: Ученик 1С
Ребят объясните пожалуйста.Вот у меня есть справочник с реквизитом ДанныеФайлаКартинки тип ХранилищеЗначения.Вот код находиться в модуле "ФормаЭлемента";

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ДанныеФайлаКартинки");
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьКартинку(Команда)

Перем ВыбранноеИмя;
АдресКартинки = "";
Если ПоместитьФайл(АдресКартинки, "", ВыбранноеИмя, Истина) Тогда
Объект.ИмяФайла = ВыбранноеИмя;
ПоместитьФайлКартинки(АдресКартинки);
КонецЕсли;
АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ДанныеФайлаКартинки");

КонецПроцедуры

&НаСервере
Процедура ПоместитьФайлКартинки(АдресВременногоХранилища)

ЭлементСправочника = РеквизитФормыВЗначение("Объект");
ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресВременногоХранилища);
ЭлементСправочника.ДанныеФайлаКартинки = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных());
ЭлементСправочника.Записать();

УдалитьИзВременногоХранилища(АдресВременногоХранилища);
ЗначениеВРеквизитФормы(ЭлементСправочника, "Объект");

КонецПроцедуры
В модуле объекта, в отчете, у меня есть код для вывода картинки при формировании.Картинку выводит, проверено на элементарном примере, а вот теперь нужно как то подязаться к картинкам в справочнике.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
а вот теперь нужно как то подязаться к картинкам в справочнике.

В смысле подвязаться?
МояКартинка = ЭлементСправочника.ДанныеФайлаКартинки.Получить(); //Получаем двоичные данные и дальше делай с ними что хочешь.
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
alex0402
64 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
53 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
37 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
32 Сообщений

* Кто онлайн

  • Точка Гостей: 746
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal