Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получить значение реквизита с типом Хранилище Значения  (Прочитано 2342 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн grand1k

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-10
  • Сайт: 
  • Профессия: Ученик 1С
Ребят объясните пожалуйста.Вот у меня есть справочник с реквизитом ДанныеФайлаКартинки тип ХранилищеЗначения.Вот код находиться в модуле "ФормаЭлемента";

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ДанныеФайлаКартинки");
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьКартинку(Команда)

Перем ВыбранноеИмя;
АдресКартинки = "";
Если ПоместитьФайл(АдресКартинки, "", ВыбранноеИмя, Истина) Тогда
Объект.ИмяФайла = ВыбранноеИмя;
ПоместитьФайлКартинки(АдресКартинки);
КонецЕсли;
АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ДанныеФайлаКартинки");

КонецПроцедуры

&НаСервере
Процедура ПоместитьФайлКартинки(АдресВременногоХранилища)

ЭлементСправочника = РеквизитФормыВЗначение("Объект");
ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресВременногоХранилища);
ЭлементСправочника.ДанныеФайлаКартинки = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных());
ЭлементСправочника.Записать();

УдалитьИзВременногоХранилища(АдресВременногоХранилища);
ЗначениеВРеквизитФормы(ЭлементСправочника, "Объект");

КонецПроцедуры
В модуле объекта, в отчете, у меня есть код для вывода картинки при формировании.Картинку выводит, проверено на элементарном примере, а вот теперь нужно как то подязаться к картинкам в справочнике.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
а вот теперь нужно как то подязаться к картинкам в справочнике.

В смысле подвязаться?
МояКартинка = ЭлементСправочника.ДанныеФайлаКартинки.Получить(); //Получаем двоичные данные и дальше делай с ними что хочешь.
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 359
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal