Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2018, 08:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Загрузка из Excel  (Прочитано 1840 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dima09

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-01
  • Сайт: 
  • Профессия: Программист 7.7
Доброе время суток! есть файлик из него нужно подгрузить информацию в справочник сравнивая лицевой счет, если лицевой счет стоит в колонке код тогда все нормально он ищет НайтиПоКоду() а если лицевой счет стоит в другой колонке я ищю НайтиПоРеквизиту() и вот тут ничего не получается.
Процедура Сформировать()  
  НачатьТранзакцию();
xl=СоздатьОбъект("Excel.Application");
rows=xl.ActiveSheet.UsedRange.Rows.Count;
спр=СоздатьОбъект("Справочник.Нас_Население");
Для row = 1 По rows Цикл   
имя=СокрЛП(xl.Cells(row,1).Value);
записать=СокрЛП(xl.Cells(row,2).Value);
Состояние(""+row+"/"+rows+"   "+имя);
Если имя="" Тогда
Продолжить;
КонецЕсли;
Если спр.НайтиПоКоду(имя,0)=1 Тогда //Вот здесь если ставлю
// спр.НайтиПоРеквизиту("Код_ИЭСБК",имя,0)=1 обработка не ищет по этому реквизиту
спр.Код_ИЭСБК=записать;
спр.Записать();   
Иначе
Сообщить(Спр.Код+"    " + Спр.Нименование);
КонецЕсли;
КонецЦикла;
ЗафиксироватьТранзакцию();
КонецПроцедуры
В чем может быть моя ошибка


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Загрузка из Excel
« Ответ #1: 10 Апр 2013, 07:41 »
Признак "сортировка" у реквизита Код_ИЭСБК установлен?

Оффлайн Dima09

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-01
  • Сайт: 
  • Профессия: Программист 7.7
Re: Загрузка из Excel
« Ответ #2: 11 Апр 2013, 03:05 »
Признак "сортировка" у реквизита Код_ИЭСБК установлен?
Да установлен

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Загрузка из Excel
« Ответ #3: 11 Апр 2013, 08:27 »
А тип значения какой у реквизита?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
98 Сообщений
AIFrame
77 Сообщений
alex0402
32 Сообщений
kiksi
24 Сообщений
pavl_vs
23 Сообщений
andron81_81
18 Сообщений
alexandr_ll
17 Сообщений
Norfolk
15 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений
Orion
12 Сообщений

* Кто онлайн

  • Точка Гостей: 532
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal