Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Май 2018, 14:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: УТ 11 внешняя обработка  (Прочитано 2097 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн asdfr1

  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-28
  • Сайт: 
по задумке в каждую номенклатуру добавляется характеристика из "СписокЗнач"

пытаюсь впихнуть ещё одним циклом - процессор загружается на 99 %,  не пойму что не так
&НаСервере 
Функция ЗаполнитьОбъект(Знач док)
докоб=док.получитьобъект();
докпроведен=док.проведен;
таб=новый ТаблицаЗначений;
таб.Колонки.Добавить("Номен");
таб.Колонки.Добавить("Цена");
таб.Колонки.Добавить("Видцены");

//отдел1=Справочники.ХарактеристикиНоменклатуры.НайтиПоРеквизиту("НаименованиеПолное", Строка(Характе));
 Запрос = Новый Запрос;
 Запрос.Текст =
"ВЫБРАТЬ
| ХарактеристикиНоменклатуры.Ссылка  КАК Хар
|ИЗ
| Справочник.ХарактеристикиНоменклатуры КАК ХарактеристикиНоменклатуры
|ГДЕ
| ХарактеристикиНоменклатуры.Владелец.Ссылка = &Ссылка";
Запрос.УстановитьПараметр("Ссылка", Справочники.ВидыНоменклатуры.НайтиПоНаименованию("Ассортимент"));
//Результат1 = Запрос.Выполнить().Выгрузить();
СписокЗнач = Новый СписокЗначений;
СписокЗнач.ЗагрузитьЗначения(Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Хар"));

Для Каждого ТекущаяСтрока Из СписокЗнач Цикл
отдел1=ТекущаяСтрока.Значение;
отдел1=Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию(отдел1);
Сообщить(отдел21);
КонецЦикла;

для каждого текстрока из докоб.товары цикл
Для Каждого ТекущаяСтрока Из СписокЗнач Цикл
отдел1=ТекущаяСтрока.Значение;
отдел21=Справочники.ХарактеристикиНоменклатуры.НайтиПоНаименованию(отдел1);

текстрока.характеристика= отдел21;
номен=текстрока.номенклатура;
цена=текстрока.цена; видцены=текстрока.видцены;
    новстрока=таб.добавить();                                                                                                           
    новстрока.номен=номен;
    новстрока.видцены=видцены;
    новстрока.цена=цена;
//Возврат;
  Продолжить;
  Сообщить(Отдел21);

КонецЦикла;
 
для каждого текстрока из таб цикл
новстрока=докоб.товары.добавить();
новстрока.номенклатура=текстрока.номен;
новстрока.видцены=текстрока.видцены;
новстрока.цена=текстрока.цена;
конеццикла;
// вторая


докоб.записать(?(докпроведен,РежимЗаписиДокумента.Проведение,РежимЗаписиДокумента.Запись));

КонецФункции


Оффлайн wise

  • *****
  • Сообщений: 508
  • РЕПУТАЦИЯ: 65
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
для каждого текстрока из докоб.товары цикл
    Для Каждого ТекущаяСтрока Из СписокЗнач Цикл

цикла ДВА, а КонецЦикла ОДИН !!!
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
oleg-x
64 Сообщений
alex0402
61 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
24 Сообщений
BuhRust
21 Сообщений
alexandr_ll
20 Сообщений

* Кто онлайн

  • Точка Гостей: 851
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal