Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 14:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод сведений об организации  (Прочитано 4698 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн deringpavel

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-12
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте. Делаю печатную форму ТОРГ-12 для конфы УТ 11.
Как вывести сведения об организации в формате <организация-грузоотправитель, адрес, телефон, банк>?

Текст функции такой:
Функция СформироватьПечатнуюФорму(Тип, МассивОбъектов, ОбъектыПечати)

УстановитьПривилегированныйРежим(Истина);


ТабличныйДокумент = Новый ТабличныйДокумент;
ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ОрдерНаОтражениеНедостачТоваров_ОтражениеНедостачТоваров";
//
//КолонкаКодов = ФормированиеПечатныхФорм.ИмяДополнительнойКолонки();
//ВыводитьКоды = ЗначениеЗаполнено(КолонкаКодов);

ЗапросДанные = Новый Запрос;
ЗапросДанные.Текст =
"ВЫБРАТЬ
| ОрдерНаОтражениеНедостачТоваровТовары.Номенклатура КАК Номенклатура,
| ОрдерНаОтражениеНедостачТоваровТовары.Количество КАК Количество,
| ОрдерНаОтражениеНедостачТоваровТовары.Номенклатура.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
| ОрдерНаОтражениеНедостачТоваровТовары.Номенклатура.Код КАК Код,
| ОрдерНаОтражениеНедостачТоваровТовары.Номенклатура.ЕдиницаИзмерения.Код КАК КодПоОКЕИ,
| ОрдерНаОтражениеНедостачТоваров.Номер,
| ОрдерНаОтражениеНедостачТоваров.Дата
|ИЗ
| Документ.ОрдерНаОтражениеНедостачТоваров.Товары КАК ОрдерНаОтражениеНедостачТоваровТовары
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ОрдерНаОтражениеНедостачТоваров КАК ОрдерНаОтражениеНедостачТоваров
| ПО ОрдерНаОтражениеНедостачТоваровТовары.Ссылка = ОрдерНаОтражениеНедостачТоваров.Ссылка
|
|УПОРЯДОЧИТЬ ПО
| Количество";


Результаты = ЗапросДанные.Выполнить();

Выборка = Результаты.Выбрать();



//ВыводитьЯчейкиИУпаковки = СкладыСервер.ИспользоватьАдресноеХранение(ВыборкаПоДокументам.Склад, ВыборкаПоДокументам.Помещение);

   
//Макет получаем в цикле,т.к. ширина колонок зависит от склада и помещения в документе

// Шапка
        Макет = ПолучитьМакет("Макет");

ОбластьШапка = Макет.ПолучитьОбласть("Шапка");

ВыборкаНомерДата = Результаты.Выбрать();

Пока ВыборкаНомерДата.Следующий() Цикл

ОбластьШапка.Параметры.НомерДокумента = ВыборкаНомерДата.Номер;
ОбластьШапка.Параметры.ДатаДокумента = ВыборкаНомерДата.Дата;
КонецЦикла;

СведенияОПокупателе = ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ОбъектыПечати.Покупатель, ОбъектыПечати.Дата);
   
ТабличныйДокумент.Вывести(ОбластьШапка);



ОбластьЗаголовок = Макет.ПолучитьОбласть("ЗаголовокТаб");
ТабличныйДокумент.Вывести(ОбластьЗаголовок);


Номер = 0;
Пока Выборка.Следующий() Цикл
Номер = Номер + 1;
ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
ОбластьСтрока.Параметры.Номер = Номер;
    ОбластьСтрока.Параметры.ТоварНаименование = Выборка.Номенклатура;
    ОбластьСтрока.Параметры.КоличествоМест = Выборка.Количество;
ОбластьСтрока.Параметры.Количество = Выборка.Количество;
ОбластьСтрока.Параметры.БазоваяЕдиницаНаименование = Выборка.ЕдиницаИзмерения;
ОбластьСтрока.Параметры.ВидУпаковки = Выборка.ЕдиницаИзмерения;
ОбластьСтрока.Параметры.ТоварКод = Выборка.Код;
ОбластьСтрока.Параметры.БазоваяЕдиницаКодПоОКЕИ = Выборка.КодПоОКЕИ;
ТабличныйДокумент.Вывести(ОбластьСтрока);
КонецЦикла;



ОбластьИтого = Макет.ПолучитьОбласть("ИтогоПоСтранице");

Результат = ЗапросДанные.Выполнить();
ВыборкаСумма = Результат.Выбрать();

СуммаИтог = 0;

Пока ВыборкаСумма.Следующий() Цикл
СуммаИтог = СуммаИтог + ВыборкаСумма.Количество;
КонецЦикла;

ОбластьИтого.Параметры.ИтогоМестНаСтранице = СуммаИтог;
ОбластьИтого.Параметры.ИтогоКоличествоНаСтранице = СуммаИтог;


ТабличныйДокумент.Вывести(ОбластьИтого);


ОбластьВсего = Макет.ПолучитьОбласть("Всего");

ОбластьВсего.Параметры.ИтогоМест = СуммаИтог;
ОбластьВсего.Параметры.ИтогоКоличество = СуммаИтог;

ТабличныйДокумент.Вывести(ОбластьВсего);

ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");

Количество = Выборка.Количество();

ОбластьПодвал.Параметры.КоличествоПорядковыхНомеровЗаписейПрописью = ЧислоПрописью(Количество, "Л = ru_RU", ",,,,,,,,0");
ОбластьПодвал.Параметры.ВсегоМестПрописью = ЧислоПрописью(СуммаИтог, "Л = ru_RU", ",,,,,,,,0");




ТабличныйДокумент.Вывести(ОбластьПодвал);


Возврат ТабличныйДокумент;
КонецФункции

Предполагаю, что для этого нужно использовать функции ОписаниеОрганизации и СведенияОбЮрФизЛице. Но у них имеются параметры - а вот как их определить, не могу взять в толк.

И второй вопрос - требуется разделить печатную форму на страницы, если кол-во данных не помещается на одной странице?


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Можно сделать так:
СведенияОбОрганизации = ФормированиеПечатныхФорм.СведенияОЮрФизЛице(Шапка.ОрганизацияПолучатель, Шапка.ДатаДокумента);
ОбластьМакетаШапка.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации);
Добавлено: 05 Апр 2013, 14:34

Шапка.ОрганизацияПолучатель - это получено из запроса по шапке документа!
Помогли, отблагодари!

Оффлайн deringpavel

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-12
  • Сайт: 
  • Профессия: Программист 8.1
СведенияОбОрганизации = ФормированиеПечатныхФорм.СведенияОЮрФизЛице(Шапка.ОрганизацияПолучатель, Шапка.ДатаДокумента);
ОбластьМакетаШапка.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации);


Переменная Шапка что собой представляет?

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Отбор по запросу, по шапке документа! я привел пример как я делал! в вашем варианте добавляете в запрос организацию вставляете в параметр!
Помогли, отблагодари!

Оффлайн deringpavel

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-12
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо, уже понял)
Добавлено: 07 Апр 2013, 08:50

Еще вопрос: как можно грамотно реализовать функцию ПроверитьВывод(), чтобы печатная форма делилась на страницы?


Последний раз редактировалось: deringpavel; 07 Апр 2013, 08:50. Причина: Объединение сообщений


Теги:
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4843
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7740
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9340
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 205
Последний ответ 07 Окт 2017, 19:03
от Norfolk
В чем отличие регистра сведений от регистра накопления?

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 486
Последний ответ 11 Сен 2017, 10:50
от ilyay

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 836
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal