Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 08:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обновление подвала в РТУ  (Прочитано 1642 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Бухгалтерия для украины 8.2
Помогите плз не обновляеться подвал при таком коде в РТУ


Скидка по контрагентам
Справочник.Контрагенты
новый реквезит «СкидкаПоКонтрагенту»
Тип – Строка       Длина – 4
ФормаЭлемента – Новое поле ввода «Скидка»
Процедура ПриОткрытии()
Если НЕ РольДоступна("Просмотр")
Тогда ЭлементыФормы.Скидка.РедактированиеТекста = ТолькоПросмотр=Истина
КонецЕсли;
Документы.РеализацияТоваровУслуг
Новый реквизит «Скидка»
Тип – Строка       Длина – 4
ТабличныеЧасти.Товары  реквезит «СуммаСкидки»
Тип – Число       Длина – 6 Точность - 2
ФормаДокумента – Новое поле ввода данные -«Скидка»
Процедура ПриОткрытии()

Скидка = Контрагент.СкидкаПоКонтрагенту;
Процедура ОбновлениеОтображения()
Тогда Скидка = Контрагент.СкидкаПоКонтрагенту;
Процедура КонтрагентПриИзменении(Элемент)
ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;

Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока)

ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;

ЭлементыФормы.Товары.ТекущиеДанные.Сумма =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки-ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки);
Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;
ЭлементыФормы.Товары.ТекущиеДанные.Сумма =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки-ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки);

Процедура ТоварыНоменклатураПриИзменении(Элемент)
ЭлементыФормы.Товары.ТекущаяСтрока.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;

ЭлементыФормы.Товары.ТекущиеДанные.Сумма =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки-ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки);
Процедура ТоварыЦенаПриИзменении(Элемент)

Если ЭлементыФормы.Товары.ТекущиеДанные.Цена >=0
Тогда ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;
КонецЕсли;

Если ЭлементыФормы.Товары.ТекущиеДанные.Цена >=0
Тогда ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки= (ЭлементыФормы.Товары.ТекущиеДанные.Количество * ЭлементыФормы.Товары.ТекущиеДанные.Цена)
КонецЕсли;

УБРАТЬ
Процедура ТоварыСкидкаПриИзменении(Элемент)

// Выполнить общие действия для всех документов при изменении Суммы.
ОбработкаТабличныхЧастей.ПриИзмененииСкидкиТабЧасти(ЭлементыФормы.Товары.ТекущиеДанные, ЭтотОбъект);
// Рассчитать реквизиты табличной части.
ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(ЭлементыФормы.Товары.ТекущиеДанные, ЭтотОбъект);
КонецПроцедуры
Процедура ТоварыСуммаСкидкиНачалоВыбора(Элемент, СтандартнаяОбработка)

ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки = (ЭлементыФормы.Товары.СуммаБезскидки/100)*Скидка
КонецПроцедуры 


ПРИСВОЕНИЕ МЕНЕДЖЕРА КОНТРАГЕНТУ
Справочник.Контрагенты
новый реквезит «Менеджер»
Тип – СправочникСсылка.СотрудникиОрганизаций
ФормаЭлемента – Новое поле ввода «Менеджер»
Процедура ПриОткрытии()
Если НЕ РольДоступна("Просмотр")
Тогда ЭлементыФормы.Менеджер.ТолькоПросмотр = ИСТИНА
КонецЕсли;

Документы.РеализацияТоваровУслуг
Форма Документа
Новый реквизит «Менеджер»
Тип – Строка      Неограниченная длина

Процедура ПриОткрытии()

Менеджер = Контрагент.Менеджер;
Процедура ОбновлениеОтображения()

Менеджер = Контрагент.Менеджер;
Форма Списка
Новая Колонка «Менеджер»
Данные – Менеджер       Элемент Управления – Поле ввода
События ПриИзминении
Процедура ДокументСписокМенеджерПриИзменении(Элемент)
ЭлементыФормы.ДокументСписок.ОбновитьСтроки();
КонецПроцедуры
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Менеджер = Метаданные.Документы.РеализацияТоваровУслуг.Реквизиты.Менеджер.ЗначениеЗаполнения;



Теги:
 

Как правильно настроить регламентные "Обновление индекса ППД" и "Слияние индекса ППД"

Автор bkmz_1_Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4382
Последний ответ 13 Окт 2016, 09:14
от MuI_I_Ika
Обновление конфигурации "Аренда и управление недвижимостью для "1С:Бухгалтерия 8"" с 2.0 на 3.0

Автор Эльвина МуромцеваРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 237
Последний ответ 16 Ноя 2017, 14:26
от Геннадий ОбьГЭС
Обновление "Бухгалтерия автономного учреждения"

Автор LyudaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1882
Последний ответ 01 Апр 2014, 11:00
от Lyuda
Обновление. не удаляет "ненужные" модули

Автор vitaswРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1239
Последний ответ 02 Июн 2016, 11:44
от Rasty
Создание/обновление документа на основании другого документа

Автор РиммаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 396
Последний ответ 28 Авг 2017, 16:02
от Vladimkir

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
135 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 405
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal