Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 11:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя печатная форма.  (Прочитано 7054 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Онлайн ls600

  • ****
  • Сообщений: 327
  • РЕПУТАЦИЯ: 21
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С

Доброго времени суток. Делаю внешнюю печатную форму для документа "Доверенность." в коде синтаксических ошибок нет. но при печати выскакивает такое сообщение:

Не удалось сформировать внешнюю печатную форму!
Ошибка при вызове метода контекста (ПолучитьМакет): Недопустимое значение параметра (параметр номер '1')


В чем дело понять не могу???? Подскажите.
Конфигурация Бухгалтерия Для Казахстана 8.2



Функция Печать() Экспорт


Запрос = Новый Запрос();
Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
Запрос.Текст =
"ВЫБРАТЬ
| Доверенность.Номер КАК НомерДокумента,
| Доверенность.Дата КАК ДатаДокумента,
| Доверенность.СтруктурнаяЕдиница КАК БанковскийСчет,
| Доверенность.Организация,
|   Доверенность.СтруктурноеПодразделение,
| Доверенность.ФизЛицо,
| Доверенность.ФизЛицо.Наименование КАК ФамилияИмяОчествоДоверенного,
| Доверенность.Контрагент КАК Поставщик,
| ВЫРАЗИТЬ(Доверенность.НаПолучениеОт КАК СТРОКА(1000)) КАК ПоставщикПредставление,
| Доверенность.ДатаДействия КАК СрокДействия,
| ВЫРАЗИТЬ(Доверенность.ПоДокументу КАК СТРОКА(1000)) КАК РеквизитыДокументаНаПолучение
|ИЗ
| Документ.Доверенность КАК Доверенность
|ГДЕ
| Доверенность.Ссылка = &ТекущийДокумент";
Шапка = Запрос.Выполнить().Выбрать();
Шапка.Следующий();

//запрос по товарам
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
Запрос.Текст = "ВЫБРАТЬ
               | Доверенность.НомерСтроки КАК Номер,
               | Доверенность.НаименованиеТовара КАК Ценнности,
               | Доверенность.НаименованиеТовара КАК ЦеннностиПредставление,
               | Доверенность.ЕдиницаПоКлассификатору КАК ЕдиницаИзмерения,
               | Доверенность.ЕдиницаПоКлассификатору.Представление КАК ЕдиницаИзмеренияПредставление,
               | Доверенность.Количество
               |ИЗ
               | Документ.Доверенность.Товары КАК Доверенность
               |ГДЕ
               | Доверенность.Ссылка = &ТекущийДокумент
               |
               |УПОРЯДОЧИТЬ ПО
               | Номер";
   
ВыборкаСтрокТовары = Запрос.Выполнить().Выбрать();


СтруктурнаяЕдиницаОрганизация = ОбщегоНазначения.ПолучитьСтруктурнуюЕдиницу(Шапка.Организация, Шапка.СтруктурноеПодразделение);

ТабДокумент = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Доверенность_Д1";


Макет = ПолучитьМакет("Д1");


ДанныеОФизЛице = ПроцедурыУправленияПерсоналом.ДанныеФизЛица(СсылкаНаОбъект.Организация, СсылкаНаОбъект.ФизЛицо, СсылкаНаОбъект.Дата);

ФамилияИмяОчествоДоверенного = ""+ДанныеОФизЛице.Фамилия +" "+ ДанныеОФизЛице.Имя +" "+ ДанныеОФизЛице.Отчество;
Должность                    = СокрЛП(ДанныеОФизЛице.Должность);
    СтруктураФИО = Новый Структура();
СтруктураФИО.Вставить("Фамилия", ДанныеОФизЛице.Фамилия);
СтруктураФИО.Вставить("Имя", ДанныеОФизЛице.Имя);
СтруктураФИО.Вставить("Отчество", ДанныеОФизЛице.Отчество);

Руководители = ОбщегоНазначения.ОтветственныеЛицаОрганизаций(СтруктурнаяЕдиницаОрганизация, СсылкаНаОбъект.Дата);
Руководитель = Руководители.Руководитель;
Бухгалтер    = Руководители.ГлавныйБухгалтер;

СведенияОбОрганизации = ОбщегоНазначения.СведенияОЮрФизЛице(СтруктурнаяЕдиницаОрганизация, Шапка.ДатаДокумента, , Шапка.БанковскийСчет);
ПредставлениеОрганизации = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "ПолноеНаименование,");

ОбластьМакета = Макет.ПолучитьОбласть("Отрез");
ОбластьМакета.Параметры.Заполнить(Шапка);
ОбластьМакета.Параметры.ФИОДоверенного = "" + ?(ПустаяСтрока(Должность), "", Должность + ", ") + (ФамилияИмяОчествоДоверенного);

//найдем документ, выполнящий поручение
     СписокЗаполнения = ОбщегоНазначения.ПолучитьСписокВводимыхДокументовНаОсновании(ЭтотОбъект.Метаданные());
Для Каждого Элемент Из СписокЗаполнения Цикл
НайденыйДокумент = ОбщегоНазначения.НайтиПодчиненныйДокумент(СсылкаНаОбъект.Ссылка,Элемент.Значение);
Если НайденыйДокумент = Неопределено Тогда
Продолжить;
Иначе
ОбластьМакета.Параметры.ДокументИсполнения = НайденыйДокумент;
Прервать;
КонецЕсли;
КонецЦикла;
ТабДокумент.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
ОбластьМакета.Параметры.Заполнить(Шапка);
ОбластьМакета.Параметры.ПредставлениеОрганизации = ПредставлениеОрганизации;
ОбластьМакета.Параметры.НомерДокумента           = ОбщегоНазначения.ПолучитьНомерНаПечать(СсылкаНаОбъект, глСписокПрефиксовУзлов);
ОбластьМакета.Параметры.СрокДействия             = Формат(Шапка.СрокДействия,"Л=ru_RU; ДЛФ=DD");
ОбластьМакета.Параметры.ДатаВыдачи               = Формат(Шапка.ДатаДокумента,"Л=ru_RU; ДЛФ=DD");
РеквизитыСчета = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "НомерСчета,Банк,БИК,");
Позиция = Найти(РеквизитыСчета, " в банке ");
НаименованиеБанка_                               = Сред(РеквизитыСчета, Позиция + 9, СтрДлина(РеквизитыСчета));
ОбластьМакета.Параметры.НаименованиеБанка        = НаименованиеБанка_;
НомерСчета_                                      = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "НомерСчета,");
ОбластьМакета.Параметры.НомерСчета               = НомерСчета_;

ОбластьМакета.Параметры.ОрганизацияРНН_БИН   = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "БИН_ИИН,", Ложь, Шапка.ДатаДокумента, "ru");
ОбластьМакета.Параметры.РеквизитыПотребителя        = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "ПолноеНаименование,БИН_ИИН,ЮридическийАдрес,", , Шапка.ДатаДокумента, "ru");
ОбластьМакета.Параметры.РеквизитыПлательщика        = ОбщегоНазначения.ОписаниеОрганизации(СведенияОбОрганизации, "ПолноеНаименование,БИН_ИИН,ЮридическийАдрес,", , Шапка.ДатаДокумента, "ru");
ОбластьМакета.Параметры.ПаспортСерия                = ДанныеОФизЛице.ДокументСерия;
ОбластьМакета.Параметры.ПаспортНомер                = ДанныеОФизЛице.ДокументНомер;
ОбластьМакета.Параметры.ПаспортВыдан                = ДанныеОФизЛице.ДокументКемВыдан;
ОбластьМакета.Параметры.ПаспортДатаВыдачи          = Формат(ДанныеОФизЛице.ДокументДатаВыдачи,"ДФ=dd.MM.yyyy") ;
ОбластьМакета.Параметры.РеквизитыДокументаНаПолучение = СокрЛП(Шапка.РеквизитыДокументаНаПолучение);
ОбластьМакета.Параметры.ПоставщикПредставление      = СокрЛП(Шапка.ПоставщикПредставление);

Если  Не СсылкаНаОбъект.ФИзЛицо.Пустая() Тогда
ОбластьМакета.Параметры.ФамилияИмяОчествоДоверенного = ОбщегоНазначения.ПреобразоватьФИОВДательныйПадеж(СтруктураФИО, ДанныеОФизЛице.НеСклонятьФамилию);
ОбластьМакета.Параметры.ДолжностьДоверенного      = Должность;
КонецЕсли;

ТабДокумент.Вывести(ОбластьМакета);


ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
ТабДокумент.Вывести(ОбластьМакета);


ОбластьМакета = Макет.ПолучитьОбласть("Строка");


Пока ВыборкаСтрокТовары.Следующий() Цикл


ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);
Если ТипЗнч(ВыборкаСтрокТовары.ЦеннностиПредставление) = Тип("Строка") Тогда
ЦеннностиПредставление = ВыборкаСтрокТовары.ЦеннностиПредставление;
Иначе
ЦеннностиПредставление = ВыборкаСтрокТовары.ЦеннностиПредставление.НаименованиеПолное;
КонецЕсли;

ОбластьМакета.Параметры.ЦеннностиПредставление = ЦеннностиПредставление;

ОбластьМакета.Параметры.КоличествоПрописью = "";

Если ВыборкаСтрокТовары.Количество <> 0 Тогда
ОбластьМакета.Параметры.КоличествоПрописью = Строка(ВыборкаСтрокТовары.Количество) + " (" +
СокрЛП(КоличествоПрописью(ВыборкаСтрокТовары.Количество)) + ")";
                                           
КонецЕсли;

ТабДокумент.Вывести(ОбластьМакета);


КонецЦикла;

Руководители = ОбщегоНазначения.ОтветственныеЛицаОрганизаций(СтруктурнаяЕдиницаОрганизация, СсылкаНаОбъект.Дата);
Руководитель = Руководители.Руководитель;

ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
ОбластьМакета.Параметры.Заполнить(Шапка);

Если ЗначениеЗаполнено(Руководитель) Или Руководитель <> Неопределено Тогда
ОбластьМакета.Параметры.Руководитель     = СокрЛП(Руководитель);
КонецЕсли;

ТабДокумент.Вывести(ОбластьМакета);


Возврат ТабДокумент;


КонецФункции


Онлайн ls600

  • ****
  • Сообщений: 327
  • РЕПУТАЦИЯ: 21
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Наконец разобрался в чем проблема была и ошибка, в Окне регистрации печатных форм был указан файл который не относился к этому отчету, эту строку удалил и новую добавил. все заработало. :D

Оффлайн mam66

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-17
  • Сайт: 
  • Профессия: Бухгалтер
Наконец разобрался в чем проблема была и ошибка, в Окне регистрации печатных форм был указан файл который не относился к этому отчету, эту строку удалил и новую добавил. все заработало. :D
подскажи что надо поправить

Онлайн ls600

  • ****
  • Сообщений: 327
  • РЕПУТАЦИЯ: 21
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
в окне регистрации удаляешь строку в табличной части и заново прикрепляешь внешнюю печатную форму к документу.


Теги:
 

УТ 11.3 форма "УправлениеЭквайринговымТерминалом"

Автор skelaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 238
Последний ответ 09 Фев 2018, 21:23
от Геннадий ОбьГЭС
Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5541
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94
Вопрос по УНФ (форма "Задание на работу")

Автор tantonyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 623
Последний ответ 22 Июн 2017, 18:22
от tantony
Как программно вызывать обработчик ПриИзменении поля табличной части после того, как форма была заполнена программно?

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5483
Последний ответ 27 Июл 2015, 06:21
от cska-fanat-kz
Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7880
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
30 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal