Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 17:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как добавить новое условие?  (Прочитано 1865 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GoldMen

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-10
  • Сайт: 
  • Профессия: Программист 8.1

Как добавить в модуль условие "Если толщина (c) 0.5мм <равно 2мм, то допуск (d) = 10 мм, 2 < c < равно 5, то d=16, 5 < c < равно 10, то d=20"
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
   СтрокаТабличнойЧасти.Размер = ((СтрокаТабличнойЧасти.Длина + СтрокаТабличнойЧасти.Допуск) * (СтрокаТабличнойЧасти.Ширина + СтрокаТабличнойЧасти.Допуск)) / 1000000;
КонецПроцедуры





Оффлайн greenLiss

  • Приятно осознавать, что я кому-то нужен и за мной наблюдают (тем более, админы) XD
  • ***
  • Сообщений: 104
  • РЕПУТАЦИЯ: 8
  • КПД: 8%
  • Регистрация: 2012-12-04
  • Сайт: 
Эм.... ничего не понял, но если я правильно не понял, то...

Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
Если СтрокаТабличнойЧасти.Толщина <= 2 Тогда
СтрокаТабличнойЧасти.Допуск = 10;
ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 2) И (СтрокаТабличнойЧасти.Толщина <= 5) Тогда
СтрокаТабличнойЧасти.Допуск = 16;
ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 5) И (СтрокаТабличнойЧасти.Толщина <= 10) Тогда
СтрокаТабличнойЧасти.Допуск = 20;
Иначе
Сообщить("толщина больше 10 мм");
Возврат;
КонецЕсли;
СтрокаТабличнойЧасти.Размер = ((СтрокаТабличнойЧасти.Длина + СтрокаТабличнойЧасти.Допуск) * (СтрокаТабличнойЧасти.Ширина + СтрокаТабличнойЧасти.Допуск)) / 1000000;
КонецПроцедуры

   
только, куда 0.5мм ?
короче, я ничего не понял и написал бред сумасшедшего :D
   

Оффлайн GoldMen

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-10
  • Сайт: 
  • Профессия: Программист 8.1
Эм.... ничего не понял, но если я правильно не понял, то...

Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
Если СтрокаТабличнойЧасти.Толщина <= 2 Тогда
СтрокаТабличнойЧасти.Допуск = 10;
ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 2) И (СтрокаТабличнойЧасти.Толщина <= 5) Тогда
СтрокаТабличнойЧасти.Допуск = 16;
ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 5) И (СтрокаТабличнойЧасти.Толщина <= 10) Тогда
СтрокаТабличнойЧасти.Допуск = 20;
Иначе
Сообщить("толщина больше 10 мм");
Возврат;
КонецЕсли;
СтрокаТабличнойЧасти.Размер = ((СтрокаТабличнойЧасти.Длина + СтрокаТабличнойЧасти.Допуск) * (СтрокаТабличнойЧасти.Ширина + СтрокаТабличнойЧасти.Допуск)) / 1000000;
КонецПроцедуры

   
только, куда 0.5мм ?
короче, я ничего не понял и написал бред сумасшедшего :D
   
Посмотрю. Толщина от 0.5 до 2 мм, допуск = 10.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 579
  • Точка Скрытых: 1
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal