Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 20:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как добавить новое условие?  (Прочитано 2064 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GoldMen

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-10
  • Сайт: 
  • Профессия: Программист 8.1

Как добавить в модуль условие "Если толщина (c) 0.5мм <равно 2мм, то допуск (d) = 10 мм, 2 < c < равно 5, то d=16, 5 < c < равно 10, то d=20"
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
   СтрокаТабличнойЧасти.Размер = ((СтрокаТабличнойЧасти.Длина + СтрокаТабличнойЧасти.Допуск) * (СтрокаТабличнойЧасти.Ширина + СтрокаТабличнойЧасти.Допуск)) / 1000000;
КонецПроцедуры





Оффлайн greenLiss

  • Приятно осознавать, что я кому-то нужен и за мной наблюдают (тем более, админы) XD
  • ***
  • Сообщений: 104
  • РЕПУТАЦИЯ: 8
  • КПД: 8%
  • Регистрация: 2012-12-04
  • Сайт: 
Эм.... ничего не понял, но если я правильно не понял, то...

Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
Если СтрокаТабличнойЧасти.Толщина <= 2 Тогда
СтрокаТабличнойЧасти.Допуск = 10;
ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 2) И (СтрокаТабличнойЧасти.Толщина <= 5) Тогда
СтрокаТабличнойЧасти.Допуск = 16;
ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 5) И (СтрокаТабличнойЧасти.Толщина <= 10) Тогда
СтрокаТабличнойЧасти.Допуск = 20;
Иначе
Сообщить("толщина больше 10 мм");
Возврат;
КонецЕсли;
СтрокаТабличнойЧасти.Размер = ((СтрокаТабличнойЧасти.Длина + СтрокаТабличнойЧасти.Допуск) * (СтрокаТабличнойЧасти.Ширина + СтрокаТабличнойЧасти.Допуск)) / 1000000;
КонецПроцедуры

   
только, куда 0.5мм ?
короче, я ничего не понял и написал бред сумасшедшего :D
   

Оффлайн GoldMen

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-10
  • Сайт: 
  • Профессия: Программист 8.1
Эм.... ничего не понял, но если я правильно не понял, то...

Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
Если СтрокаТабличнойЧасти.Толщина <= 2 Тогда
СтрокаТабличнойЧасти.Допуск = 10;
ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 2) И (СтрокаТабличнойЧасти.Толщина <= 5) Тогда
СтрокаТабличнойЧасти.Допуск = 16;
ИначеЕсли (СтрокаТабличнойЧасти.Толщина > 5) И (СтрокаТабличнойЧасти.Толщина <= 10) Тогда
СтрокаТабличнойЧасти.Допуск = 20;
Иначе
Сообщить("толщина больше 10 мм");
Возврат;
КонецЕсли;
СтрокаТабличнойЧасти.Размер = ((СтрокаТабличнойЧасти.Длина + СтрокаТабличнойЧасти.Допуск) * (СтрокаТабличнойЧасти.Ширина + СтрокаТабличнойЧасти.Допуск)) / 1000000;
КонецПроцедуры

   
только, куда 0.5мм ?
короче, я ничего не понял и написал бред сумасшедшего :D
   
Посмотрю. Толщина от 0.5 до 2 мм, допуск = 10.


Теги:
 

Добавить поле "Свойство" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 311
Последний ответ 24 Фев 2018, 14:40
от useronforum
Добавить поле "Комментарий" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 271
Последний ответ 03 Мар 2018, 16:14
от useronforum
Как добавить столбец "Номенклатура" в таблицу "Реализация товаров и услуг"

Автор ZanderBlackРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 10906
Последний ответ 19 Ноя 2012, 11:12
от Gunner
Не активны кнопки "Добавить" и "Удалить" дополнительные строки в отчете по НДС

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 316
Последний ответ 25 Янв 2018, 14:50
от kiksi
Документ "Поступление товаров и услуг" - как добавить графу "единица измерения"

Автор asolРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6558
Последний ответ 29 Мар 2012, 14:40
от Essential

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
58 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 207
  • Точка Скрытых: 1
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal