Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 03:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как вводить реквизиты документа по умолчанию  (Прочитано 4172 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Bahrom

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-17
  • Сайт: 
  • Профессия: Разработчик 1С
Как вводить реквизиты документа по умолчанию? В модуле документа подписка на событие ПриУстановкеНовогоНомера. Создаю новый документ, на ворме появляется Плательшик, но не поялется расчетный счет,   Сообщить(счет); выводить номер счета . Никаких ошибок. Что нитак я сделал?


Процедура ПриУстановкеНовогоНомера(СтандартнаяОбработка, Префикс)
   
   Если ЭтоНовый() Тогда
      
      Плательшик=Константы.Организация.Получить();
      
      выборка=Справочники.РасчетныеСчета.Выбрать(Неопределено, Плательшик);
      
      Если выборка.Следующий() Тогда
         
         счет= выборка.ПолучитьОбъект();
         
         СчетПлательщика=счет;
         
         Сообщить(счет);
         
      КонецЕсли;
      
   КонецЕсли;
   
КонецПроцедуры


Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
А у СчетПлательщика и счет типы одинаковые? по-моему, "счет" будет типом СправочникОбъект, а не СправочникСсылка

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Попробуй так
выборка=Справочники.РасчетныеСчета.Выбрать(, Плательшик);
или так
выборка=Справочники.РасчетныеСчета.Выбрать(Справочники.РасчетныеСчета.ПустаяСсылка(), Плательшик);
Так же имеет смысл проверить , есть ли у данного плательщика расчетные счета

Оффлайн Bahrom

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-17
  • Сайт: 
  • Профессия: Разработчик 1С
выборка=Справочники.РасчетныеСчета.Выбрать(Неопределено, Плательшик); работает

Сообщить(счет); дает правилное сообщение.



Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Посмотрите какой тип у реквизита документа! Если это ссылка на справочник то вам и надо присваивать ссылку! Скорее всего Расчетный счет у вас имеет справочник владельца Контрагенты! А чтобы не гадать, то скажите, что за документ и конфигурация какая!
Добавлено: 22 Мар 2013, 10:08

СчетПлательщика = Счет.Ссылка;
попробуйте!
Помогли, отблагодари!

Оффлайн Bahrom

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-17
  • Сайт: 
  • Профессия: Разработчик 1С
Спасибо, помогло

написал так

счет= выборка.Ссылка;

все работает


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4481
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15950
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4203
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 639
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7752
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 128
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal