Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 11:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Приходная Накладная  (Прочитано 4658 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Кирюха

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-17
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.

Делаю Проведение Документа РасходнаяНакладная на основе регистра накопления ОстаткиНоменклатуры.

При записи, возникает ошибка

Ошибка при выполнении обработчика - '{Документ.РасходнаяНакладная(36)}: Ошибка при вызове метода контекста (Остатки): Недопустимое значение параметра (параметр номер '2')'
по причине:
{Документ.РасходнаяНакладная(36)}: Ошибка при вызове метода контекста (Остатки): Недопустимое значение параметра (параметр номер '2')

по причине:
Недопустимое значение параметра (параметр номер '2')

Модуль обьекта таков:

Процедура ОбработкаПроведения(Отказ, Режим)
//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
ОстаткиТовара=РегистрыНакопления.ОстаткиНоменклатуры;
Для Каждого ТекСтрокаМатериалы Из Материалы Цикл
ТекТовар=ТекСтрокаМатериалы.Материал;
ТекСклад=Склад;
ФильтрТовара=Новый Структура();
ФильтрТовара.Вставить("Материал",ТекТовар);
ФильтрТовара.Вставить("Склад",ТекСклад);
ТаблицаОстатков=ОстаткиТовара.Остатки(МоментВремени(),ФильтрТовара,"Материал","Количество");
Остатки=ТаблицаОстатков.Итог("Количество");
Если Остатки>=ТекСтрокаМатериалы.Количество Тогда
// регистр ОстаткиНоменклатуры Расход
Движение = Движения.ОстаткиНоменклатуры.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаМатериалы.Материал;
Движение.Склад = Склад;
Движение.Количество = ТекСтрокаМатериалы.Количество;
Движение.Сумма = ТекСтрокаМатериалы.Себестоимость*ТекСтрокаМатериалы.Количество;
Иначе
Сообщить("На складе "+Склад.Наименование+" недостаточно товара "+ТекСтрокаМатериалы.Материал.Наименование+". Документ не проводится");
отказ = истина;
возврат;
КонецЕсли;
КонецЦикла;
Движения.ОстаткиНоменклатуры.Записать();
//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

Подскажите пожалуйста, где ошибка?


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
ТаблицаОстатков=ОстаткиТовара.Остатки(МоментВремени(),ФильтрТовара,"Материал","Количество");
явно ругается на эту строку, а елси хоите сделать контроль оставткв, то это необходимо делать с помощью запроса см. тему http://forum-1c.ru/index.php?topic=27187.0



Теги:
 

УПП и "требование-накладная"

Автор boobzxРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2019
Последний ответ 24 Апр 2014, 20:16
от boobzx
Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 206
Последний ответ 07 Окт 2017, 19:03
от Norfolk
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4100
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Добавление к "Товары, накладная" транспортных услуг.

Автор Владимир ЦыбинРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 272
Последний ответ 24 Июн 2017, 12:37
от oleg-x
Поле "ИФО" в документах требование-накладная и акт списания материалов

Автор LamiaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1367
Последний ответ 13 Фев 2016, 19:06
от KatiaP

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
181 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 1023
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal