Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 17:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Преобразование значения к типу Число не может быть выполнено  (Прочитано 3397 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fitilj

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-18
  • Сайт: 
  • Профессия: Ученик 1С
добрый день . нужна помащь не получаеться округление выводит сообщение - Преобразование значения к типу Число не может быть выполнено   что не так подскажите


Процедура КоманднаяПанельТоварыИзменитьЗаГрам(Кнопка)
   
   ФормаВводаЗаГрам = ПолучитьФорму("ВводЦеныЗаГрам",ЭтаФорма);
   
   Если ТипЗнч(ПараметрыНаценки) = Тип("Структура") Тогда
      
      Для каждого КлючИЗначение Из ПараметрыНаценки цикл
         
         ФормаВводаЗаГрам[КлючИЗначение.Ключ] = КлючИЗначение.Значение;   
         
      КонецЦикла;   
      
   КонецЕсли;   

   ПараметрыНаценки = ФормаВводаЗаГрам.ОткрытьМодально();
   
   Если ТипЗнч(ПараметрыНаценки) = Тип("Структура") Тогда
        
      МассивПодарочныхСертификатов = ПолучитьМассивНоменклатурыПодарочныхСертификатов();
      Для каждого СтрокаТоваров Из Товары Цикл
         
         Если СтрокаТоваров.Пометка
            И МассивПодарочныхСертификатов.Найти(СтрокаТоваров.Номенклатура) = Неопределено Тогда
            
            //СтрокаТоваров.Цена = СтрокаТоваров.вес*ПараметрыНаценки.Цена;
            Если ЗначениеЗаполнено(ПараметрыНаценки.Округление) Тогда
         
         ЗначениеОкругления = Число(Строка(ПараметрыНаценки.Округление));
   
         
         Цена = Окр(Цена/ЗначениеОкругления,РежимОкругления.Окр15как20);
                           
      КонецЕсли;
           СтрокаТоваров.Цена = СтрокаТоваров.вес*ПараметрыНаценки.Цена;
            
         КонецЕсли;
         
      КонецЦикла;   
      
            
   КонецЕсли;   
   
КонецПроцедуры


Оффлайн Санчес

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-03-11
  • Сайт: 
  • Профессия: Разработчик 1С


Теги:
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 293
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 990
Последний ответ 11 Июл 2016, 09:00
от vitasw
Как сложить значения Столбца "Объем"

Автор anton.kislovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 13582
Последний ответ 04 Май 2017, 10:48
от ospov11789
Ошибка "Итератор для значения не определён"

Автор КараулРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 851
Последний ответ 17 Авг 2016, 11:25
от Караул
Очистить значение типа "Хранилище значения"

Автор ЛеонидРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4736
Последний ответ 22 Ноя 2009, 17:45
от Никитина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
59 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 313
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal