Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Ноя 2018, 02:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Среда. Вопрос 7  (Прочитано 28821 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн techh

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-11
  • Сайт: 
  • Профессия: Программист 1С
Re: Среда. Вопрос 7
« Ответ #10: 13 Мар 2013, 12:33 »
Скачать ОбработкаДляForum1C.epf с WebFile.RU

&НаКлиенте
Функция РазложитьСтрокуПосимвольно(Стр)

Список = Новый СписокЗначений;

ДлинаСтроки = СтрДлина(Стр);
Для К = 1 По ДлинаСтроки Цикл
ТекСимвол = Сред(Стр, К, 1);
Список.Добавить(ТекСимвол);
КонецЦикла;

Возврат Список;

КонецФункции

&НаКлиенте
Функция СобратьСтрокуИзСимволов(Список)

Стр = "";

ДлинаСписка = Список.Количество();
Для К = 0 По ДлинаСписка - 1 Цикл
//ТекЦифра = Список[ДлинаСписка-К-1];
ТекЦифра = Список[К];
Стр = Стр + ТекЦифра;
КонецЦикла;

Возврат Стр;

КонецФункции

&НаКлиенте
Процедура НайтиОшибку(Команда)

// проверим, возможно, бухгалтер обсчитался, и сумма слагаемых совпадает с подотчётной
СуммаСлагаемых = Объект.Слагаемые.Итог("Слагаемое");
Если СуммаСлагаемых = Объект.СуммаОтчета Тогда
Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = "Ошибка отсутсвует."; 
Сообщение.Сообщить();
Возврат;
КонецЕсли;

НашлиОшибку = Ложь;
ТекСтрока = 0;
Для Каждого ТекСтр Из Объект.Слагаемые Цикл
ТекСтрока = ТекСтрока + 1;

ТекСлагаемое = ТекСтр.Слагаемое;
СуммаБезТекущегоСлагаемого = СуммаСлагаемых - ТекСлагаемое;

СтрСлагаемое = Строка(ТекСлагаемое);
СтрСлагаемое = СтрЗаменить(СтрСлагаемое, Символы.НПП, "");

ДлинаСлагаемого = СтрДлина(СтрСлагаемое);
Если ДлинаСлагаемого > 1 Тогда   // цифры слагаемого можно переставлять, если в слагаемом их хотя бы две
Цифры = РазложитьСтрокуПосимвольно(СтрСлагаемое);

Для К = 0 По ДлинаСлагаемого-2 Цикл
Инд = ДлинаСлагаемого-1-К;

Цифра = Цифры[Инд].Значение;
Если (Цифра = "0") И (К = ДлинаСлагаемого - 2) Тогда
Продолжить;
КонецЕсли;

НовЦифры = Цифры.Скопировать();
НовЦифры.Сдвинуть(Инд, -1);

СтрНовСлагаемое = СобратьСтрокуИзСимволов(НовЦифры);

НовСлагаемое = Число(СтрНовСлагаемое);
НовСумма = СуммаБезТекущегоСлагаемого + НовСлагаемое;
Если НовСумма = Объект.СуммаОтчета Тогда
НашлиОшибку = Истина;
Прервать;
КонецЕсли;
КонецЦикла;

КонецЕсли;

Если НашлиОшибку Тогда
Прервать;
КонецЕсли;
КонецЦикла;

Сообщение = Новый СообщениеПользователю;
Если НашлиОшибку Тогда
Сообщение.Текст = "Ошибка находится в строке " + ТекСтрока + ". Правильное значение: " + НовСлагаемое;
Иначе
Сообщение.Текст = "Ошибка не найдена."
КонецЕсли;
Сообщение.Сообщить();

КонецПроцедуры


Оффлайн Alex_k

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-14
  • Сайт: 

Оффлайн michael2k

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-13
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Среда. Вопрос 7
« Ответ #12: 13 Мар 2013, 13:16 »
Вот, в формате 8.2 в режиме обычного приложения.

Оффлайн Alex_k

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-14
  • Сайт: 
Re: Среда. Вопрос 7
« Ответ #13: 13 Мар 2013, 13:18 »
Сюда еще...

Оффлайн Санчес

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-03-11
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Среда. Вопрос 7
« Ответ #14: 13 Мар 2013, 13:26 »
Файл обработки во вложении.
Версия платформы: 8.2

Оффлайн Evga

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Среда. Вопрос 7
« Ответ #15: 13 Мар 2013, 14:24 »
прикрепляю обработку

Оффлайн iPach89

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-16
  • Сайт: 
  • Профессия: Программист 8.1
Re: Среда. Вопрос 7
« Ответ #16: 13 Мар 2013, 14:55 »
Конечно на коленке сделанная, но чтото :)
http://rusfolder.com/35447573

Оффлайн mzelensky

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-28
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Среда. Вопрос 7
« Ответ #17: 13 Мар 2013, 15:24 »
Обработка во вложении. Платформа 8.2.16.362

Оффлайн Evgeny

  • *
  • Сообщений: 46
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Среда. Вопрос 7
« Ответ #18: 13 Мар 2013, 15:49 »
http://yadi.sk/d/sqXJkekM3FsBL   обработка лежит на яндекс диске
О_о Кто здесь?

Оффлайн AAlexandra

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-28
  • Сайт: 
  • Профессия: Программист 1С
Re: Среда. Вопрос 7
« Ответ #19: 13 Мар 2013, 16:05 »
8.2, Управляемые формы.


Теги:
 


* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
wise wise
50 Сообщений
alexandr_ll
45 Сообщений
alex0402
44 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
38 Сообщений
BuhRust
28 Сообщений
andron81_81
24 Сообщений
byte777
21 Сообщений
LexaK
21 Сообщений

* Кто онлайн

  • Точка Гостей: 128
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal