Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос новичка  (Прочитано 2386 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн H0mRk

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-18
  • Сайт: 
  • Профессия: Ученик 1С
Есть форма, в ней таблица, подключил туда Итоги, все как и положено, Итоги считают сумму в таблице, но мне нужно еще добавить туда СуммуСНДС и формы, вот код и он не работает:
&НаКлиенте
Процедура Итоги()
    Стр = Элементы.Договора.ТекущиеДанные;
    Для Каждого Стр Из Объект.Договора Цикл
            Стр.ИтогСуммаСНДС = Объект.СуммаСНДС + Стр.СуммаСНДС;
            Стр.ИтогСуммаБезНДС = Объект.СуммаБезНДС + Стр.СуммаБезНДС;
    Если    Стр.Корректировка Тогда
            Объект.Договора.ИтогСуммаСНДС = 0;
            Объект.Договора.ИтогСуммаБезНДС = 0;
        КонецЕсли;
    КонецЦикла;
      КонецПроцедуры

При входе в форму, выдает ошибку:
Поле объекта не обнаружено (ИтогСуммаСНДС)

Уже по разному перепробовал, ничего понять не могу, почему не работает.


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Вопрос новичка
« Ответ #1: 12 Мар 2013, 12:52 »
А чем у вас является ИтогСуммаСНДС?

Оффлайн H0mRk

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-18
  • Сайт: 
  • Профессия: Ученик 1С
Re: Вопрос новичка
« Ответ #2: 12 Мар 2013, 13:23 »
Сумма сумм в строках таблицы.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Вопрос новичка
« Ответ #3: 12 Мар 2013, 13:33 »
Непонятно. Судя по вашему коду это реквизит табличной части Договора:

Стр.ИтогСуммаСНДС

Оффлайн H0mRk

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-18
  • Сайт: 
  • Профессия: Ученик 1С
Re: Вопрос новичка
« Ответ #4: 12 Мар 2013, 13:45 »
Я решил что будет правильней так записать, так как у ИтогСуммаСНДС как у данных в таблице, например строка Предмет договора "Объект.Договора.ПредметДоговора", у ИтогСуммаСНДС путь к данным "Объект.Договора.ИтогСуммаСНДС"
Но я пробовал по разному, пробовал и "Объект.Договора.ИтогСуммаСНДС", но все равно ничего не получается.
Мне надо всего лишь, получить Итог от сумм которые указаны в таблице, это без проблем решилось без программирования средствами 1С, но я еще хотел добавить сумму основного договора из поля в форме "Объект.СуммаПоДоговору"


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9246
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5859
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3295
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3463
Последний ответ 06 Окт 2014, 15:23
от jenya1111
Вопрос по отчету "Материалы в эксплуатации".

Автор mitauskasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2374
Последний ответ 04 Мар 2015, 11:07
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
140 Сообщений
AIFrame
70 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
BuhRust
31 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 371
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal