Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Май 2018, 13:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Строки дублируются в регистрах при проведении документа  (Прочитано 3747 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mmv_89@mail.ru

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-06
  • Сайт: 
  • Профессия: Ученик 1С
Есть 2 документа: Договор залога и Закрытие договора залога. Они регистрируются в регистре накопления и регистре бухгалтерии. Договор залога проходит нормально по регистрам. А при проведении Закрытия договора залога данные выдергиваются из Договора залога и строки в регистрах дублируется, т.е. удваиваются.  В чем может быть ошибка? Процедуру привожу ниже.

Процедура ОбработкаПроведения(Отказ, РежимПроведения)

   Для Каждого ТекСтрокаОбъекты Из Состав Цикл
      Движение = Движения.Хозрасчетный.ДобавитьКредит();
      //Движение.СчетДт = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
      Движение.СчетКт = ПланыСчетов.Хозрасчетный.ОбеспеченияОбязательствВыданные;
      Сообщить(ПланыСчетов.Хозрасчетный.ОбеспеченияОбязательствВыданные);
      
      Движение.Организация = Организация;
      Сообщить(Организация);
      
      Движение.Период = Дата;
      Сообщить(ТекСтрокаОбъекты.ДоговорЗалога.Выгодоприобретатель);
      
      Движение.Сумма = ТекСтрокаОбъекты.ДоговорЗалога.СтраховаяСумма/2;
      Сообщить(ТекСтрокаОбъекты.ДоговорЗалога.СтраховаяСумма);
      
      Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Контрагенты] = ТекСтрокаОбъекты.ДоговорЗалога.СтраховаяКомпания;
      Сообщить(ТекСтрокаОбъекты.ДоговорЗалога.СтраховаяКомпания);
      
      Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Договоры] = ТекСтрокаОбъекты.ДоговорЗалога.ДоговорКонтрагента;
      Сообщить(ТекСтрокаОбъекты.ДоговорЗалога.ДоговорКонтрагента);
   КонецЦикла;
   
   
   Для Каждого ТекСтрокаСостав Из Состав Цикл
      Для Каждого ТекСтрокаОбъекты Из ТекСтрокаСостав.ДоговорЗалога.Объекты Цикл
         Движение = Движения.ОбъектыВЗалоге.Добавить();         
         Движение.Регистратор = ЭтотОбъект;
         Движение.Организация = Организация;
         Движение.Договор = ТекСтрокаСостав.ДоговорЗалога;         
         Движение.Объект = ТекСтрокаОбъекты.Объект;
         Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
         Движение.Период = Дата;
         Движение.Количество = ТекСтрокаСостав.НомерСтроки;
         Движение.Сумма = ТекСтрокаОбъекты.СтраховаяСтоимость/2;
         
      КонецЦикла;      
   КонецЦикла;
КонецПроцедуры


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А у вас регистр накопления случайно не оборотный?


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4852
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 17211
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4768
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1180
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8266
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
oleg-x
64 Сообщений
alex0402
61 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
24 Сообщений
BuhRust
21 Сообщений
alexandr_ll
20 Сообщений

* Кто онлайн

  • Точка Гостей: 822
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal