Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 20:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Позиционирование в списке.  (Прочитано 9956 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн boobzx

  • ***
  • Сообщений: 124
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2013-03-07
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Подскажите пожалуйста как с позиционироваться в списке УФ? Пример: завел справочник иерархический "Номенкалтура" там завел две группы, "Группа1" и "Группа2", далее в каждой группе сделал по 5 элементов: "Элемент1"  и т.д. Также сделал собственную кнопку "Сохранить". Принцип её работы также как и кнопка Записать и закрыть в управляемой форме при заведении нового элемента. Т.е. Если я изменил группу, То после закрытия карточки товара, товар сам перенесется в другую группу + еще с позиционируется динамический список на этой строке.  Что пробовал сделать я, создал форму элемента, далее написал код по событию этой кнопки своей "Сохранить"

&НаКлиенте
Процедура СохранитьРуками (Команда)

ЗаменимТекущегоРодителяНаСервере();
ОповеститьОбИзменении(Объект.Ссылка);
Закрыть();

КонецПроцедуры

&НаСервере
Функция ЗаменимТекущегоРодителяНаСервере()

Объект.Родитель = КудаПереместить;
Записать();

КонецФункции // ЗаменимТекущегоРодителяНаСервере()


Что нужно написать такое, что бы теперь в форме списка была спозиционирована строчка этого измененного элемента? Я хочу получить такой же результат что делает кнопка записать и закрыть.


Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
>> как с позиционироваться в списке УФ?
Элементы.Список.ТекущаяСтрока = Справочники.Номенклатура.НайтиПоНаименованию("НаименованиеТовара");
Вместо конструкции "Справочники.Номенклатура.НайтиПоНаименованию("НаименованиеТовара")" можете вставить любую ссылку на элемент справочника "Номенклатура".

Оффлайн boobzx

  • ***
  • Сообщений: 124
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2013-03-07
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
sadovod
Спасибо! Код преобразился теперь вот так,

&НаКлиенте
Процедура СохранитьРуками (Команда)
   
    ЗаменимТекущегоРодителяНаСервере();
    ОповеститьОбИзменении(Объект.Ссылка);
    ФормаСпискаНомен = ОткрытьФорму("Справочник.НОМЕНКЛАТУРА.ФормаСписка");
    ФормаСпискаНомен.Элементы.Список.ТекущаяСтрока = Объект.Ссылка;

    Закрыть();
       
КонецПроцедуры

&НаСервере
Функция ЗаменимТекущегоРодителяНаСервере()

    Объект.Родитель = КудаПереместить;
    Записать();
   
КонецФункции // ЗаменимТекущегоРодителяНаСервере()

Теперь, у меня при нажатии на кнопку открывается новое окно, и там уже позиционируется. А как сделать что бы открывалось в текущем окне? А то приходится новое окно закрывать и в старом снова править. Пробую добавлять параметр владельца

ФормаСпискаНомен = ОткрытьФорму("Справочник.НОМЕНКЛАТУРА.ФормаСписка",,ЭтаФОрма);
И все равно в новом окне. Почитал про Активизировать и активное окно... что-от не то..

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
А зачем второй раз открывать форму списка? Кстати, а как вы открываете вашу форму, где меняете родителя? По идее можно использовать всего одну строчку кода Обновить(), но нужно знать, где и как вы открываете форму элемента.
Ну а если всё же использовать вашу логику, то для получения заданного результата можно применить пару методов
  Оповестить("Перемещено", Объект.Ссылка);
пишете её после метода Закрыть(). А в форме списка нужно использовать стандартный обработчик события формы ОбработкаОповещения(ИмяСобытия, Параметр, Источник) таким образоом:
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
Если ИмяСобытия = "Перемещено" Тогда
Элементы.Список.ТекущаяСтрока = Параметр;
КонецЕсли;
КонецПроцедуры

Оффлайн boobzx

  • ***
  • Сообщений: 124
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2013-03-07
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за код! в 8.3 не работает.... возможно баг... перенес все на 8.2.. все как положено запустилось:) как раз так как я и хотел:) спасибо еще раз за код! Воспользовался воторым вариантом. Я им пробовал тоже пользоваться... но ума не хватила еще добавить событие оповещения на форму списка..:ooifh::ooifh::ooifh::ooifh::ooifh:


Теги:
 

Перенесено: Сбросить пользователей в "списке активных пользователей" 1С 8.1

Автор KlyacksaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2713
Последний ответ 12 Май 2011, 21:37
от Klyacksa
Общая Сумма Документов в Списке Документов

Автор Andrey777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 609
Последний ответ 13 Дек 2016, 15:27
от ilyay
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4683
Последний ответ 24 Ноя 2015, 15:38
от welldone
ЗУП 3.1(базовая). В списке выбора вида тарифа нет "Организации, уплачивающие ЕНВД"

Автор FilidorРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 110
Последний ответ 01 Дек 2017, 08:31
от alex0402
Колонка с долгом в списке документов "Реализация товаров и услуг" в УТ 8.1

Автор benoevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2294
Последний ответ 13 Ноя 2010, 19:16
от progmikon

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 233
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal