Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 05:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Интерактивное удаление по клавише Del  (Прочитано 6780 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн greenLiss

  • Приятно осознавать, что я кому-то нужен и за мной наблюдают (тем более, админы) XD
  • ***
  • Сообщений: 104
  • РЕПУТАЦИЯ: 8
  • КПД: 8%
  • Регистрация: 2012-12-04
  • Сайт: 
Добрый вечер!
Есть справочник, нужно сделать так, что бы при нажатии на клавишу DELETE(в форме списка) предлагалось не пометить элемент на удаление, а непосредственно удалить. Как это сделать, а то я не знаю?  :nhsrm:


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн greenLiss

  • Приятно осознавать, что я кому-то нужен и за мной наблюдают (тем более, админы) XD
  • ***
  • Сообщений: 104
  • РЕПУТАЦИЯ: 8
  • КПД: 8%
  • Регистрация: 2012-12-04
  • Сайт: 
Shift+Del

Вы наверное не в эту тему хотели написать, или вопрос не внимательно читаете...  :dfbbdrfb:
Вопрос был не "Какие клавиши выполняют интерактивное удаление ?", а "Как сделать интерактивное удаление по клавише delete ?" <_<

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Как вариант могу предложить такую реализацию

Процедура ПередЗаписью(Отказ) //В модуле объекта

Если ПометкаУдаления Тогда
   
    ПодключитьОбработчикОжидания("ОбработчикУдалениеОбъекта",0.1,Истина);

КонецПроцедуры

//Процедура общего глобального модуля
Процедура ОбработчикУдалениеОбъекта() Экспорт

Запрос = Новый Запрос("ВЫБРАТЬ
                      | МойСправочник.Ссылка
                      |ИЗ
                      | Справочник.МойСправочник КАК МойСправочник
                      |ГДЕ
                      | МойСправочник.ПометкаУдаления");
 
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
Объект = Выборка.Ссылка.ПолучитьОбъект();
Попытка
Объект.Удалить();
Исключение
#Если Клиент тогда
Сообщить(ОписаниеОшибки());
#КонецЕсли
КонецПопытки;
КонецЦикла;

КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
лучше действовать через параметр сеанса, наверное
вот если бы еще можно было бы изменить стандартное сообщение :(
skype: slin-dev

Оффлайн greenLiss

  • Приятно осознавать, что я кому-то нужен и за мной наблюдают (тем более, админы) XD
  • ***
  • Сообщений: 104
  • РЕПУТАЦИЯ: 8
  • КПД: 8%
  • Регистрация: 2012-12-04
  • Сайт: 
.

Добавлено: 07 Мар 2013, 13:30

Спасибо, код работает, если не считать
ПодключитьОбработчикОжидания
на сервере.
И правда, буду делать через параметры сеанса :D
Всем спасибо :ooifh:

Последний раз редактировалось: greenLiss; 07 Мар 2013, 13:30. Причина: Объединение сообщений

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Спасибо, код работает, если не считать
Вы же нифига не пишете релиз платформы и конфигурацию!!! Приходиться телепатировать!!!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн greenLiss

  • Приятно осознавать, что я кому-то нужен и за мной наблюдают (тем более, админы) XD
  • ***
  • Сообщений: 104
  • РЕПУТАЦИЯ: 8
  • КПД: 8%
  • Регистрация: 2012-12-04
  • Сайт: 
Спасибо, код работает, если не считать
Вы же нифига не пишете релиз платформы и конфигурацию!!! Приходиться телепатировать!!!
Искренне прошу прощения :mellow:


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 230
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal