Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помощь исправить ошибки!  (Прочитано 11488 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
помогите пожалуйста исправить ошибки! надо сделать удобным список отбора план производства! и чтобы каждый заказ который находиться в плане производства при создании нового документа чтобы каждый заказ из плана создавался отдельным документов ! помогите исправить пожалуйста эти ошибки!


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Какие ошибки? ГДЕ? :dfbsdfbsdf:
Помогли, отблагодари!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
у меня в обработке! надо чтобы отбор за период был более удобным! а то когда я делаю отбор за период! выходит с форма возможностью выбора документов! а мне надо чтобы они сразу выводились списком на форме!  мне надо чтобы каждый заказ который есть в плане производства создавались отдельным документом, а не чтобы все заказы плана создаются 1 документом! вот код:

Процедура КнопкаВыполнитьНажатие(Кнопка)

Если ЭлементыФормы.НашиДокументы.Значение.Количество() = 0 Тогда
Возврат;
КонецЕсли;

Запрос = Новый Запрос;
Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
Запрос.Текст =
"ВЫБРАТЬ
| ПланыПроизводстваОбороты.Номенклатура,
| ПланыПроизводстваОбороты.ХарактеристикаНоменклатуры,
| ПланыПроизводстваОбороты.Заказ,
| ПланыПроизводстваОбороты.Спецификация,
| ПланыПроизводстваОбороты.КоличествоОборот КАК Количество,
| ПланыПроизводстваОбороты.Подразделение,
| ПланыПроизводстваОбороты.ДокументПланирования КАК Регистратор
|ПОМЕСТИТЬ ИсходныеДанные
|ИЗ
| РегистрНакопления.ПланыПроизводства.Обороты(, , Запись, ДокументПланирования В (&Регистратор)) КАК ПланыПроизводстваОбороты
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| ИсходныеДанные.Регистратор,
| ИсходныеДанные.Номенклатура,
| ИсходныеДанные.ХарактеристикаНоменклатуры,
| ИсходныеДанные.Спецификация,
| ИсходныеДанные.Количество,
| ИсходныеДанные.Заказ,
| ИсходныеДанные.Подразделение,
| ОсновныеСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры КАК ОсновнаяСпецификация
|ПОМЕСТИТЬ ТочныеСпецификации
|ИЗ
| ИсходныеДанные КАК ИсходныеДанные
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК ОсновныеСпецификацииНоменклатурыСрезПоследних
| ПО ИсходныеДанные.Номенклатура = ОсновныеСпецификацииНоменклатурыСрезПоследних.Номенклатура
| И ИсходныеДанные.ХарактеристикаНоменклатуры = ОсновныеСпецификацииНоменклатурыСрезПоследних.ХарактеристикаНоменклатуры
| И ИсходныеДанные.Подразделение = ОсновныеСпецификацииНоменклатурыСрезПоследних.Подразделение
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| ТочныеСпецификации.Регистратор,
| ТочныеСпецификации.Номенклатура,
| ТочныеСпецификации.ХарактеристикаНоменклатуры,
| ТочныеСпецификации.Спецификация,
| ТочныеСпецификации.Количество,
| ТочныеСпецификации.Заказ,
| ТочныеСпецификации.Подразделение,
| ВЫБОР
| КОГДА ТочныеСпецификации.ОсновнаяСпецификация ЕСТЬ NULL
| ТОГДА ЕСТЬNULL(ОсновныеСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры, ЗНАЧЕНИЕ(Справочник.СпецификацииНоменклатуры.ПустаяСсылка))
| ИНАЧЕ ЕСТЬNULL(ТочныеСпецификации.ОсновнаяСпецификация, ЗНАЧЕНИЕ(Справочник.СпецификацииНоменклатуры.ПустаяСсылка))
| КОНЕЦ КАК ОсновнаяСпецификация
|ПОМЕСТИТЬ ВсеСпецификации
|ИЗ
| ТочныеСпецификации КАК ТочныеСпецификации
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних(, Подразделение = ЗНАЧЕНИЕ(Справочник.Подразделения.ПустаяСсылка)) КАК ОсновныеСпецификацииНоменклатурыСрезПоследних
| ПО ТочныеСпецификации.Номенклатура = ОсновныеСпецификацииНоменклатурыСрезПоследних.Номенклатура
| И ТочныеСпецификации.ХарактеристикаНоменклатуры = ОсновныеСпецификацииНоменклатурыСрезПоследних.ХарактеристикаНоменклатуры
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
| ВсеСпецификации.Регистратор КАК Регистратор,
| ВсеСпецификации.Номенклатура,
| ВсеСпецификации.ХарактеристикаНоменклатуры,
| ВЫБОР
| КОГДА ВсеСпецификации.Спецификация = ЗНАЧЕНИЕ(Справочник.СпецификацииНоменклатуры.ПустаяСсылка)
| ТОГДА ВсеСпецификации.ОсновнаяСпецификация
| ИНАЧЕ ВсеСпецификации.Спецификация
| КОНЕЦ КАК Спецификация,
| ВсеСпецификации.Количество,
| ВсеСпецификации.Заказ,
| ВсеСпецификации.Подразделение,
| ВсеСпецификации.Номенклатура.ЕдиницаХраненияОстатков.Ссылка КАК ЕдиницаИзмерения,
| ВсеСпецификации.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент КАК Коэффициент
|ИЗ
| ВсеСпецификации КАК ВсеСпецификации
|ИТОГИ ПО
| Регистратор";

Запрос.УстановитьПараметр("Регистратор", ЭлементыФормы.НашиДокументы.Значение.ВыгрузитьКолонку("План"));

ВыборкаПоРегистратору = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);


Пользователь = ПараметрыСеанса.ТекущийПользователь;
Отбор = Новый Структура("Пользователь, Настройка", Пользователь, ПланыВидовХарактеристик.НастройкиПользователей.ОсновнаяОрганизация);
Орг = РегистрыСведений.НастройкиПользователей.Получить(Отбор);
Если НЕ ЗначениеЗаполнено(Орг.Значение) Тогда
Выборка = Справочники.Организации.Выбрать();
Если Выборка.Следующий() Тогда
Орг = Выборка.Ссылка;
Иначе
Орг = Справочники.Организации.ПустаяСсылка();
КонецЕсли;
Иначе
Орг = Орг.Значение;
КонецЕсли;

Пока ВыборкаПоРегистратору.Следующий() Цикл

Док = Документы.ЗаказНаПроизводство.СоздатьДокумент();
Док.Дата = ТекущаяДата();
Док.Ответственный = Пользователь;
Док.Организация = Орг;


Выборка = ВыборкаПоРегистратору.Выбрать();
Пока Выборка.Следующий() Цикл
Док.Подразделение = Выборка.Подразделение;
СтрокаТЧ = Док.Продукция.Добавить();
СтрокаТЧ.Номенклатура = Выборка.Номенклатура;
СтрокаТЧ.ХарактеристикаНоменклатуры = Выборка.ХарактеристикаНоменклатуры;
СтрокаТЧ.Количество = Выборка.Количество;
СтрокаТЧ.ЕдиницаИзмерения = Выборка.ЕдиницаИзмерения;
СтрокаТЧ.Спецификация = Выборка.Спецификация;
СтрокаТЧ.Заказ = Выборка.Заказ;
КонецЦикла;

Док.Записать(РежимЗаписиДокумента.Запись);

СтрокаТЗ = ЭлементыФормы.НашиДокументы.Значение.Найти(ВыборкаПоРегистратору.Регистратор, "План");
Если СтрокаТЗ = Неопределено Тогда
Сообщить("Что-то тут не так! " + ВыборкаПоРегистратору.Регистратор, СтатусСообщения.Важное);
Иначе
СтрокаТЗ.Заказ = Док.Ссылка;
КонецЕсли;

ЭлементыФормы.НашиДокументы.ОбновитьСтроки();

КонецЦикла;






КонецПроцедуры

Процедура ВыбПериодНажатие(Элемент)
НастройкаПериода = Новый НастройкаПериода;
НастройкаПериода.РедактироватьКакИнтервал = Истина;
НастройкаПериода.РедактироватьКакПериод = Истина;
НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
Если НастройкаПериода.Редактировать() Тогда
НачПериода = НастройкаПериода.ПолучитьДатуНачала();
КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
КонецЕсли;
КонецПроцедуры

Процедура ЗаполнитьНажатие(Элемент)

ТЗ = Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("План", Новый ОписаниеТипов("ДокументСсылка.ПланПроизводства"),
"Документ планирования");
ТЗ.Колонки.Добавить("Заказ", Новый ОписаниеТипов("ДокументСсылка.ЗаказНаПроизводство"),
"Заказ на производство");

Список = Новый СписокЗначений;

Если ЗначениеЗаполнено(НачПериода) И ЗначениеЗаполнено(КонПериода) Тогда
Выборка = Документы.ПланПроизводства.Выбрать(НачПериода,КонецДня(КонПериода));
ИначеЕсли НЕ ЗначениеЗаполнено(НачПериода) И ЗначениеЗаполнено(КонПериода) Тогда
Выборка = Документы.ПланПроизводства.Выбрать(,КонецДня(КонПериода));
ИначеЕсли ЗначениеЗаполнено(НачПериода) И НЕ ЗначениеЗаполнено(КонПериода) Тогда
Выборка = Документы.ПланПроизводства.Выбрать(НачПериода);
Иначе
Выборка = Документы.ПланПроизводства.Выбрать();
КонецЕсли;

Пока Выборка.Следующий() Цикл
Если Выборка.Проведен Тогда
Список.Добавить(Выборка.Ссылка,,Истина);
КонецЕсли;
КонецЦикла;

Если Список.ОтметитьЭлементы("Отметьте необходимые планы") Тогда
Для каждого ЭлементСписка Из Список Цикл
Если ЭлементСписка.Пометка Тогда
СтрокаТЗ = ТЗ.Добавить();
СтрокаТЗ.План = ЭлементСписка.Значение;
КонецЕсли;
КонецЦикла;
Иначе
Для каждого ЭлементСписка Из Список Цикл
СтрокаТЗ = ТЗ.Добавить();
СтрокаТЗ.План = ЭлементСписка.Значение;
КонецЦикла;
КонецЕсли;

ЭлементыФормы.НашиДокументы.Значение = ТЗ;
ЭлементыФормы.НашиДокументы.СоздатьКолонки();

КолонкаПлан = ЭлементыФормы.НашиДокументы.Колонки.План;
КолонкаПлан.ЭлементУправления.КнопкаОткрытия = Истина;
КолонкаЗаказ = ЭлементыФормы.НашиДокументы.Колонки.Заказ;
КолонкаЗаказ.ЭлементУправления.КнопкаОткрытия = Истина;

ЭлементыФормы.НашиДокументы.ОбновитьСтроки();

КонецПроцедуры

Последний раз редактировалось: MuI_I_Ika; 05 Мар 2013, 12:53

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Так вы поставьте условие что если Документ план на производство меняется то создавать новый документ заказа
Помогли, отблагодари!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
хмм это где надо поставит! и это решит мою проблему того чтобы каждый заказ из плана будет создавать отдельным документом?

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Он у вас один документ выводит? Или все в один?
Помогли, отблагодари!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
все в один! т.е для каждого плана производства создается свой заказ на производство! например если в документе плана производства в списке несколько заказов! он создает общий документ с несколькими заказами! а мне надо чтобы каждый заказ из списка создавался отдельным документов!

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Список заказов хранится здесь - ПланыПроизводстваОбороты.Заказ
Помогли, отблагодари!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
вы можете написать полный код , и написать куда его вставить!

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
вы можете написать полный код , и написать куда его вставить!
а че своих мыслей ваабще нет? ты уже не раз задавал вопрос на эту тему, начни что нибудь свое, а люди подскажут по ходу пьнсы, а то вынь да положь


Теги:
 

Нужна помощь про "Отчет о смене без гашение" и "Z отчет"

Автор Serg85Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3759
Последний ответ 23 Ноя 2014, 12:36
от дфтын
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2758
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Нужна помощь по "Управление торговлей 10.3"

Автор werstakРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1972
Последний ответ 26 Мар 2011, 12:50
от werstak
Нужна помощь в формировании отчета "Преобразование значения к типу Дата не может быть выполнено"

Автор STLuka1337Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2094
Последний ответ 14 Ноя 2014, 13:24
от cska-fanat-kz
Нужна помощь специалиста 1С (v8.1) (программиста) по работе с "Бухгалтерией"

Автор lx470Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2387
Последний ответ 24 Фев 2011, 15:25
от lx470

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 177
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal