Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение реквизиов табличной части документа из форми. (УТ 11)  (Прочитано 6263 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн swannm

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: -3
  • Регистрация: 2011-03-17
  • Сайт: 
  • Профессия: Программист 1С
Когда пытаюсь в обработчике кнопки на форме документа изменить значение какого - то реквизита (и это с помощью  процедуры, которая НаСервере и которую вызываю в обработчике кнопки) , то выдает ошыбку " Нельзя изменять поле, содержащее об#ект данных формы". Что делать?


Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Очень даже не понятный вопрос, переформулируйте, чтобы мы все поняли. Мне кажется даже мои непонятные вопросы, понятны глядя на ваш вопрос :btbzdb:

Оффлайн swannm

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: -3
  • Регистрация: 2011-03-17
  • Сайт: 
  • Профессия: Программист 1С
В документе "ПоступлениеТоваровУслуг" в табличной части "Товары" надо кое-что изменить, а вот не получается, ругается вышесказанным.
Вот код:
& НаСервере
Процедура  Проц1(Об#ект)
    Для Каждого Стр Из Об#ект.Товары Цикл
        Стр.Наименование = "АААА";
    КонецЦикла;
КонецЦикла;

&НаКлиенте
Процедура Команда1(Команда)
    Проц1(Об#ект);
КонецПроцедуры

При вызове процедуры Команда1 (это при нажатии на кнопку) и выдает ошыбку.

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
ошыбку
И какую ОШИБКУ выдает! Русский язык знать надо!

Добавлено: 05 Мар 2013, 09:32

И Объект можно не передавать он доступен как на клиенте так и на сервере! Или вы передаете переменную Об#ект
Помогли, отблагодари!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
&НаСервере
Процедура  Проц1()
    Док = РеквизитФормыВЗначение(Объект);
    Для Каждого Стр Из Док.Товары Цикл
        Стр.Наименование = "АААА";
    КонецЦикла;
КонецЦикла;
ЗначениеВРеквизитФормы(Док,"Объект");
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    Проц1();
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн swannm

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: -3
  • Регистрация: 2011-03-17
  • Сайт: 
  • Профессия: Программист 1С
&НаСервере
Процедура  Проц1()
    Док = РеквизитФормыВЗначение(Объект);
    Для Каждого Стр Из Док.Товары Цикл
        Стр.Наименование = "АААА";
    КонецЦикла;
КонецЦикла;
ЗначениеВРеквизитФормы(Док,"Объект");
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    Проц1();
КонецПроцедуры

Нет, знаете, не вышло, теперь " Несоответствие типов (параметр номер 1)" на строке
 Док = РеквизитФормыВЗначение(Объект);
Добавлено: 05 Мар 2013, 11:01

Ну все, просо надо было "Объект" вместо Объекта

Последний раз редактировалось: swannm; 05 Мар 2013, 11:01. Причина: Объединение сообщений


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4474
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7745
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4783
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8514
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7343
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 278
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal