Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавление информационного поля на форму счета  (Прочитано 8910 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hobat

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-03
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Я новичок в 1с, но пытаюсь сам разобраться по имеющейся конфиге (1с8.2 КА).
Возникла необходимость добавить на поле формы документа СчетНаОплатуПокупателю информационное поле, которое бы отображало название позиции номенклатуры полностью, ибо в таблице не влазит целиком.
Для чего как я думал и что делал:
1) на форме документа СчетНаОплатуПокупателю добавил надпись ПолноеНаименование
2) в модуле добавил процедуру:

Процедура ВыводПолногоНаименования()
   ТекСтрокаТЧ = ЭлементыФормы.Товары.ТекущаяСтрока;
   Если ТекСтрокаТЧ = Неопределено Тогда
      ЭлементыФормы.ПолноеНаименование = 0;
   Иначе
      ЭлементыФормы.ПолноеНаименование = ТекСтрокаТЧ.Номенклатура;
    КонецЕсли;
КонецПроцедуры;

и добавил ее в процедуру приОткрытии()

Выдает ошибку:

{Документ.СчетНаОплатуПокупателю.Форма.ФормаДокумента.Форма(3249)}: Поле объекта недоступно для записи (ПолноеНаименование)
      ЭлементыФормы.ПолноеНаименование = 0;

подскажите пожалуйста, почему этого недостаточно и что не так?


Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Что значит не влазит полностью? покажите скрин

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ЭлементыФормы.ПолноеНаименование.Значение = ТекСтрокаТЧ.Номенклатура;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн hobat

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-03
  • Сайт: 
  • Профессия: Ученик 1С
Что значит не влазит полностью? покажите скрин
Допустим вот так. Суть в чем - есть нереально длинные названия позиций, что манагам нужно будет растягивать одну только колонку наименования на пол экрана, что не удобно для работы. Поэтому есть необходимость добавить информационное поле под ТЧ


ЭлементыФормы.ПолноеНаименование.Значение = ТекСтрокаТЧ.Номенклатура;
ничего не дало

Оффлайн aleon

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 1
  • КПД: 17%
  • Регистрация: 2013-03-13
  • Сайт: 
  • Профессия: Ученик 1С
&НаКлиенте
Процедура ТоварыПриАктивизацииСтроки(Элемент)

Товар=Элементы.Товары.ТекущиеДанные.Номенклатура;
ПолноеНаименованиеНаСервере(Товар);
КонецПроцедуры
  &НаСервере
Функция  ПолноеНаименованиеНаСервере(Товар);

Вид=Товар.ПолноеНаименование;
Реквизит1=Вид;
КонецФункции
Реквизит1 просто поле надписи на форме
При активизации строки это стандартное событие ТЧ ну или просто Реквизит1=Товар.ПолноеНаименование;))
А ну еще при выборе номенклатуры не видно будет ее сразу поэтому добавь
Товар=Элементы.Товары.ТекущиеДанные.Номенклатура;
ПолноеНаименованиеНаСервере(Товар);
в событие при изменении , должно работать

Последний раз редактировалось: aleon; 14 Мар 2013, 17:56

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура ТоварыПриАктивизацииСтроки()

ТекСтрока = ЭлементыФормы.ИмяТАбличнойЧасти.ТекущиеДанные;
Если ТекСтрока = Неопределено Тогда
   Возврат;
КонецЕсли;

ЭлементыФормы.ИмяРеквизитаТекстаНаФорме.Заголовок = ТекСтрока.Номенклатура.Наименование; //Ну или полное наименование, по вкусу

КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн aleon

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 1
  • КПД: 17%
  • Регистрация: 2013-03-13
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ТоварыПриАктивизацииСтроки()
ТекСтрока = ЭлементыФормы.ИмяТАбличнойЧасти.ТекущиеДанные;
............

я канешь новичок в программировании 1С но это событие управляемой формы исполняется на клиенте, и твой код не будет работать, чтоб у него отображалось полное наименование на сервер надо закинуть ссылку на справочник, и на сервере полное наименование получить

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
я канешь новичок в программировании 1С но это событие управляемой формы исполняется на клиенте, и твой код не будет работать, чтоб у него отображалось полное наименование на сервер надо закинуть ссылку на справочник, и на сервере полное наименование получить

Скриншот выше посмотри! Это обычная ФОРМА!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


 

Не работают поля "налоговый" и "бухгалтерский"

Автор oleg_e1Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2469
Последний ответ 31 Дек 2011, 11:36
от AntonB
Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6853
Последний ответ 24 Ноя 2014, 12:21
от gigson
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4198
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3222
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1348
Последний ответ 18 Янв 2017, 12:32
от sertak

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 181
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal