Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 19:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не получается списывать товар с ОБЩЕГО списка :(  (Прочитано 5035 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер

Здравствуйте!
  [size=78%]Есть Документ ПоступлениеТовараКартриджи, и человек [/size][size=78%]который принимает этот товар из Основного Склада. Соответственного завхоз принял товар (картриджи). К[/size][size=78%]роме завхоза могут еще 2 человека этот товар списывать. Вот код:[/size]
 [size=78%]Процедура ОбработкаПроведения(Отказ, Режим)[/size]
   //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!


   // регистр УчетКартриджей Приход
   Движения.УчетКартриджей.Записывать = Истина;
   Для Каждого ТекСтрокаМатериал Из Материал Цикл
      Движение = Движения.УчетКартриджей.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Склад = Склад;
      Движение.Картридж = ТекСтрокаМатериал.Картридж;
      Движение.Количество = ТекСтрокаМатериал.Количество;
   КонецЦикла;


   // регистр УчетКартриджейПоСотрудникам Приход
   Движения.УчетКартриджейПоСотрудникам.Записывать = Истина;
   Для Каждого ТекСтрокаМатериал Из Материал Цикл
      Движение = Движения.УчетКартриджейПоСотрудникам.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Сотрудник = СотрудникАвтоматизации;
      Движение.Картридж = ТекСтрокаМатериал.Картридж;
      Движение.Количество = ТекСтрокаМатериал.Количество;
      Движение.СотрудникОтдела = СотрудникОтдела;
   КонецЦикла;


   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры


Вопрос: На примере (код выше) завхоз с ОБЩЕГО списка списывает картриджи, а другие сотрудники не могут списывать с ОБЩЕГО Списка (списывается только единично). Как сделать так чтобы др.сотрудники тоже могли списывать с ОБЩЕГО Списка ?


Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
я так понял что ошибка в этой строке Движение.Сотрудник = СотрудникАвтоматизации;, если так то откуда берется СотрудникАвтоматизации, в смысле заполнется вручную ил автоматически в зависимости от пользователя? и вообще хорошо бы было узнать какая ошибка вываливается

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
я так понял что ошибка в этой строке Движение.Сотрудник = СотрудникАвтоматизации;, если так то откуда берется СотрудникАвтоматизации, в смысле заполнется вручную ил автоматически в зависимости от пользователя? и вообще хорошо бы было узнать какая ошибка вываливается

СотрудникАвтоматизации выбирается из Справочника в зависимости от пользователя. Ошибка никакая не вываливается. И код другой конечно, по ошибке не тот код выложил (приход) нужно расход :Процедура ОбработкаПроведения(Отказ, Режим)
   //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

   // регистр УчетКартриджей Расход
   Движения.УчетКартриджей.Записывать = Истина;
   Движение = Движения.УчетКартриджей.Добавить();
   Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
   Движение.Период = Дата;
   Движение.Склад = Склад;
   Движение.Картридж = Картридж;
   Движение.Количество = 1;

   // регистр УчетКартриджейПоСотрудникам Расход
   Движения.УчетКартриджейПоСотрудникам.Записывать = Истина;
   Движение = Движения.УчетКартриджейПоСотрудникам.Добавить();
   Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
   Движение.Период = Дата;
   Движение.Сотрудник = Сотрудникавтоматизации;
   Движение.Картридж = Картридж;
   Движение.Количество = 1;
   Движение.СотрудникОтдела = СотрудникОтдела;

   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
тогда у вас проблема наверное с правами доступа на документ списание по сотрудникам, попробуйте предостаивть полные права на данный документ тем  сотрудникам к\е имеют право списывать картриджы


Теги:
 

Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 271
Последний ответ 12 Окт 2017, 14:02
от wise
Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1685
Последний ответ 21 Сен 2016, 08:16
от GadLex
Изменение вида "выпадающего списка"

Автор JohnDoe144Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1224
Последний ответ 20 Май 2016, 13:26
от LexaK
Отключение кнопки "Отключить отбор" на панели формы списка документа

Автор AlterMannРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 10354
Последний ответ 13 Мар 2013, 09:41
от AlterMann
Где найти вкладку "Параметры", в конструкторе запроса при создании динамического списка?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 810
Последний ответ 09 Мар 2017, 14:48
от LexaK

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 236
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal