Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Дек 2017, 01:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение поля формы(Число)  (Прочитано 4787 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Всем добрый день!Как можно заполнить поле формы автоматически,значением например (25) если в поле стоит (0)?


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
В процедуре например при открытии пишите
Если Объект.ПолеКотороеЧисло = 0 тогда
    Объект.ПолеКотороеЧисло = 25;
КонецЕсли;
Помогли, отблагодари!

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
В процедуре например при открытии пишите
Если Объект.ПолеКотороеЧисло = 0 тогда
    Объект.ПолеКотороеЧисло = 25;
КонецЕсли;
неа,не помогло
Добавлено: 28 Фев 2013, 15:31

Всем добрый день!Как можно заполнить поле формы автоматически,значением например (25) если в поле стоит (0)?

Корректировка:  заполнить поле формы автоматически,значением например (25) если в поле стоит (0 при выборе номенклатуры)?
Добавлено: 28 Фев 2013, 15:39

В процедуре например при открытии пишите
Если Объект.ПолеКотороеЧисло = 0 тогда
    Объект.ПолеКотороеЧисло = 25;
КонецЕсли;

Все,ссорри я натупил)))Огромное спасибо!Хорошего Вам дня!!

Последний раз редактировалось: Kostik2013; 28 Фев 2013, 15:39. Причина: Объединение сообщений

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Строчки вставьте в  процедуру НоменклатураПриИзменении
Добавлено: 28 Фев 2013, 15:45

вы пытаетесь в табличной части документа изменить?
Помогли, отблагодари!

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Строчки вставьте в  процедуру НоменклатураПриИзменении
Добавлено: 28 Фев 2013, 15:45

вы пытаетесь в табличной части документа изменить?

Все,ссорри я натупил)))Огромное спасибо!Хорошего Вам дня!!


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 302
Последний ответ 21 Сен 2017, 10:33
от Insider
Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 7613
Последний ответ 16 Авг 2012, 21:50
от Will
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4830
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3426
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5014
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
AIFrame
73 Сообщений
alex0402
52 Сообщений
ilyay ilyay
51 Сообщений
andron81_81
44 Сообщений
oleg-x
35 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal