Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 02:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как правильно составить запрос в консоли запросов  (Прочитано 6499 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
объясните ЧТО ДАЛЬШЕ ДЕЛАТЬ! Я СОБРАЛ ДОКУМЕНТЫ "ПЛАН ПРОИЗВОДСТВА" ЧЕРЕЗ КОНСОЛЬ ЗАПРОСОВ! ЧТО МНЕ ДАЛЬШЕ ДЕЛАТЬ ЧТОБЫ НА ЛЮБОМ ОТКРЫТОМ ДОКУМЕНТЕ СДЕЛАТЬ КНОПКУ ЧТОБЫ ПРИ НАЖАТИИ НА НЕЕ ВЫХОДИЛА ФОРМА ДОКУМЕНТА "ЗАКАЗ НА ПРОИЗВОДСТВО"!


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6650
  • РЕПУТАЦИЯ: 787
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
НА ЛЮБОМ ОТКРЫТОМ ДОКУМЕНТЕ СДЕЛАТЬ КНОПКУ ЧТОБЫ ПРИ НАЖАТИИ НА НЕЕ ВЫХОДИЛА ФОРМА ДОКУМЕНТА "ЗАКАЗ НА ПРОИЗВОДСТВО"

Непонятно что вы хотите сделать. Вы хотите добавить кнопку на форму документа и чтобы при нажатии на нее открывался какой-то связанный с ним документ?

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
да вы правы! мне так и надо сделать
Добавлено: 28 Фев 2013, 11:15

вотя написал 2 код! 1 производит отбор документов и делает выгрузку на табличную часть; а 2 код открывает другой связанный документ! ну почему то обработка не работает! не могли бы вы посмотреть в чем дело пожалуйста! очень вас прошу вопрос жизни и смерти!

Добавлено: 28 Фев 2013, 11:16

Процедура КнопкаВыполнитьНажатие(Кнопка)

ВыборкаПланПроизводства = Документы.ПланПроизводства.Выбрать(НачалоПериода, КонецПериода);


Пока ВыборкаПланПроизводства.Следующий() Цикл

ДокументОбъект = Документы.Заказнапроизводство.СоздатьДокумент();
ДокументОбъект.Заполнить(ПланПроизводства);
ДокументОбъект.Записать();

///открытие
формаДок=ДокументОбъект.ПолучитьФорму();
формаДок.Открыть();
//


КонецЦикла;


КонецПроцедуры
 и вот выводит такую ошибку:
{Форма.Форма.Форма(10,26)}: Переменная не определена (ПланПроизводства)
ДокументОбъект.Заполнить(<<?>>ПланПроизводства); (Проверка: Толстый клиент (обычное приложение))
 

 и 2 код:
Процедура КнопкаВыполнитьНажатие2(Кнопка)
Док=Документы.ЗаказНаПроизводство.СоздатьДокумент();
Док.ПолучитьФорму().Открыть();
КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Непонятно что вы хотите сделать. Вы хотите добавить кнопку на форму документа и чтобы при нажатии на нее открывался какой-то связанный с ним документ?
Хочу дополнить вопрос MuI_I_Ika
кнопка должна Открывать связанный документ? или Создавать новый и заполнять?
Добавлено: 28 Фев 2013, 11:47

И еще вопрос.
Конфигурация самописная или типовая?
Добавлено: 28 Фев 2013, 11:59

Что бы отработал код ДокументОбъект.Заполнить(ПланПроизводства);

В модуле объекта документа Заказнапроизводство должно быть описано заполнение в Процедуре ОбработкаЗаполения()
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Последний раз редактировалось: Dethmontt; 28 Фев 2013, 11:59. Причина: Объединение сообщений

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6650
  • РЕПУТАЦИЯ: 787
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
ДокументОбъект.Заполнить(ПланПроизводства);

Ну собственно здесь у вас непойми откуда берется переменная ПланПроизводства. Очевидно, вы хотели написать ВыборкаПланПроизводства.

Во второй процедуре не написали на что ругается. Предположу, что у 1С проблемы с разименованием переменных в этой строке:

Док.ПолучитьФорму().Открыть();

Напишите так:

Форма = Док.ПолучитьФорму();
Форма.Открыть();

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
может я вам вышлю файл а вы сами посмотрели бы пожалуйста


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10991
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3366
Последний ответ 15 Май 2013, 23:27
от Березин
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1228
Последний ответ 11 Июл 2016, 09:00
от vitasw
Запрос по обработке "Согласование заявок"

Автор DenielAkreedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 931
Последний ответ 29 Сен 2016, 02:39
от DenielAkreed
После "Выборка = Запрос.Выполнить().Выбрать()" строка в выборке автоматически переключается сама

Автор RuslerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 215
Последний ответ 30 Мар 2018, 05:05
от Luzer1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
50 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 125
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal