Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Посмотрите что не верно в этом коде  (Прочитано 12487 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С

Процедура КнопкаВыполнитьНажатие(Кнопка)
   
   ВыборкаПланПроизводства = Документы.ПланПроизводства.Выбрать(НачалоПериода, КонецПериода);
      
   
   Пока ВыборкаПланПроизводства.Следующий() Цикл
      
      ДокументОбъект = Документы.Заказнапроизводство.СоздатьДокумент();
      ДокументОбъект.Заполнить(ПланПроизводства);
      ДокументОбъект.Записать();
      
   КонецЦикла;
   
      
КонецПроцедуры
 
Я пытаюсь отобрать документы за период. И на основании документов "ПланПроизводства", создать документ Заказ на производство


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура КнопкаВыполнитьНажатие(Кнопка)
   
   ВыборкаПланПроизводства = Документы.ПланПроизводства.Выбрать(НачалоПериода, КонецПериода);
     
   
   Пока ВыборкаПланПроизводства.Следующий() Цикл
     
      ДокументОбъект = Документы.Заказнапроизводство.СоздатьДокумент();
      ДокументОбъект.Заполнить(ВыборкаПланПроизводства.Ссылка);
      ДокументОбъект.Записать();
     
   КонецЦикла;
   
     
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
спасиббо
Добавлено: 27 Фев 2013, 13:08

{Форма.Форма.Форма(10)}: Ошибка при вызове метода контекста (Записать)
      ДокументОбъект.Записать();
по причине:
Значение поля "Дата" не может быть пустой датой

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Присвойте ДокументОбъект.Дата = ТекущаяДата(); или ту дату которые вы хотите!
Помогли, отблагодари!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
в какую часть кода надо вставить эту запись?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Между заполнить и записать
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
почему тогда он выводит синтаксическую ошибку:{Форма.Форма.Форма(10,39)}: Ожидается символ ';'
     ДокументОбъект.Дата = ТекущаяДата()<<?>> (Проверка: Толстый клиент (обычное приложение))

Добавлено: 27 Фев 2013, 14:55

почему тогда он выводит синтаксическую ошибку:{Форма.Форма.Форма(10,39)}: Ожидается символ ';'
     ДокументОбъект.Дата = ТекущаяДата()<<?>> (Проверка: Толстый клиент (обычное приложение))


Последний раз редактировалось: ildarik_58; 27 Фев 2013, 14:55. Причина: Объединение сообщений

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Точку с запятой поставьте после ТекущаяДата()

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
запустил обработку! пару секунд! подумала и никакого результата не произошло!

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Люди даже не могут прочитать текст ошибки! Вот что значит просто копировать, а своей головой не думать! :befhbt:
Добавлено: 27 Фев 2013, 15:15

Может в выборка вам не чего не дала! проверьте есть ли документы в том периоде что вы задали!
Помогли, отблагодари!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 323
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal