Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 12:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Посмотрите что не верно в этом коде  (Прочитано 14193 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С

Процедура КнопкаВыполнитьНажатие(Кнопка)
   
   ВыборкаПланПроизводства = Документы.ПланПроизводства.Выбрать(НачалоПериода, КонецПериода);
      
   
   Пока ВыборкаПланПроизводства.Следующий() Цикл
      
      ДокументОбъект = Документы.Заказнапроизводство.СоздатьДокумент();
      ДокументОбъект.Заполнить(ПланПроизводства);
      ДокументОбъект.Записать();
      
   КонецЦикла;
   
      
КонецПроцедуры
 
Я пытаюсь отобрать документы за период. И на основании документов "ПланПроизводства", создать документ Заказ на производство


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура КнопкаВыполнитьНажатие(Кнопка)
   
   ВыборкаПланПроизводства = Документы.ПланПроизводства.Выбрать(НачалоПериода, КонецПериода);
     
   
   Пока ВыборкаПланПроизводства.Следующий() Цикл
     
      ДокументОбъект = Документы.Заказнапроизводство.СоздатьДокумент();
      ДокументОбъект.Заполнить(ВыборкаПланПроизводства.Ссылка);
      ДокументОбъект.Записать();
     
   КонецЦикла;
   
     
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
спасиббо
Добавлено: 27 Фев 2013, 13:08

{Форма.Форма.Форма(10)}: Ошибка при вызове метода контекста (Записать)
      ДокументОбъект.Записать();
по причине:
Значение поля "Дата" не может быть пустой датой

Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
Присвойте ДокументОбъект.Дата = ТекущаяДата(); или ту дату которые вы хотите!
Помогли, отблагодари!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
в какую часть кода надо вставить эту запись?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Между заполнить и записать
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
почему тогда он выводит синтаксическую ошибку:{Форма.Форма.Форма(10,39)}: Ожидается символ ';'
     ДокументОбъект.Дата = ТекущаяДата()<<?>> (Проверка: Толстый клиент (обычное приложение))

Добавлено: 27 Фев 2013, 14:55

почему тогда он выводит синтаксическую ошибку:{Форма.Форма.Форма(10,39)}: Ожидается символ ';'
     ДокументОбъект.Дата = ТекущаяДата()<<?>> (Проверка: Толстый клиент (обычное приложение))


Последний раз редактировалось: ildarik_58; 27 Фев 2013, 14:55. Причина: Объединение сообщений

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Точку с запятой поставьте после ТекущаяДата()

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
запустил обработку! пару секунд! подумала и никакого результата не произошло!

Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
Люди даже не могут прочитать текст ошибки! Вот что значит просто копировать, а своей головой не думать! :befhbt:
Добавлено: 27 Фев 2013, 15:15

Может в выборка вам не чего не дала! проверьте есть ли документы в том периоде что вы задали!
Помогли, отблагодари!


Теги:
 

Ошибка в расчете оклада. Помогите пожалуйста найти ошибку в коде?

Автор pvictorp11Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 441
Последний ответ 17 Мар 2017, 13:29
от pvictorp11
Как вывести сообщение пользователю, не используя при этом метод "Сообщить" ?

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 7580
Последний ответ 13 Фев 2011, 12:19
от Klyacksa
При создание калькулятора на обработке вылазит ошибки в коде.

Автор alteSsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 342
Последний ответ 18 Май 2017, 12:28
от alteSs
Помогите пожалуйста разобраться с ошибкой в коде

Автор ildarik_58Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4962
Последний ответ 20 Май 2013, 10:15
от Yura063
Ошибка в коде ОКАТО за 2013 год, как исправить?

Автор asteraРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3338
Последний ответ 17 Янв 2014, 15:58
от pavl_vs

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
71 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
41 Сообщений
wise wise
39 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
Анюта17
25 Сообщений

* Кто онлайн

  • Точка Гостей: 815
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal