Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 21:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Принадлежность группе  (Прочитано 26258 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Помогите пожалуйста, необходимо проверить принадлежит элемент группе или нет, в группе несколько подгрупп и она сама в группе...


Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Если Элемент.Родитель.ЭтоГруппа Тогда
    Сообщить("Принадлежит группе";
КонецЕсли;

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Мне необходимо проверить принадлежность определенной группе

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Если Элемент.Родитель.Наименование = "Группа" Тогда
    Сообщить("Принадлежит группе ""Группа""");
КонецЕсли;

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
не срабатывает Ситуация такая: Группа1, Группа 2, Группа3...ГруппаN . Реквизит. Мне нужно проверить принадлежит ли Реквизит Группе 2

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Т.е надо просто проверить принадлежит ли элемент к опред. группе в иерархии или именно к группе на каком-то уровне?

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
принадлежит ли элемент к опред. группе в иерархии

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
    Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
               | Номенклатура.Ссылка КАК Группа
               |ИЗ
               | Справочник.Номенклатура КАК Номенклатура
               |ГДЕ
               | Номенклатура.ЭтоГруппа
               | И Номенклатура.Наименование = &Группа";
Запрос.УстановитьПараметр("Группа", "ПринадлежащаяГруппа");
Результат = Запрос.Выполнить().Выгрузить();
Если Результат.Количество()>0 Тогда
Группа = Результат[0].Группа;
Если ЭтотОбъект.ПринадлежитЭлементу(Группа) Тогда
Сообщить("ПринадлежитГруппе");
КонецЕсли;
КонецЕсли;

сначала находим группу, потом используем метод "Принадлежит элементу" для поиска принадлежности элемента к группе на всех уровнях иерархии

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Спасибо))))
Добавлено: 25 Фев 2013, 16:34

а вот еще вопрос: если элемент принадлежит группе то на форме открыть возможность редактирования поля табличной части "Ширина", иначе "Ширина" недоступно для редактирования. Как это сделать??

Последний раз редактировалось: Tyshkan; 25 Фев 2013, 16:34. Причина: Объединение сообщений

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
А почему не сделать так:
Спр = Справочники.Номенклатура;
Если Спр.НайтиПоНаименованию(Элемент,,Группа) <> Спр.ПустаяСсылка() Тогда
    //тот код которые вы хотите
Иначе
    Сообщить(Элемент + " не принадлежит группе: " + Группа);
КонецЕсли;
Добавлено: 25 Фев 2013, 16:58

СправочникМенеджер.<Имя справочника> (CatalogManager.<Имя справочника>)
НайтиПоНаименованию (FindByDescription)
Синтаксис:

НайтиПоНаименованию(<Наименование>, <ТочноеСоответствие>, <Родитель>, <Владелец>)
Параметры:

<Наименование> (обязательный)

Тип: Строка.
Строка, содержащая искомое наименование.
<ТочноеСоответствие> (необязательный)

Тип: Булево.
Определяет режим поиска по полному соответствию.
Поиск будет успешным, если строка поиска: в случае значения параметра Ложь - будет соответствовать левой части наименования; в случае значения параметра Истина - будет полностью совпадать с наименованием (за исключением "хвостовых" пробелов в наименовании).
Значение по умолчанию: Ложь
<Родитель> (необязательный)

Тип: СправочникСсылка.
Родитель, в пределах которого нужно выполнять поиск. Если не указан, то поиск будет проводиться во всем справочнике.
<Владелец> (необязательный)

Тип: СправочникСсылка.
Владелец, в пределах которого нужно выполнять поиск. Если не указан, то поиск будет проводиться во всем справочнике.
Возвращаемое значение:

Тип: СправочникСсылка.<Имя справочника>; Неопределено.
Ссылка на найденный элемент справочника.
Если не существует ни одного элемента с требуемым наименованием, то будет возвращена пустая ссылка.
Если для справочника наименование не задано (длина = 0), то будет возвращено Неопределено.
Описание:

Осуществляет поиск элемента по его наименованию.

Доступность:

Сервер, толстый клиент, внешнее соединение.
Примечание:

Если существует несколько элементов с указанным наименованием, то будет найден только один из них.
Помогли, отблагодари!


Теги:
 

Есть Справочник. В нем есть группа. Как в этой группе создать еще группу?

Автор СсылкаНаОбъектРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2579
Последний ответ 09 Фев 2011, 19:58
от cska-fanat-kz
Фильтр: возможность вывода отчета по группе контрагентов

Автор SnakeyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5063
Последний ответ 17 Фев 2013, 18:37
от Yura063
Анализ счета по субконто с отбором по группе номенклатуры

Автор Olya2015Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 8402
Последний ответ 08 Апр 2014, 10:59
от Olya2015
Ограничение доступа к определенной группе справочника

Автор ls600Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 16352
Последний ответ 28 Янв 2013, 12:32
от Klyacksa
автоматическое Присвоение Типа Цен группе контрагентов

Автор KrzhmelikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1852
Последний ответ 15 Июн 2013, 09:59
от Eugeneer

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 326
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal