Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 15:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Очистка Поля в Справочнике  (Прочитано 2128 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток! Такая ситуация. При создании Нового Контрагента на форме есть кнопка "Проверить". Нужно дописать код что бы если в базе есть контрагент с таким РНН  то  поле автоматические очищается. Как реализовать такое?!

Процедура КнопкаПроверкиРНННажатие(Элемент)

ПрисутствиеОшибок = ПроверкаДубликатовКонтрагента(Истина);

Если ОбщегоНазначения.РННСоответствуетТребованиям(РНН) Тогда
Если НЕ ПрисутствиеОшибок Тогда
Предупреждение("Введенный РНН корректен!");
КонецЕсли;
Иначе  ЭтотОбъект.РНН.Очистить(); //Ни че не происходит, ???
КонецЕсли;                     


КонецПроцедуры


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Есть 2 варианта!
1. Циклом прогоняешь по всем контрагентам и проверяешь РНН если найдет то присваиваешь флагу например ложь и делаешь выход из цикла.
2. Запрос по контрагентам с параметром РНН.
Помогли, отблагодари!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ЭтотОбъект.РНН = "";
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Благодарю парни!


Теги:
 

Не работают поля "налоговый" и "бухгалтерский"

Автор oleg_e1Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2467
Последний ответ 31 Дек 2011, 11:36
от AntonB
Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6850
Последний ответ 24 Ноя 2014, 12:21
от gigson
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4198
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3217
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8498
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 899
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal