Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 сен 2021, 19:22

ФормаСР.РегистрСведенийСписок.Отбор.Валюта.Использование = Истина;

Автор jei, 07 фев 2013, 14:28

0 Пользователей и 1 гость просматривают эту тему.

jei

что означает сей код прошу подробно прокомментировать каждую строку

Процедура НадписьНажатие(Элемент)
//здесь устанавливаем владельца для формы списка регистра сведений
ФормаСР = РегистрыСведений.КурсыВалют.ПолучитьФормуСписка(,ЭтаФорма,"Док"+Номер);
ФормаСР.РегистрСведенийСписок.Отбор.Валюта.Использование = Истина;
ФормаСР.ЗакрыватьПриЗакрытииВладельца = Истина;
Если НЕ ФормаСР.Открыта() Тогда
ФормаСР.РазрешитьСостояниеПрячущееся = Истина;
ФормаСР.РазрешитьСостояниеПрикрепленное = Истина;
ФормаСР.РазрешитьСоединятьОкно = Истина;
КонецЕсли;
ФормаСР.Открыть();

КонецПроцедуры

Klyacksa

А может, сразу всю конфигурацию давайте? Чо уж там, объясним каждую строку конфигурации...
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

jei

Не обращаем внимание на модераторов.С ними всё понятно.Люди знающие подскажите.

Dethmontt

Подробно вы можете прочитать в книге по встроенному языку 1С (ЖК)

Кратко:
//Название процедуры - параметры: элемент формы
Процедура НадписьНажатие(Элемент)
//Получение формы списка регистра сведений - параметры: Форма из которой вызывается, Ключ формы
ФормаСР = РегистрыСведений.КурсыВалют.ПолучитьФормуСписка(,ЭтаФорма,"Док"+Номер);
//Установка отбора по реквизиту Валюта (галочка ИСПОЛЬЗОВАТЬ отбор)
ФормаСР.РегистрСведенийСписок.Отбор.Валюта.Использование = Истина;
//Закрыть форму списка если закрыли форму владельца
ФормаСР.ЗакрыватьПриЗакрытииВладельца = Истина;
//Условие если форма не открыта
Если НЕ ФормаСР.Открыта() Тогда

//Устанавливаются свойства формы
        ФормаСР.РазрешитьСостояниеПрячущееся = Истина;
        ФормаСР.РазрешитьСостояниеПрикрепленное = Истина;
        ФормаСР.РазрешитьСоединятьОкно = Истина;
    КонецЕсли;
//Открывают форму (Активизируется в случае если уже открыта)
ФормаСР.Открыть();

//Конец программы
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

cska-fanat-kz

Dethmontt, идете против системы (читай "против незнающих модераторов")? )))

jei, а вы, уважаемый, вместо того, чтобы цеплять модераторов (а особенно ее прекрасную половину!), выучите комбинацию клавиш CTRL+F1.
Выделив незнакомое свойство или метод и нажав эту волшебную комбинацию, получите статью синтакс-помощника с описанием и примером...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Теги:

Похожие темы (4)

Рейтинг@Mail.ru Rambler's Top100

Поиск