Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 23:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ФормаСР.РегистрСведенийСписок.Отбор.Валюта.Использование = Истина;  (Прочитано 4336 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jei

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: -3
  • скайп jeimen
  • Регистрация: 2012-10-13
  • Сайт: 
  • Профессия: Программист 1С
что означает сей код прошу подробно прокомментировать каждую строку

Процедура НадписьНажатие(Элемент)
//здесь устанавливаем владельца для формы списка регистра сведений
ФормаСР = РегистрыСведений.КурсыВалют.ПолучитьФормуСписка(,ЭтаФорма,"Док"+Номер);
ФормаСР.РегистрСведенийСписок.Отбор.Валюта.Использование = Истина;
ФормаСР.ЗакрыватьПриЗакрытииВладельца = Истина;
Если НЕ ФормаСР.Открыта() Тогда
ФормаСР.РазрешитьСостояниеПрячущееся = Истина;
ФормаСР.РазрешитьСостояниеПрикрепленное = Истина;
ФормаСР.РазрешитьСоединятьОкно = Истина;
КонецЕсли;
ФормаСР.Открыть();

КонецПроцедуры


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
А может, сразу всю конфигурацию давайте? Чо уж там, объясним каждую строку конфигурации...
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн jei

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: -3
  • скайп jeimen
  • Регистрация: 2012-10-13
  • Сайт: 
  • Профессия: Программист 1С
Не обращаем внимание на модераторов.С ними всё понятно.Люди знающие подскажите.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Подробно вы можете прочитать в книге по встроенному языку 1С (ЖК)

Кратко:
//Название процедуры - параметры: элемент формы
Процедура НадписьНажатие(Элемент)
//Получение формы списка регистра сведений - параметры: Форма из которой вызывается, Ключ формы
ФормаСР = РегистрыСведений.КурсыВалют.ПолучитьФормуСписка(,ЭтаФорма,"Док"+Номер);
//Установка отбора по реквизиту Валюта (галочка ИСПОЛЬЗОВАТЬ отбор)
ФормаСР.РегистрСведенийСписок.Отбор.Валюта.Использование = Истина;
//Закрыть форму списка если закрыли форму владельца
ФормаСР.ЗакрыватьПриЗакрытииВладельца = Истина;
//Условие если форма не открыта
Если НЕ ФормаСР.Открыта() Тогда

//Устанавливаются свойства формы
        ФормаСР.РазрешитьСостояниеПрячущееся = Истина;
        ФормаСР.РазрешитьСостояниеПрикрепленное = Истина;
        ФормаСР.РазрешитьСоединятьОкно = Истина;
    КонецЕсли;
//Открывают форму (Активизируется в случае если уже открыта)
 ФормаСР.Открыть();

//Конец программы
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Dethmontt, идете против системы (читай "против незнающих модераторов")? )))

jei, а вы, уважаемый, вместо того, чтобы цеплять модераторов (а особенно ее прекрасную половину!), выучите комбинацию клавиш CTRL+F1.
Выделив незнакомое свойство или метод и нажав эту волшебную комбинацию, получите статью синтакс-помощника с описанием и примером...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Программный отбор в "Документы"

Автор SeolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4261
Последний ответ 06 Окт 2012, 18:08
от Seolkin
Отбор при "быстром выборе"

Автор Gregory78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3113
Последний ответ 15 Фев 2015, 12:13
от Gregory78
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 134
Последний ответ 15 Дек 2017, 14:36
от alex0402
Отбор по номенклатуре в отчете "ВЕдомость выдачи мц"

Автор notaSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2357
Последний ответ 08 Авг 2015, 15:40
от ppkmlite
Отбор по дате проведения документа в обработке "Универсальные подбор и обработка объектов"

Автор rooflessРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2584
Последний ответ 25 Июн 2014, 15:30
от roofless

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 301
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal