Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 23:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка из 7.7 в 8.2  (Прочитано 6602 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Доброе время суток. Первый раз столкнулся с такой вот задачей.
В общем есть конфига 7.7 БП, она не типовая переделанная под ЖКХ и есть конфига ЖКХ 8.2. Нужно из 7.7 в 8.2 перевести все справочники и сальдо на конец года, какие будут идеи? Кто делал, поделитесь опытом пожалуйста  ;)


Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Видимо никто не сталкивался с такой задачей=( можно же сказать..реализовывал так то так то, я не прошу готового решения!)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Юзай Конфигурацию Конвертация Данных для 1С 8.2
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Как вариант в принципе я рассматривал, наверное как самый простой вар?
Единственная сложность в написании правил, завтра заюзаю=)
А кто-нить программно переносил?)
Спасибо и на этом!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Воообще 7.7 на 8 я думаю переносили многие!

По опыту скажу, что в большинстве случаев приходилось писать/допиливать правила ручками!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Решил попробовать выгрузку через xml, но возник вопрос по иерархии справочника, а точнее формирование иерархии в xml.
Этот справочник имеет в вид такой: Город-район-улица-подъезд...как организовать такую иерархию?)))
Добавлено: 07 Фев 2013, 16:25

Короче, курил курил курил................и понял, что надо делать совсем не так, структуру все получил (с помощью OLE, все прекрасно работает) и понял, что можно сделать проще, можно все данные получить из элемента справочника.=)
Добавлено: 08 Фев 2013, 10:29

Короче нифига че то не создает группы в справочнике, я беру из элемента Адрес и Улицу, Адрес -это родитель-группа, а улица это тоже группа. Почему то родители вообще пустая строка, что у Адреса что у Улицы. ui;;t;

Пока СправочникЗдания.ПолучитьЭлемент() = 1 Цикл

Если СправочникЗдания.ЭтоГруппа()=0 Тогда
ОсновнаяГруппа=Справочники.КВП_Здания.НайтиПоНаименованию(СокрЛП(СправочникЗдания.Улица));

Если ОсновнаяГруппа.Пустая() Тогда
НовыйОбъект=Справочники["КВП_Здания"].СоздатьГруппу();
НовыйОбъект.Наименование=СправочникЗдания.Улица;

Если СокрЛП(СправочникЗдания.Родитель.Улица)<>"" Тогда
Родитель=Справочники.КВП_Здания.НайтиПоНаименованию(СправочникЗдания.Родитель.Адрес);
Если Не Родитель.Пустая() Тогда
НовыйОбъект.Родитель=Родитель;
Иначе
Родитель=Справочники["КВП_Здания"].СоздатьГруппу();
Родитель.Наименование=СправочникЗдания.Родитель.Улица;
Родитель.Записать();
КонецЕсли;
НовыйОбъект.Записать();
КонецЕсли;
Иначе Сообщить("О...Оууууууу.....!!!");
КонецЕсли;

КонецЕсли;


КонецЦикла;

Пока как то так :befhbt:

Последний раз редактировалось: markgenuine; 08 Фев 2013, 10:29

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Ну что, никто не подскажет что ли? пока что курил, родилась еще одна идея, взять справочник без иерархии чисто элементы, у каждого элемента брать Населенный пункт и Улицу, записать это в таблицу значений, сворачиваем эти данные и создаем Группы справочника Населенный пункт/Улица/и дальше элементы...подскажите как это реализовать программно...
Спасибо!!)

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Цитировать
Родитель=Справочники.КВП_Здания.НайтиПоНаименованию(СправочникЗдания.Родитель.Адрес);
Может он вам просто не находит?
Помогли, отблагодари!

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Цитировать
Родитель=Справочники.КВП_Здания.НайтиПоНаименованию(СправочникЗдания.Родитель.Адрес);
Может он вам просто не находит?
Да не находит...

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
А родитель создается в корне папке?
Добавлено: 08 Фев 2013, 16:56

Цитировать
Родитель=Справочники["КВП_Здания"].СоздатьГруппу();
Помогли, отблагодари!


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4115
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2426
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8574
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 948
Последний ответ 11 Май 2016, 13:23
от Rasty
Выгрузка из "Зарплата и кажпы" платеж за три месяца

Автор vlasssov71Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1232
Последний ответ 07 Июл 2015, 15:19
от vlasssov71

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 207
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal