Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2018, 10:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: есть ли инструменты для манипулирования ИСХОДНЫМ ТЕКСТОМ? внутри пример+++  (Прочитано 1264 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Арпахшад

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-08
  • Сайт: 
  • Профессия: Программист 1С
например, текст:

Если К=1 Тогда
    сообщить("К=1");
ИначеЕсли К=2 Тогда
    сообщить("К=2");
ИначеЕсли К=3 Тогда
    сообщить("К=3");
КонецЕсли;

Если К1=1 Тогда
    сообщить("К1=1");
ИначеЕсли К1=2 Тогда
    сообщить("К1=2");
ИначеЕсли К1=3 Тогда
    сообщить("К1=3");
КонецЕсли;

привратить в текст:

Для И1=1 по 3 Цикл
    Если К=И1 Тогда
        сообщить("К="+строка(К));
    КонецЕсли;
КонецЦикла;

Для И1=1 по 3 Цикл
    Если К1=И1 Тогда
        сообщить("К1="+строка(К1));
    КонецЕсли;
КонецЦикла;


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2859
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Можете помочь написать обработку которая сможет делать реализацию списывая поступления из другой базы или ссылаясь на них? просто одна компания покупает другая продает этот товар и чтобы вторая компания не смогла продать больше чем есть у первой? 1с 8.2 2

Автор Юлия АндреевнаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 818
Последний ответ 13 Ноя 2016, 19:25
от BuhRust
При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4673
Последний ответ 21 Сен 2011, 17:35
от proofet
Здравствуйте!!! Необходимо востановить ИБ на определенную дату. Копии через конфигуратор на эту дату не сделали, но есть файл в формате CD в rar (Это программа сама сделала резервную копию). Возможно ли востановит ее в 1с и работать (как при загрузке копи

Автор Лариса198888Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1948
Последний ответ 24 Май 2016, 17:17
от Kironten
Метод объекта не обнаружен. Но метод есть.

Автор ВитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 13087
Последний ответ 10 Фев 2015, 21:54
от vitasw
"Поле не найдено" в запросе, но оно есть.

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2813
Последний ответ 27 Окт 2015, 10:29
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
105 Сообщений
alex0402
28 Сообщений
kiksi
17 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
BuhRust
13 Сообщений
pavl_vs
13 Сообщений
LexaK
13 Сообщений
Artibon
12 Сообщений

* Кто онлайн

  • Точка Гостей: 922
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal