Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 16:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка в Контроле остатков  (Прочитано 1959 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MihaSerb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-29
  • Сайт: 
  • Профессия: Ученик 1С
При отладки вылетает ошибка
{Документ.РасходнаяНакладная.МодульОбъекта(75,36)}: Переменная не определена (Склад)
Запрос.УстановитьПараметр("Склад", <<?>>Склад); (Проверка: Сервер)



Процедура ОбработкаПроведения(Отказ, Режим)
   
   
   
     Запрос = Новый Запрос;

      Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;

      Запрос.Текст = "ВЫБРАТЬ
                     |   РасходнаяТовары.Номенклатура,
                     |   СУММА(РасходнаяТовары.Количество) КАК Количество
                     |ПОМЕСТИТЬ ДокТЧ
                     |ИЗ
                     |   Документ.РасходнаяНакладная.Товары КАК РасходнаяТовары
                     |ГДЕ
                     |   РасходнаяТовары.Ссылка = &Ссылка
                     |
                     |СГРУППИРОВАТЬ ПО
                     |   РасходнаяТовары.Номенклатура
                     |;
                     |
                     |////////////////////////////////////////////////////////////////////////////////
                     |ВЫБРАТЬ
                     |   ДокТЧ.Номенклатура,
                     |   ДокТЧ.Количество
                     |ИЗ
                     |   ДокТЧ КАК ДокТЧ";

      Запрос.УстановитьПараметр("Ссылка", Ссылка);

      РезультатЗапроса = Запрос.Выполнить();

Движения.ТоварыНаСкладе.Записывать = Истина;

Выборка = РезультатЗапроса.Выбрать();

Пока Выборка.Следующий() Цикл

      Движение = Движения.ТоварыНаСкладе.Добавить();

      Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

      Движение.Период = Дата;

      Движение.Номенклатура = Выборка.Номенклатура;

      Движение.Склад = Склад;

      Движение.Количество = Выборка.Количество;

КонецЦикла;

Движения.Записать();

 
 
Запрос.Текст = "ВЫБРАТЬ

|     Номенклатура,
|     КоличествоОстаток КАК Остаток
|ИЗ
|     РегистрНакопления.ТоварыНаСкладе.Остатки(
|                       ,
|                       Склад = &Склад
|                            И Номенклатура В
|                                  (ВЫБРАТЬ
|                                        ДокТЧ.Номенклатура
|                                  ИЗ
|                                        ДокТЧ КАК ДокТЧ))
|ГДЕ
|     КоличествоОстаток < 0";
 

Запрос.УстановитьПараметр("Склад", Склад);

РезультатЗапроса = Запрос.Выполнить();

 
Выборка = РезультатЗапроса.Выбрать();

Пока Выборка.Следующий() Цикл

            Сообщение = Новый СообщениеПользователю;

            Сообщение.Текст = "Не хватает товара " + Выборка.Номенклатура + ", после проведения документа остаток составит " + Выборка.Остаток;

            Сообщение.Сообщить();

            Отказ = Истина;       

КонецЦикла;    
   
КонецПроцедуры


Оффлайн tank436

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-11
  • Сайт: 
  • Профессия: Ученик 1С
Видимо вы не указали Склад как реквизит

Оффлайн MihaSerb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-29
  • Сайт: 
  • Профессия: Ученик 1С
У меня строго регламентированное задание и в расходной накладной реквезит склад только в табличной части, возможно вобще как-нибудь иначе сделать контроль остатков???


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4524
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6078
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4192
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8485
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8554
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 815
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal