Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 22:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Экспортные переменные  (Прочитано 4732 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlterMann

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-21
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет!
Необходимо передать переменную из модуля формы документа в модуль формы обработки, которая вызывается кнопкой на форме документа. Код такой:
В модуле формы документа:
Перем НомерДок Экспорт
...
Процедура Кнопка1Нажатие2(Элемент)

НомерДок = номер;

ОткрытьФормуМодально("Обработка.СМС_отправка.Форма.Форма");

КонецПроцедуры
Пытаюсь обратиться к этой переменной в процедуре в модуле формы обработки:
Процедура ОбновлениеОтображения()
ОбновитьСтатусСимволы();
     
НомерДокумента= НомерДок;               
 
КонецПроцедуры
Ошибку не выдает, но переменная НомерДокумента пуста.


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
чтобы в форме обработки были какие-то переменные из документа, туда (в обработку) надо что-то передать - либо значения самих этих переменных, либо указать владельцем форму обработки форму документа.
короче говоря вариантов 2:
1. указываем владельца при открытии формы
Процедура Кнопка1Нажатие2(Элемент)
НомерДок = номер;
ОткрытьФормуМодально("Обработка.СМС_отправка.Форма.Форма",, ЭтаФорма);
КонецПроцедуры
и потом через владельца обращаемся к переменной
Процедура ОбновлениеОтображения()
ОбновитьСтатусСимволы();
НомерДокумента= ВладелецФормы.НомерДок;
КонецПроцедуры

2. либо в форме, которая открывается модально определяем экспортную переменную либо реквизит формы, допустим с именем НомерДокумента. Тогда открытие форму будет осуществляться кодом
Процедура Кнопка1Нажатие2(Элемент)
//НомерДок = номер;
//ОткрытьФормуМодально("Обработка.СМС_отправка.Форма.Форма",, ЭтаФорма);
ФормаОбработки = Обработки.СМС_отправка.ПолучитьФорму("Форма");
ФормаОбработки.НомерДокумента = номер;
ФормаОбработки.ОткрытьМодально();
КонецПроцедуры

Оффлайн AlterMann

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-21
  • Сайт: 
  • Профессия: Ученик 1С
:zebzdr: Большое спасибо, mixqn, выручил.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 325
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal