Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 05:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ограничение редактирование чужих документов  (Прочитано 6769 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Онлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Приветствую программисты 1С, подскажите такую вещь.  Пользователь 1 создает документ, получается он ответственный,  пользователь 2 может зайти в  документ пользователя 1 и изменить его. Ниже представлен код то что Пользователь 2  заходит в документ пользователя 1  и изменить не может.


Пишу код :



Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)


Если (НЕ ЭтоНовый()) И (Ответственный <> ИмяПользователя()) Тогда Сообщить("Вам запрещено редактировать данный документ");
КонецЕсли;


КонецПроцедуры


Вроде бы все нормально, редактирование запрещено. А как сделать так если у Пользователя 3 есть полный права то он смог бы редактировать и изменять документы пользователей.





Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
ну пропиши что если у пользователя Роль администратор то давать изменять!
	Если РольДоступна("ПолныеПрава") Тогда
Отказ = Ложь;
КонецЕсли;
Помогли, отблагодари!

Онлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С

если я правильно понял вас то получится так
Если (НЕ ЭтоНовый()) И (Ответственный <> ИмяПользователя()) Тогда Сообщить("Вам запрещено редактировать данный документ");
   ИначеЕсли РольДоступна("ПолныеПрава") Тогда Отказ=Ложь;   
   КонецЕсли;
прописал, ни че не изменилось.

Оффлайн Msoul

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-04-19
  • Сайт: 
Если НЕ ( ЭтоНовый() ИЛИ Ответственный = ИмяПользователя() ИЛИ РольДоступна("ПолныеПрава") )  
Тогда
    Сообщить("Вам запрещено редактировать данный документ");
    Отказ=ИСТИНА;   
КонецЕсли;


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Если (НЕ ЭтоНовый()) И (Ответственный <> ИмяПользователя() И НЕ РольДоступна("ПолныеПрава")) Тогда 
Сообщить("Вам запрещено редактировать данный документ");
Отказ=Истина;
КонецЕсли;

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А что случилось с Тэгом перевода строки в коде?


Добавлено: 30 Янв 2013, 21:10

Гугл хром
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Dethmontt, что-то поломалось... неизвестно, что. надеюсь, получится починить в ближайшее время.

Онлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
 
Если (НЕ ЭтоНовый()) И (Ответственный <> ИмяПользователя() И НЕ РольДоступна("ПолныеПрава")) Тогда 
Сообщить("Вам запрещено редактировать данный документ");
Отказ=Истина;
КонецЕсли;

парни такое дело получается, под другим пользователем открываю документ и выскакивает ошибка

{Документ.ПоступлениеТоваровУслуг.Форма.ФормаДокумента.Форма(37)}: Ошибка при вызове метода контекста (Записать)
   ЭтотОбъект.Записать();         
по причине:
Не удалось записать "Поступление товаров и услуг 000000064 от 14.01.2013 16:04:06"!

ругается на эту процедуру  которая находится "Форма Документа" модуль формы.

Процедура ЗаполнитьТекстПроСчетФактуру() Экспорт

   ЭлементыФормы.ГиперссылкаСчетФактура.Заголовок = ПолучитьТекстСчетаФактуры(
                                                    НайтиПодчиненныйДокумент(Ссылка, "СчетФактураПолученный"));
                СчетФактураПолученная=  НайтиПодчиненныйДокумент(Ссылка, "СчетФактураПолученный");
   ЭтотОбъект.Записать();         

КонецПроцедуры // ЗаполнитьТекстПроСчетФактуру()





Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ну оно логично, что ругается на эту строку - тут же попытка записи, а права записи мы пользователю не оставили.
а что за конфигурация? странно, что в форме что-то записывается.

Онлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Конфигурация старенькая, СнабжениеИСклад, редакция 1.0 (2.1.2.1.2).

и как решить данную проблему ?!

 
Добавлено: 31 Янв 2013, 09:55

а если такой вариант в форме документа написать

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Если Не ЭтоНовый() И  Не Ссылка.Ответственный = ПараметрыСеанса.ТекущийПользователь тогда
ЭтаФорма.ТолькоПросмотр = Истина;
КонецЕсли;
Конецпроцедуры

Последний раз редактировалось: ls600; 31 Янв 2013, 09:55


Теги:
 

Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3175
Последний ответ 21 Мар 2015, 20:24
от дфтын
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4092
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 169
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3018
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1781
Последний ответ 24 Янв 2014, 13:55
от mspuz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 223
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal