Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 01:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получение значения валюты Евро из справочника  (Прочитано 7820 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Graf_Vorontsov

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Ученик 1С
мне нужно получить значение текущего курса введёное в справочнике и отображаемое на данный момент.
Не получается.


Пытаюсь получить текущий курс валюты (Евро) из базы 1с 7.7


в этом случае выводит деление на ноль!

Валюта=СоздатьОбъект("Справочник.Валюты");
Валюта.НайтиПоКоду("978");
Валюта = Валюта.ТекущийЭлемент();

а в этом не работает тоже


Валюта = Создатьобъект("Справочник.Валюты");
Валюта.ВыбратьЭлементы(978);
Валюта.НайтиПоКоду(978);
Курс=Валюта.ПолучитьЭлемент(978);
Курс=Валюта.Курс.Получить(ТекущаяДата());





Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Курс это периодический элемент! Для его получения нужно указать дату на которую вы хотите получить курс!
Помогли, отблагодари!

Оффлайн Graf_Vorontsov

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Ученик 1С
так я и пишу что на текущую дату ТекущаяДата()
Валюта = Валюта.ВалютаПродажи.получить(ТекущаяДата());

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
	Валюта = Создатьобъект("Справочник.Валюты");
Если Валюта.НайтиПоКоду(978) = 1 Тогда
Валюта.ТекущийЭлемент();
Курс=Валюта.Курс.Получить(ТекущаяДата());
КонецЕсли;
Сообщить(Курс)
Помогли, отблагодари!

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
извиняюсь за оффтоп.

а у всех примеры кода в одной строке показываются или это мой браузер тупит?

Оффлайн Graf_Vorontsov

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Ученик 1С
не пойму, выдаёт какоето значение непонятное...
у меня далее идёт вот что
ТабПартии.Цена_Прод = ((ЦенаПродажи * Константа.КоэффициентПродажи.получить(ТекущаяДата())) / Курс);
результат получается вообще как попало, а должно пересчитывать гривну в евро

вот так получается
ТабПартии.Цена_Прод = ((ЦенаПродажи * Константа.КоэффициентПродажи.получить(ТекущаяДата())) / 11.5)
т.е. когда вручную пишу нужное число, но не считывает его автоматом......
Добавлено: 29 Янв 2013, 15:56

извиняюсь за оффтоп.

а у всех примеры кода в одной строке показываются или это мой браузер тупит?
у меня также. браузер Хром

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
извиняюсь за оффтоп.

а у всех примеры кода в одной строке показываются или это мой браузер тупит?
Та же фигня! Мазила! Надо админам сказать!
Помогли, отблагодари!

Оффлайн Graf_Vorontsov

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Ученик 1С
может у меня не так что-то в этом куске кода.. хотя работает, гривну выводит. полностью код привёл
Цитировать
         Ит.ВыбратьСубконто(ВидыСубконто.Партии);
         Пока Ит.ПолучитьСубконто(ВидыСубконто.Партии) = 1 Цикл
            
               ТабПартии.НоваяСтрока();
               ТабПартии.ТМЦ = Ит.Субконто(2);
               ТабПартии.Партия = Ит.Субконто(3);
               ТабПартии.Цена_Прих = глПересчет(ТабПартии.Партия.Цена_Прих,Гривня,Константа.Валютапродажи.получить(ТекущаяДата()),ТабПартии.Партия.Дата_Прих);

               ТабПартии.Дата_Прих = ТабПартии.Партия.Дата_Прих;
               ТабПартии.Остаток = Ит.СКД(3);
               СтарВал=Константа.Валютапродажи.получить(ТабПартии.Партия.Дата_Прих);
               Старыйкурс=СтарВал.Курс.получить(ТабПартии.Партия.Дата_Прих);
               НовВал=Константа.Валютапродажи.получить(ТекущаяДата());
               Новыййкурс=НовВал.Курс.получить(ТекущаяДата());
               ЦенаПродажи=0;
               если Старыйкурс=0 тогда
                  ЦенаПродажи=0;
               иначе
                  ЦенаПродажи = ТабПартии.Партия.Цена_Прих / Старыйкурс * Новыййкурс;
                  
               конецесли;
                        
               //**************

                     Валюта = Создатьобъект("Справочник.Валюты");

               Если Валюта.НайтиПоКоду(978) = 1 Тогда
               Валюта.ТекущийЭлемент();     
               Курс=Валюта.Курс.Получить(ТекущаяДата());
               КонецЕсли;
               Сообщить(Курс);

               //***************

               ТабПартии.Цена_Прод = ((ЦенаПродажи * Константа.КоэффициентПродажи.получить(ТекущаяДата())) / Курс);
               
            
         КонецЦикла;

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
У Гривня курс не 1 равен?
Помогли, отблагодари!

Оффлайн Graf_Vorontsov

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Ученик 1С
да 1 и кратность 1
а евро 1,150 и кратность 100


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 227
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal