Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Неправильно считаются копейки НДС и Суммы в первичных документах  (Прочитано 11291 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн anya25

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-28
  • Сайт: 
  • Профессия: Бухгалтер
Скажите пожалуйста, что надо исправить,чтобы наша программа при вводе количества и цены правильно выводила копейки НДС и суммы в первичных документах?? И можно ли сделать столбец "Всего" редактируемым, чтобы все остальное считалось от него????1С: 7.7 версия 4,5


Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Скажите пожалуйста, что надо исправить,чтобы наша программа при вводе количества и цены правильно выводила копейки НДС и суммы в первичных документах??

что значит правильно или неправильно?

Цитировать
И можно ли сделать столбец "Всего" редактируемым, чтобы все остальное считалось от него????1С: 7.7 версия 4,5

можно.

1. нужно снять галку "Сделать недоступным" в свойствах колонки и еще необходимо проверить модули на случай, если доступность/недоступность устанавливается программно.

2. а чтобы считалось от него, пишите процедуру которая будет рассчитывать нужные значения от "Всего"

Оффлайн anya25

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-28
  • Сайт: 
  • Профессия: Бухгалтер
Скажите пожалуйста, что надо исправить,чтобы наша программа при вводе количества и цены правильно выводила копейки НДС и суммы в первичных документах??

что значит правильно или неправильно?

Цитировать
И можно ли сделать столбец "Всего" редактируемым, чтобы все остальное считалось от него????1С: 7.7 версия 4,5

можно.

1. нужно снять галку "Сделать недоступным" в свойствах колонки и еще необходимо проверить модули на случай, если доступность/недоступность устанавливается программно.

2. а чтобы считалось от него, пишите процедуру которая будет рассчитывать нужные значения от "Всего"
Спасибо за ответ!!Неправильно-значит от руки получается другая сумма. а можно подробней,где и что менять...а то я чисто бухгалтер и никогдва не лазила в конфигураторе.
Добавлено: 28 Янв 2013, 13:21

Неправильно-значит "всего" выводит с копейками. Например:12шт*10р.=120руб., а в программе без НДС 12*8,47=101,64, ндс 18,29(18,30-в программе) всего без ндс=101,71(101,64- в прогр) и естественно всего=120(119,94-в программе)
Добавлено: 28 Янв 2013, 13:32

Процедура Пересчет(ИмяРеквизита="")
      
   Если ИмяРеквизита = "" Тогда // вызов из формулы колонки табличной части
       ИмяРеквизита = Форма.ТекущаяКолонка();
   КонецЕсли;

   Если Товар.Выбран() = 1 Тогда
      Если (ИмяРеквизита = "Товар") Тогда
         Цена = глПолучитьЦену(Контекст,Товар,ТипЦен,ДатаДок,Валюта);
         //глСуммаДокумента(Контекст, Товар);
         Если Количество <> 0 Тогда
            Пересчет("Цена");
         КонецЕсли;
      ИначеЕсли (ИмяРеквизита = "Количество") Тогда
         Сумма = Цена*Количество;
         РассчитатьНалоги();
       ИначеЕсли (ИмяРеквизита = "Цена") Тогда
         Сумма = Цена*Количество;
         РассчитатьНалоги();
      ИначеЕсли (ИмяРеквизита = "Сумма") Тогда
         РассчитатьНалоги();
         Цена = ?(Количество = 0, Сумма, Сумма/Количество);
      ИначеЕсли (ИмяРеквизита = "НДС") или (ИмяРеквизита = "НП") Тогда
   Всего = глПоказательДокумента(Контекст, "СуммаСНалогами");
      КонецЕсли;
   КонецЕсли;

КонецПроцедуры // Пересчет()
может тут "Всего" поменять надо????

Последний раз редактировалось: anya25; 28 Янв 2013, 13:32

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Цена без НДС и НДС у вас правильно сохраняются, проблемы только с колонкой "Всего"? я правильно вас понял?

это известная проблема в приходной.

пересчет от всего тоже ничего не решит , потому что тогда цена без ндс и ндс могут также расходиться с суммами поставщика.

Для решения - следует в справочнике "товары" создать служебный товар, например - "Округление 18%" и "Округление 10%", который добавлял бы недостающие копейки для общей суммы в колонке "Всего".

Оффлайн anya25

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-28
  • Сайт: 
  • Профессия: Бухгалтер
Мы производители и при отгрузке возникает эта проблема...дело не в округлении как я поняла...если я смогу менять "Всего" и от него будет идти расчет-это будет самое то, чего хотели покупатели.

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Мой совет - Обратитесь к местным специалистам.



Добавлено: 28 Янв 2013, 16:44

дело не в округлении как я поняла.

именно в округлении. у вас ндс = 18.2952, данная сумма округляется до двух знаков в большую сторону (по этому правилу 1,5 округляется до 2), т.е у вас в программе и получилось 18.30.




Добавлено: 28 Янв 2013, 18:05

И кстати, а вариант налогов "НДС в сумме" вас не устраивает?

Последний раз редактировалось: Herby; 28 Янв 2013, 18:05


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
156 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 276
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal