Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Июл 2017, 07:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вызов процедуры из модуля документа в модуле формы  (Прочитано 11930 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlterMann

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-21
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
Вопрос такой. Не получается вызвать процедуру из модуля документа в модуль формы. Код такой:

МОДУЛЬ ОБЪЕКТА (документа)
...
процедура ОбработкаПроведения(Отказ, РежимПроведения) экспорт
...
 
МОДУЛЬ ФОРМЫ ДОКУМЕНТА

&НаКлиенте

Процедура Печать(Команда)
...
ОбработкаПроведения(Отказ, РежимПроведения);


Выдается ошибка: процедура с именем ОбработкаПроведения () не определена.


Онлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2853
  • РЕПУТАЦИЯ: 545
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В форме
&НаСервере
Процедура гПровестиДокумент()
   Объект.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры
Добавлено: 28 Янв 2013, 11:04

И прочтите это
http://www.cyberforum.ru/1c/thread764261-page2.html#post4033102
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн AlterMann

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-21
  • Сайт: 
  • Профессия: Ученик 1С
В форме
&НаСервере
Процедура гПровестиДокумент()
   Объект.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры
Выдает ту же ошибку. :(

Онлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2853
  • РЕПУТАЦИЯ: 545
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн AlterMann

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-21
  • Сайт: 
  • Профессия: Ученик 1С
Модуль документа.
Процедура ОбработкаПроведения(Отказ, РежимПроведения)  Экспорт
             
Если ПроверитьЗаполнение() Тогда
ДвиженияДоставленныеПакинги = Движения.хз_ДоставленныеПакинги;
ДвиженияДоставленныеПакинги.Записывать = Истина;

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | хз_ПакингДоставочныеЛисты.Ссылка КАК Пакинг,
               | хз_ПакингДоставочныеЛисты.ЗаказПокупателя,
               | хз_ПакингДоставочныеЛисты.Ссылка.Дата КАК Период,
               | хз_ПакингДоставочныеЛисты.Ссылка.СтатусДоставки
               |ИЗ
               | Документ.хз_Пакинг.ДоставочныеЛисты КАК хз_ПакингДоставочныеЛисты
               |ГДЕ
               | хз_ПакингДоставочныеЛисты.Ссылка = &Ссылка
               | И (хз_ПакингДоставочныеЛисты.Отгружен
               | ИЛИ хз_ПакингДоставочныеЛисты.Ссылка.СтатусДоставки = ЗНАЧЕНИЕ(Перечисление.хз_СтатусДоставки.ВПути))";
Запрос.УстановитьПараметр("Ссылка", Ссылка);
РезультатЗапроса = Запрос.Выполнить();

Если Не РезультатЗапроса.Пустой() Тогда
ДвиженияДоставленныеПакинги.Загрузить(РезультатЗапроса.Выгрузить());

КонецЕсли;

Иначе
ОбщегоНазначения.СообщитьОбОшибке("Не заполнены все обязательные реквизиты!", Отказ);

КонецЕсли;
 

КонецПроцедуры
Модуль формы.
&НаСервере
Процедура гПровестиДокумент()
Объект.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры

&НаКлиенте
Процедура Печать(Команда)
РежимПроведения = РежимПроведенияДокумента.Неоперативный;
отказ = ложь;


ОбработкаПроведения(Отказ, РежимПроведения);


ОбъектДокумента = РеквизитФормыВЗначение("Объект");
ИмяКлюча = "ПечатьДоставочногоЛиста" + "ВКоличестве";

ЗаданиеНаПечать = Новый Структура();
ЗаданиеНаПечать.Вставить("ПечатьДоставочногоЛиста", "ПечатьДоставочногоЛиста");
ЗаданиеНаПечать.Вставить(ИмяКлюча, 1);

ПечатьКомплектаДокументов(ЗаданиеНаПечать);

КонецПроцедуры

Онлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2853
  • РЕПУТАЦИЯ: 545
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
//В модуле объекта описываем поведение проведения документа
&НаКлиенте
Процедура ПровестиМойДокумент() //В форме документа
    гПровестиДокумент();
КонецПроцедуры

&НаСервере
Процедура гПровестиДокумент() //В форме документа
      Об = РеквизитФормыВЗначение("Объект");
   Об.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
а вот по  тойже схеме, мне нужно вызвать процедуру печати из общего модуля внешней обработки, на форму этой обработки, там есть кнопочка печать и при нажатии формируется макет.
там типа такого?
&НаКлиенте
Процедура Печать(Команда)

Макет = ПолучитьМакетНаСервере();

КонецПроцедуры

&НаСервере
функция СформироватьМакетНаСервере()
ЭтотОбъект1 = РеквизитФормыВЗначение("Объект");
Макет = ЭтотОбъект1.Печать();
Возврат Макет;
КонецФункции


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4189
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14650
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3760
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 284
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7225
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
116 Сообщений
alex0402
102 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
Golickoff Golickoff
49 Сообщений
ilyay ilyay
49 Сообщений
AIFrame
49 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 173
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal