Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите начинающему, пожалуйста.  (Прочитано 1211 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн iturkin

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-05-06
  • Сайт: 
Не могу понять, где туплю...


Процедура НажатиеОК(Элемент)

ВыборкаДокументов = Документы.ПоступлениеТоваровУслуг.Выбрать(НачалоПериода, КонецПериода);

Пока ВыборкаДокументов.Следующий() Цикл
   Докум=ВыборкаДокументов.ссылка;
   Для Каждого Рекв из Докум.Товары Цикл
      Товар=Рекв.Номенклатура;
      Рекв.НомерГТД= Товар.НомерГТД;
   КонецЦикла;
      Докум.Записать();
КонецЦикла;    

Сообщение об ошибке:   
Поле объекта недоступно для записи (НомераГТД)


Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
ВыборкаДокументов.Ссылка - это ссылка на документ. И хотя по ней можно получить значения полей, но записать нельзя. Для получения объекта для записи существует функция ПолучитьОбъект().
Таким образом,
Пока ВыборкаДокументов.Следующий() Цикл
   Докум=ВыборкаДокументов.Ссылка.ПолучитьОбъект();
   Для Каждого Рекв из Докум.Товары Цикл
      Товар=Рекв.Номенклатура;
      Рекв.НомерГТД= Товар.НомерГТД;
   КонецЦикла;
      Докум.Записать();
КонецЦикла;   
будет записывать корректно.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4290
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5546
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5882
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4361
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1975
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 338
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal