Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 09:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обход табличной части  (Прочитано 4689 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KFan0

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-25
  • Сайт: 
  • Профессия: Ученик 1С
&НаКлиенте
Процедура ДобавитьТестируемого(Команда)
Для Каждого СтрокаТаблицы из Элементы.Студенты Цикл
Если СтрокаТаблицы.Пользователь <> 0 Тогда
СоздатьНовоеТестирование(СтрокаТаблицы);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

&НаСервере
Процедура СоздатьНовоеТестирование(СтрокаТаблицы)
Документ = Документы.Тестирование.СоздатьДокумент();
Документ.Тест = СтрокаТаблицы.Тест;
//Документ.Пользователь =
КонецПроцедуры

На строчке "Для Каждого СтрокаТаблицы из Элементы.Студенты Цикл" выдает ошибку "Итератор для значения не определен", в чем может быть ошибка?

P.S. все это делается в отчете, и срабатывает по нажатию кнопки "Сформировать"


Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
посмотрите здесь
Помогли, отблагодари!

Оффлайн KFan0

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-25
  • Сайт: 
  • Профессия: Ученик 1С
посмотрите здесь
Мне это ничего не дало, я смотрел в интернете, не один час, по разным запросам

В некоторых местах советуют использовать переменную Объект, но не на сервере, не на клиенте, этой переменной у меня нет

Оффлайн sertak

  • ****
  • Сообщений: 323
  • РЕПУТАЦИЯ: 92
  • КПД: 28%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: infostart.ru
Элементы.Студенты - это элемент формы, его нельзя перебрать в 8.2. Этот элемент получает данные из реквизита - табличной части. Эту табличную часть и надо перебирать:
Для Каждого СтрокаТаблицы из ТЧСтуденты Цикл
    Если СтрокаТаблицы.Пользователь <> 0 Тогда
        СоздатьНовоеТестирование(СтрокаТаблицы);   
    КонецЕсли;
КонецЦикла;
Узнать имя табличной части можно через свойство элемента формы Студенты "Путь к данным". Табличная часть может называться так же, как и соответствующий ей элемент формы (который вы пытаетесь перебрать).

Оффлайн KFan0

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-25
  • Сайт: 
  • Профессия: Ученик 1С
Элементы.Студенты - это элемент формы, его нельзя перебрать в 8.2. Этот элемент получает данные из реквизита - табличной части. Эту табличную часть и надо перебирать:
Для Каждого СтрокаТаблицы из ТЧСтуденты Цикл
    Если СтрокаТаблицы.Пользователь <> 0 Тогда
        СоздатьНовоеТестирование(СтрокаТаблицы);   
    КонецЕсли;
КонецЦикла;
Узнать имя табличной части можно через свойство элемента формы Студенты "Путь к данным". Табличная часть может называться так же, как и соответствующий ей элемент формы (который вы пытаетесь перебрать).


Огромное спасибо!


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2373
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3328
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3434
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 793
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 412
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
50 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
30 Сообщений

* Кто онлайн

  • Точка Гостей: 151
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal