Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите  (Прочитано 5421 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Чингисхан

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-24
  • Сайт: 
  • Профессия: Бухгалтер
помогите
« Первое сообщение: 24 Янв 2013, 11:21 »
помогите пожалуйста у меня выходит преобразование значения к типу число не может быть выполнено я в этом не разбераюсь в конфигураторе выходит вот это
////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ РАБОТЫ С ВАЛЮТАМИ

// Эта функция пересчитывает сумму из валюты ВалютаНач по курсу ПоКурсуНач
// в валюту ВалютаКон по курсу ПоКурсуКон
//
// Параметры:     
//  Сумма          - сумма, которую следует пересчитать;
//  ВалютаНач      - ссылка на элемент справочника Валют;
//                   определяет валюты из которой надо пересчитвать;
//  ВалютаКон      - ссылка на элемент справочника Валют;
//                   определяет валюты в которую надо пересчитвать;
//  ПоКурсуНач     - курс из которого надо пересчитать;
//  ПоКурсуКон     - курс в который надо пересчитать;
//  ПоКратностьНач - кратность из которого надо пересчитать (по умолчанию = 1);
//  ПоКратностьКон - кратность в который надо пересчитать  (по умолчанию = 1);
//
// Возвращаемое значение:
//  Сумма, пересчитанная в другую валюту
//
Функция ПересчитатьИзВалютыВВалюту(Сумма, ВалютаНач, ВалютаКон, ПоКурсуНач, ПоКурсуКон,
                  ПоКратностьНач =1, ПоКратностьКон = 1 ) Экспорт

   Если (ВалютаНач = ВалютаКон) Тогда

      // Считаем, что пересчет не нужен.
      Возврат Сумма;
   КонецЕсли;

   Если (ПоКурсуНач = ПоКурсуКон)
      и (ПоКратностьНач = ПоКратностьКон) Тогда

      // ну, тут и считать нечего...
      Возврат Сумма;
   КонецЕсли;

   Если ПоКурсуНач     = 0
    или ПоКурсуКон     = 0
    или ПоКратностьНач = 0
    или ПоКратностьКон = 0 Тогда
      ОбщегоНазначения.СообщитьОбОшибке("ПересчитатьИзВалютыВВалюту(): при пересчете обнаружен нулевой курс.");
      Возврат 0;
   КонецЕсли;

   Возврат Окр((Сумма * ПоКурсуНач * ПоКратностьКон) / (ПоКурсуКон * ПоКратностьНач), 2);

КонецФункции //ПересчитатьИзВалютыВВалюту()

// Возвращает курс валюты на дату
//
// Параметры:
//  Валюта     - Валюта (элемент справочника "Валюты")
//  ДатаКурса  - Дата, на которую следует получить курс
//
// Возвращаемое значение:
//  Структура, содержащая:
//   Курс      - курс валюты
//   Кратность - кратность валюты
//
Функция ПолучитьКурсВалюты(Валюта, ДатаКурса) Экспорт

   Структура = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(ДатаКурса, Новый Структура("Валюта", Валюта));
   Возврат Структура;
   
КонецФункции // ПолучитьКурсВалюты()

// Проверяет наличие установленного курс аи кратности валюты на 1 января 1980 года.
// В случае отсутствия устанавливает курс и кратность равными единице.
//
// Параметры:
//  Валюта - ссылка на элемент справочника Валют
//
Процедура ПроверитьКорректностьКурсаНа01_01_1980(Валюта) Экспорт

   ДатаКурса = Дата(1980, 1, 1);
   СтруктураКурса = ПолучитьКурсВалюты(Валюта, ДатаКурса);

   Если (СтруктураКурса.Курс = 0) Или (СтруктураКурса.Кратность = 0) Тогда

      // установим курс и кратность = 1 на 01.01.1980, чтобы не было ошибок при создании документов

      РегистрКурсыВалют = РегистрыСведений.КурсыВалют.СоздатьМенеджерЗаписи();

      РегистрКурсыВалют.Период    = ДатаКурса;
      РегистрКурсыВалют.Валюта    = Валюта;
      РегистрКурсыВалют.Курс      = 1;
      РегистрКурсыВалют.Кратность = 1;
      РегистрКурсыВалют.Записать();

   КонецЕсли;

КонецПроцедуры // ПроверитьКорректностьКурсаНа01_01_1980()



Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Re: помогите
« Ответ #1: 24 Янв 2013, 11:32 »
На какую переменную он ругается?
Помогли, отблагодари!

Оффлайн Чингисхан

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-24
  • Сайт: 
  • Профессия: Бухгалтер
Re: помогите
« Ответ #2: 24 Янв 2013, 11:37 »
На какую переменную он ругается?
:dfbsdfbsdf:  ты вот это имеешь ввиду
Ошибка при выполнении обработчика - '{ОбщийМодуль.МодульВалютногоУчета(45)}: Преобразование значения к типу Число не может быть выполнено'
по причине:
{ОбщийМодуль.МодульВалютногоУчета(45)}: Преобразование значения к типу Число не может быть выполнено

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Re: помогите
« Ответ #3: 24 Янв 2013, 11:41 »
Скорее всего вы не правильно передаете параметр для процедуры или функции! Напишите откуда вы запускаете эти процедуры и функции! Что вы делаете? Какой документ используете? Какая у вас конфигурация?
Помогли, отблагодари!

Оффлайн Чингисхан

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-24
  • Сайт: 
  • Профессия: Бухгалтер
Re: помогите
« Ответ #4: 24 Янв 2013, 11:48 »
Скорее всего вы не правильно передаете параметр для процедуры или функции! Напишите откуда вы запускаете эти процедуры и функции! Что вы делаете? Какой документ используете? Какая у вас конфигурация?

поступления хочу заносить не получается


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4300
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5556
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5895
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4381
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1982
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 129
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal