Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 14:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1C+Excel  (Прочитано 2049 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
1C+Excel
« Первое сообщение: 22 Янв 2013, 10:56 »
Всем привет, может кто сталкивался с выводом в excel файл?
В цикле вывожу данные так, вывожу в шаблон xls файл поэтому нужно чтобы при выводе этих данных строчки сдвигались:

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

РабочийЛист.Cells(СтрокаШапки,КолонкаНомера).Value=НомерСтроки;
РабочийЛист.Cells(СтрокаШапки,КолонкаФамилии).Value=Фамилия;
РабочийЛист.Cells(СтрокаШапки,КолонкаФамилии).Value=Имя;
РабочийЛист.Cells(СтрокаШапки,КолонкаФамилии).Value=Отчество;
НомерСтроки=НомерСтроки+1;

КонецЦикла;

Так же еще проблема вот например я вывожу подряд строчки и если строки в xls файле объединенные, то как очистить их при выводе?

СПАСИБО!



Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Re: 1C+Excel
« Ответ #1: 22 Янв 2013, 11:15 »
Какие строчки куда сдвигались? Вы в одну и ту же строку (СтрокаШапки) выводите данные на каждой итерации, а надо каждый раз брать следующую строку. Фамилия, Имя, Отчество должно быть в разных колонках или соединиться в одну?
Как вариант:
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    РабочийЛист.Cells(СтрокаШапки+НомерСтроки,КолонкаНомера).Value=НомерСтроки;

    // дальше так
    РабочийЛист.Cells(СтрокаШапки+НомерСтроки,КолонкаФамилии).Value=Фамилия;
    РабочийЛист.Cells(СтрокаШапки+НомерСтроки,КолонкаИмени).Value=Имя;
    РабочийЛист.Cells(СтрокаШапки+НомерСтроки,КолонкаОтчества).Value=Отчество;
    // или так
    РабочийЛист.Cells(СтрокаШапки+НомерСтроки,КолонкаФамилии).Value=Фамилия+" "+Имя+" "+Отчество;

    НомерСтроки=НомерСтроки+1;
КонецЦикла;
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Re: 1C+Excel
« Ответ #2: 22 Янв 2013, 12:00 »
Они должны быть в разных колонках....
я сделал, так:
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Лист.Rows(СтрокаШапки+Номер).Insert();
Лист.Cells(СтрокаШапки+Номер,КолонкаНомера).Value=Номер+1;

Лист.Cells(СтрокаШапки+Номер,КолонкаФамилии).Value=ФФамилия;
Лист.Cells(СтрокаШапки+Номер,КолонкаИмени).Value=ФИмя;
Лист.Cells(СтрокаШапки+Номер,КолонкаОтчества).Value=ФОтчество;
Лист.Cells(СтрокаШапки+Номер,КолонкаНомераСчета).Value=ВыборкаДетальныеЗаписи.НомерЛицевогоСчета;
Лист.Cells(СтрокаШапки+Номер,КолонкаСуммы).Value=ВыборкаДетальныеЗаписи.Сумма+ВыборкаДетальныеЗаписи.КомпенсацияЗаЗадержкуЗарплаты;

Номер=Номер+1;

КонецЦикла;
Лист.Rows(СтрокаШапки+Номер).Insert();

Но теперь проблема!!! Первая строка, т.е. СтрокаШапки остается пустой, как ее потом после вывода удалить?)))

И еще вопрос как потом это еще обвести как таблицу?)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: 1C+Excel
« Ответ #3: 22 Янв 2013, 12:03 »
Открываем ЭКСЕЛЬ(Любую книгу) жмем Alt+F11 - Там есть помощник (жмем F1) Ищем и Внимательно читаем!!!
Добавлено: 22 Янв 2013, 12:04

Читаешь либо про Cells либо про Range
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Re: 1C+Excel
« Ответ #4: 22 Янв 2013, 12:24 »
удалил, оказывается легко, осталось разобраться с рамкой, тобишь с Border=) :befhbt:


Теги:
 

Круглый стол "Автоматизация учета и отчетности по МСФО: Excel против программных продуктов"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1696
Последний ответ 10 Сен 2014, 10:25
от mixqn
работа с файлами excel открытие файла xls, чтение данных и запись нового файла xls

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2809
Последний ответ 11 Фев 2016, 12:49
от Rasty
Внешняя компонента для прямого чтения файлов Excel всех версий

Автор CrazyDaveРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2107
Последний ответ 01 Мар 2012, 16:23
от CrazyDave
Не создается COM объект Excel.Application, хотя всё установлено и права есть

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 7214
Последний ответ 23 Июл 2015, 14:25
от vitasw
Алгоритм загрузки изображений из excel по ссылке URL в реквизит основное изображение

Автор nikioioioРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1000
Последний ответ 23 Мар 2016, 05:43
от nikioioio

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
69 Сообщений
ilyay ilyay
65 Сообщений
alex0402
51 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 858
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal