Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 12:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перенос данных из одной базы в другую (однотипные)  (Прочитано 4225 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dima-irk38

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-06
  • Сайт: 
  • Профессия: Программист 1С
Имеется 2-ве базы конфигурация Континет:Страхование на 7.7, в один филиал переносит бухгалтерию в Иркутск, необходимо. Из филиал №1 перенести все действующие договора страхование (объект Справочник), и содержимое одного из документов + 2-ве из 3-х проводок к нему. Нужно сделать самому, в каком направлении двигаться, навыки программирование небольшие есть, базы одинаковые.


Оффлайн sertak

  • ****
  • Сообщений: 323
  • РЕПУТАЦИЯ: 92
  • КПД: 28%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: infostart.ru
В интернетах есть всяческие стандартные обработки выгрузки из любых объектов в файлы, и, соответственно, загрузки в любые объекты из файлов. Для примитивных перегрузок очень даже подходит. На диске ИТС даже должно быть.
Есть конфигурация Конвертация данных. Но ее надо курить.

Оффлайн dima-irk38

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-06
  • Сайт: 
  • Профессия: Программист 1С
Вообщем что-то я намутил (( Перенес справочники и документы, делал самописную обработку т.к переносить нужно, только часть элементов из справочника, но проблема реквизиты, которые ссылаются на справочники все пустые ( Делал перенос через текстовый файл!! ((

Бухгалтер говорит, что можно не заполнять все реквизита справочника, достаточно основных. Вообщем я импортировал справочники и импортирую документ, хочу во время создания документа связывать его с соответствующим справочником, но когда ищу его по реквизиту номер пишет Неизвестный объект. (Код выложу внизу + обработку).

Момент второй, документ нужно проводить, но нужно в операции изменить одну проводку и одну удалить. Это возможно, когда провожу вновь созданный докуент ругается на валюты.

Еще очень интересная вещь - это периодические реквизиты, для меня что-то темное и непонятное, но хочу разобраться.

Да и вообще код у меня просто не оптимизированный и громоский. Ну в принцепи оч. хочу научиться. Подскажите че неправильно, жру разумную критику.

перем СпрДогСтр, Текст, Список, Стр;

Процедура ЗагрузитьД()
СпрДогСтр = СоздатьОбъект("Справочник.ДоговораСтрахования");
СпрДогСтр.ИспользоватьДату(ТекущаяДата());
Текст = СоздатьОбъект("Текст");
Список = СоздатьОбъект("СписокЗначений");
ТЧ = СоздатьОбъект("ТаблицаЗначений");
ТЧ.НоваяКолонка("ВидСтрахования");
ТЧ.НоваяКолонка("ПремияРуб");
ТЧ.НоваяКолонка("ПремияВал");
ТЧ.НоваяКолонка("ОтвРуб");
ТЧ.НоваяКолонка("ОтвВал");
Текст.Открыть("D:\1234.txt");

Док = СоздатьОбъект("Документ.НачислениеПоДоговору");
Для номер=1 по Текст.КоличествоСтрок() Цикл

Стр = Текст.ПолучитьСтроку(номер);
Список.ИзСтрокиСРазделителями(Стр);
НомерД = Список.ПолучитьЗначение(1);
Док.Новый();
СпрДогСтр.ВыбратьЭлементы();
Пока СпрДогСтр.ПолучитьЭлемент() = 1 Цикл
Сообщить("Пеерево р идет "+СпрДогСтр.ТекущийЭлемент().Номер+"="+НомерД+" - "+СпрДогСтр.ТекущийЭлемент().Договор);
Если СпрДогСтр.Номер = НомерД Тогда
Док.Договор = СпрДогСтр.ТекущийЭлемент().Номер;
Сообщить("++++++++++++++ НАйден = "+"Текущий элемент"+СпрДогСтр.ТекущийЭлемент());
Прервать;
КонецЕсли;
КонецЦикла;
Сообщить("+ "+Список.ПолучитьЗначение(1));
// Док.Договор = Список.ПолучитьЗначение(1);
Док.Агент1 = Список.ПолучитьЗначение(2);
Док.Агент2 = Список.ПолучитьЗначение(3);
Док.Комиссия1 = Число(Список.ПолучитьЗначение(4));
Док.Комиссия2 = Список.ПолучитьЗначение(5);
Док.Валюта = Список.ПолучитьЗначение(6);
Док.Курс = Список.ПолучитьЗначение(7);
Док.Основание = Список.ПолучитьЗначение(8);
Док.ДопС = Список.ПолучитьЗначение(9);
Док.СубСчет77 = Список.ПолучитьЗначение(10);
ТЧ.НоваяСтрока();
ТЧ.ВидСтрахования = Список.ПолучитьЗначение(11);
ТЧ.ПремияРуб = Число(Список.ПолучитьЗначение(12));
ТЧ.ПремияВал = Список.ПолучитьЗначение(13);
ТЧ.ОтвРуб = Список.ПолучитьЗначение(14);
ТЧ.ОтвВал = Список.ПолучитьЗначение(15);
Док.ЗагрузитьТабличнуюЧасть(ТЧ);
Док.Записать();
// Проводим Документ.
//Док.Провести();
ТЧ.УдалитьСтроки();
КонецЦикла;
КонецПроцедуры

Процедура ВыгрузитьД()
М = 0;
Текст = СоздатьОбъект("Текст");
Список = СоздатьОбъект("СписокЗначений");
ТЧ = СоздатьОбъект("ТаблицаЗначений");
Док = СоздатьОбъект("Документ");
Док.ИспользоватьЖурнал("ЖурналНачислений",1);
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент() = 1 Цикл
Если Док.Договор.ДатаОкончания > ТекущаяДата() Тогда
Сообщить("++++++"+Док.Договор);
Список.ДобавитьЗначение(Док.Договор);
Список.ДобавитьЗначение(Док.Агент1);
Список.ДобавитьЗначение(Док.Агент2);
Список.ДобавитьЗначение(Док.Комиссия1);
Список.ДобавитьЗначение(Док.Комиссия2);
Список.ДобавитьЗначение(Док.Валюта);
Список.ДобавитьЗначение(Док.Курс);
Список.ДобавитьЗначение(Док.Основание);
Список.ДобавитьЗначение(Док.ДопС);
Список.ДобавитьЗначение(Док.СубСчет77);
// Выгрузка табличной части
Док.ВыгрузитьТабличнуюЧасть(ТЧ);
ТЧ.ВыбратьСтроки();
Пока ТЧ.ПолучитьСтроку()=1 Цикл
Список.ДобавитьЗначение(ТЧ.ВидСтрахования);
Список.ДобавитьЗначение(ТЧ.ПремияРуб);
Список.ДобавитьЗначение(ТЧ.ПремияВал);
Список.ДобавитьЗначение(ТЧ.ОтвРуб);
Список.ДобавитьЗначение(ТЧ.ОтвВал);
Сообщить("ТЧ"+ТЧ.ВидСтрахования+" "+ТЧ.ПремияРуб+" "+ТЧ.ПремияВал+" "+ТЧ.ОтвРуб+" "+ТЧ.ОтвВал);
КонецЦикла;
Текст.ДобавитьСтроку(Список.ВСтрокуСРазделителями());
Список.УдалитьВсе();
Иначе
Сообщить("-"+Док.Договор);
М = М + 1;
// Если М=10 Тогда
// Прервать;
// КонецЕсли;
КонецЕсли;
КонецЦикла;
Текст.Записать("D:\1234.txt");
КонецПроцедуры
//Кнопка
Процедура Загрузить()
СпрДогСтр = СоздатьОбъект("Справочник.ДоговораСтрахования");
Текст = СоздатьОбъект("Текст");
Список = СоздатьОбъект("СписокЗначений");
Текст.Открыть("D:\123.txt");
СпрДогСтр.ИспользоватьДату(ТекущаяДата());
Для номер=1 по Текст.КоличествоСтрок() Цикл
Стр = Текст.ПолучитьСтроку(номер);
Список.ИзСтрокиСРазделителями(Стр);
Если СпрДогСтр.НайтиПоКоду(Список.ПолучитьЗначение(1))=0 Тогда
Сообщить("+");
СпрДогСтр.Новый();
СпрДогСтр.Код = Список.ПолучитьЗначение(1);
СпрДогСтр.Наименование = Список.ПолучитьЗначение(2);
СпрДогСтр.Агент = Список.ПолучитьЗначение(3);
СпрДогСтр.АгентДС = Список.ПолучитьЗначение(4);
СпрДогСтр.АмортизацияТС = Список.ПолучитьЗначение(5);
СпрДогСтр.Багаж = Список.ПолучитьЗначение(6);
СпрДогСтр.БезКолДог = Список.ПолучитьЗначение(7);
СпрДогСтр.БезОтветствПовреж = Список.ПолучитьЗначение(8);
СпрДогСтр.Бланк = Список.ПолучитьЗначение(9);
СпрДогСтр.Брокер = Список.ПолучитьЗначение(10);
СпрДогСтр.Вагон = Список.ПолучитьЗначение(11);
СпрДогСтр.Валюта = Список.ПолучитьЗначение(12);
СпрДогСтр.ВидБланка = Список.ПолучитьЗначение(13);
СпрДогСтр.ВидВагона = Список.ПолучитьЗначение(14);
СпрДогСтр.ВидСтрахования = Список.ПолучитьЗначение(15);
СпрДогСтр.ВидФраншизы = Список.ПолучитьЗначение(16);
СпрДогСтр.ВсеВиды = Список.ПолучитьЗначение(17);
СпрДогСтр.ВсегоБланковТипа1 = Список.ПолучитьЗначение(18);
СпрДогСтр.ВсегоБланковТипа2 = Список.ПолучитьЗначение(19);
СпрДогСтр.ВсегоБланковТипа3 = Список.ПолучитьЗначение(20);
СпрДогСтр.ВсеОтветств = Список.ПолучитьЗначение(21);
СпрДогСтр.Выгодоприобретатель = Список.ПолучитьЗначение(22);
СпрДогСтр.ГодВыпуска = Список.ПолучитьЗначение(23);
СпрДогСтр.Госномер = Список.ПолучитьЗначение(24);
СпрДогСтр.Груз = Список.ПолучитьЗначение(25);
СпрДогСтр.Дата1 = Список.ПолучитьЗначение(26);
СпрДогСтр.Дата2 = Список.ПолучитьЗначение(27);
СпрДогСтр.ДатаВвода = Список.ПолучитьЗначение(28);
СпрДогСтр.ДатаВводаОплаты = Список.ПолучитьЗначение(29);
СпрДогСтр.ДатаДог = Список.ПолучитьЗначение(30);
СпрДогСтр.ДатаДосроч = Список.ПолучитьЗначение(31);
СпрДогСтр.ДатаНакладной = Список.ПолучитьЗначение(32);
СпрДогСтр.ДатаНач = Список.ПолучитьЗначение(33);
СпрДогСтр.ДатаОкончания = Список.ПолучитьЗначение(34);
СпрДогСтр.ДатаОплаты = Список.ПолучитьЗначение(35);
СпрДогСтр.ДатаПоследнегоВзноса = Список.ПолучитьЗначение(36);
СпрДогСтр.Договор = Список.ПолучитьЗначение(37);
СпрДогСтр.ДоговорАГ = Список.ПолучитьЗначение(38);
СпрДогСтр.ДоговорПред = Список.ПолучитьЗначение(39);
СпрДогСтр.ДокСписанияБланков = Список.ПолучитьЗначение(40);
СпрДогСтр.Дополнительный = Список.ПолучитьЗначение(41);
СпрДогСтр.ДопПлан = Список.ПолучитьЗначение(42);
СпрДогСтр.ЕстьДО = Список.ПолучитьЗначение(43);
СпрДогСтр.Залог = Список.ПолучитьЗначение(44);
СпрДогСтр.ИнострГосударство = Список.ПолучитьЗначение(45);
СпрДогСтр.ИспорченныхТипа1 = Список.ПолучитьЗначение(46);
СпрДогСтр.ИспорченныхТипа2 = Список.ПолучитьЗначение(47);
СпрДогСтр.ИспорченныхТипа3 = Список.ПолучитьЗначение(48);
СпрДогСтр.Квитанция = Список.ПолучитьЗначение(49);
СпрДогСтр.КвитанцияПор = Список.ПолучитьЗначение(50);
СпрДогСтр.КодАгента = Список.ПолучитьЗначение(51);
СпрДогСтр.КодУслуг = Список.ПолучитьЗначение(52);
СпрДогСтр.Кол_во = Список.ПолучитьЗначение(53);
СпрДогСтр.Кол_дог = Список.ПолучитьЗначение(54);
СпрДогСтр.КоличествоВагонов = Список.ПолучитьЗначение(55);
СпрДогСтр.Комиссия = Список.ПолучитьЗначение(56);
СпрДогСтр.КомиссияБрокВал = Список.ПолучитьЗначение(57);
СпрДогСтр.КомиссияБрокер = Список.ПолучитьЗначение(58);
СпрДогСтр.КомиссияВал = Список.ПолучитьЗначение(59);
СпрДогСтр.Комментарий = Список.ПолучитьЗначение(60);
СпрДогСтр.Контейнер = Список.ПолучитьЗначение(61);
СпрДогСтр.Кредитор = Список.ПолучитьЗначение(62);
СпрДогСтр.КурсВалюты = Список.ПолучитьЗначение(63);
СпрДогСтр.ЛС = Список.ПолучитьЗначение(64);
СпрДогСтр.ЛС_Вклад = Список.ПолучитьЗначение(65);
СпрДогСтр.Марка = Список.ПолучитьЗначение(66);
СпрДогСтр.Мес_Вклад = Список.ПолучитьЗначение(67);
СпрДогСтр.Месячник = Список.ПолучитьЗначение(68);
СпрДогСтр.Метка = Список.ПолучитьЗначение(69);
СпрДогСтр.Модель = Список.ПолучитьЗначение(70);
СпрДогСтр.Недостача = Список.ПолучитьЗначение(71);
СпрДогСтр.НеПодлежитПерестрахованию = Список.ПолучитьЗначение(72);
СпрДогСтр.НеПоказыватьПолисы = Список.ПолучитьЗначение(73);
СпрДогСтр.НеТерриторияРФ = Список.ПолучитьЗначение(74);
СпрДогСтр.НеУчаствуетВКУБ = Список.ПолучитьЗначение(75);
СпрДогСтр.Номер = Список.ПолучитьЗначение(76);
СпрДогСтр.НомерЗаявки = Список.ПолучитьЗначение(77);
СпрДогСтр.НомерНакладной = Список.ПолучитьЗначение(78);
СпрДогСтр.НомерНакопКарточки = Список.ПолучитьЗначение(79);
СпрДогСтр.НормаДох = Список.ПолучитьЗначение(80);
СпрДогСтр.ОграничОтветств = Список.ПолучитьЗначение(81);
СпрДогСтр.Оплачено = Список.ПолучитьЗначение(82);
СпрДогСтр.Организация1 = Список.ПолучитьЗначение(83);
СпрДогСтр.ОснДоговорАГ = Список.ПолучитьЗначение(84);
СпрДогСтр.ПлПоручение = Список.ПолучитьЗначение(85);
СпрДогСтр.Повреждение = Список.ПолучитьЗначение(86);
СпрДогСтр.ПодлежитВПерестрахование = Список.ПолучитьЗначение(87);
СпрДогСтр.ПоискПред = Список.ПолучитьЗначение(88);
СпрДогСтр.ПоискСтрах = Список.ПолучитьЗначение(89);
СпрДогСтр.ПризнакВалюты = Список.ПолучитьЗначение(90);
СпрДогСтр.ПринятВПерестрахование = Список.ПолучитьЗначение(91);
СпрДогСтр.Регион = Список.ПолучитьЗначение(92);
СпрДогСтр.РПМ = Список.ПолучитьЗначение(93);
СпрДогСтр.Серия = Список.ПолучитьЗначение(94);
СпрДогСтр.СрокДоговора = Список.ПолучитьЗначение(95);
СпрДогСтр.СтанцияНазначения = Список.ПолучитьЗначение(96);
СпрДогСтр.СтанцияОтправления = Список.ПолучитьЗначение(97);
СпрДогСтр.Страхователь = Список.ПолучитьЗначение(98);
СпрДогСтр.СтраховательДС = Список.ПолучитьЗначение(99);
СпрДогСтр.СтраховательДСАдрес = Список.ПолучитьЗначение(100);
СпрДогСтр.СтраховаяПремия = Список.ПолучитьЗначение(101);
СпрДогСтр.СтраховаяПремияДО = Список.ПолучитьЗначение(102);
СпрДогСтр.СтраховаяПремияИП = Список.ПолучитьЗначение(103);
СпрДогСтр.СтраховаяПремияКВ = Список.ПолучитьЗначение(104);
СпрДогСтр.СтраховаяПремияРиск = Список.ПолучитьЗначение(105);
СпрДогСтр.СтраховаяПремияТС = Список.ПолучитьЗначение(106);
СпрДогСтр.СтраховаяСтоимостьДО = Список.ПолучитьЗначение(107);
СпрДогСтр.СтраховаяСтоимостьТС = Список.ПолучитьЗначение(108);
СпрДогСтр.СтраховаяСуммаДО = Список.ПолучитьЗначение(109);
СпрДогСтр.СтраховаяСуммаИП = Список.ПолучитьЗначение(110);
СпрДогСтр.СтраховаяСуммаИТОГО = Список.ПолучитьЗначение(111);
СпрДогСтр.СтраховаяСуммаКВ = Список.ПолучитьЗначение(112);
СпрДогСтр.СтраховаяСуммаРиск = Список.ПолучитьЗначение(113);
СпрДогСтр.СтраховаяСуммаТС = Список.ПолучитьЗначение(114);
СпрДогСтр.СубСчет77 = Список.ПолучитьЗначение(115);
СпрДогСтр.Сумма = Список.ПолучитьЗначение(116);
СпрДогСтр.Тариф = Список.ПолучитьЗначение(117);
СпрДогСтр.ТарифДО = Список.ПолучитьЗначение(118);
СпрДогСтр.ТарифТС = Список.ПолучитьЗначение(119);
СпрДогСтр.ТипОплаты = Список.ПолучитьЗначение(120);
СпрДогСтр.Утрата = Список.ПолучитьЗначение(121);
СпрДогСтр.УчетБланковВедется = Список.ПолучитьЗначение(122);
СпрДогСтр.Филиал = Список.ПолучитьЗначение(123);
СпрДогСтр.Франшиза = Список.ПолучитьЗначение(124);
СпрДогСтр.Хищение = Список.ПолучитьЗначение(125);
СпрДогСтр.ТипыНС = Список.ПолучитьЗначение(126);
СпрДогСтр.Записать();
Иначе
Сообщить("- "+СпрДогСтр.Код+" - "+СпрДогСтр.Наименование+" - "+СпрДогСтр.ДатаОкончания+" - "+ТекущаяДата());
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Процедура Сформировать()
Текст = СоздатьОбъект("Текст");
Список = СоздатьОбъект("СписокЗначений");
// РекСпр = Метаданные.Справочник("ДоговораСтрахования");
// СпрДогСтр = Метаданные.Справочник("ДоговораСтрахования");
// КолРек = РекСпр.Реквизит();
//КолРек = СпрДогСтр.Реквизит();
//Для Ном=1 по КолРек Цикл
// рекв = СпрДогСтр.Реквизит(Ном);
// р1 = рекв.Идентификатор();
//КонецЦикла;
СпрДогСтр = СоздатьОбъект("Справочник.ДоговораСтрахования");
СпрДогСтр.ВыбратьЭлементы();
Пока СпрДогСтр.ПолучитьЭлемент() = 1 Цикл
Если СпрДогСтр.ДатаОкончания < ТекущаяДата() Тогда
Сообщить("//"+СпрДогСтр.Код+" - "+СпрДогСтр.Наименование+" - "+СпрДогСтр.ДатаОкончания+" - "+ТекущаяДата());
Продолжить;
Иначе
//Для Номер=1 по КолРек Цикл
//Сообщить(СпрДогСтр.Реквизит(номер));
//КонецЦикла;
Сообщить(СпрДогСтр.Код+" - "+СпрДогСтр.Наименование+" - "+СпрДогСтр.ДатаОкончания+" - "+ТекущаяДата());

Список.ДобавитьЗначение(СпрДогСтр.Код);
Список.ДобавитьЗначение(СпрДогСтр.Наименование);
Список.ДобавитьЗначение(СпрДогСтр.Агент);
Список.ДобавитьЗначение(СпрДогСтр.АгентДС);
Список.ДобавитьЗначение(СпрДогСтр.АмортизацияТС);
Список.ДобавитьЗначение(СпрДогСтр.Багаж);
Список.ДобавитьЗначение(СпрДогСтр.БезКолДог);
Список.ДобавитьЗначение(СпрДогСтр.БезОтветствПовреж);
Список.ДобавитьЗначение(СпрДогСтр.Бланк);
Список.ДобавитьЗначение(СпрДогСтр.Брокер);
Список.ДобавитьЗначение(СпрДогСтр.Вагон);
Список.ДобавитьЗначение(СпрДогСтр.Валюта);
Список.ДобавитьЗначение(СпрДогСтр.ВидБланка);
Список.ДобавитьЗначение(СпрДогСтр.ВидВагона);
Список.ДобавитьЗначение(СпрДогСтр.ВидСтрахования);
Список.ДобавитьЗначение(СпрДогСтр.ВидФраншизы);
Список.ДобавитьЗначение(СпрДогСтр.ВсеВиды);
Список.ДобавитьЗначение(СпрДогСтр.ВсегоБланковТипа1);
Список.ДобавитьЗначение(СпрДогСтр.ВсегоБланковТипа2);
Список.ДобавитьЗначение(СпрДогСтр.ВсегоБланковТипа3);
Список.ДобавитьЗначение(СпрДогСтр.ВсеОтветств);
Список.ДобавитьЗначение(СпрДогСтр.Выгодоприобретатель);
Список.ДобавитьЗначение(СпрДогСтр.ГодВыпуска);
Список.ДобавитьЗначение(СпрДогСтр.Госномер);
Список.ДобавитьЗначение(СпрДогСтр.Груз);
Список.ДобавитьЗначение(СпрДогСтр.Дата1);
Список.ДобавитьЗначение(СпрДогСтр.Дата2);
Список.ДобавитьЗначение(СпрДогСтр.ДатаВвода);
Список.ДобавитьЗначение(СпрДогСтр.ДатаВводаОплаты);
Список.ДобавитьЗначение(СпрДогСтр.ДатаДог);
Список.ДобавитьЗначение(СпрДогСтр.ДатаДосроч);
Список.ДобавитьЗначение(СпрДогСтр.ДатаНакладной);
Список.ДобавитьЗначение(СпрДогСтр.ДатаНач);
Список.ДобавитьЗначение(СпрДогСтр.ДатаОкончания);
Список.ДобавитьЗначение(СпрДогСтр.ДатаОплаты);
Список.ДобавитьЗначение(СпрДогСтр.ДатаПоследнегоВзноса);
Список.ДобавитьЗначение(СпрДогСтр.Договор);
Список.ДобавитьЗначение(СпрДогСтр.ДоговорАГ);
Список.ДобавитьЗначение(СпрДогСтр.ДоговорПред);
Список.ДобавитьЗначение(СпрДогСтр.ДокСписанияБланков);
Список.ДобавитьЗначение(СпрДогСтр.Дополнительный);
Список.ДобавитьЗначение(СпрДогСтр.ДопПлан);
Список.ДобавитьЗначение(СпрДогСтр.ЕстьДО);
Список.ДобавитьЗначение(СпрДогСтр.Залог);
Список.ДобавитьЗначение(СпрДогСтр.ИнострГосударство);
Список.ДобавитьЗначение(СпрДогСтр.ИспорченныхТипа1);
Список.ДобавитьЗначение(СпрДогСтр.ИспорченныхТипа2);
Список.ДобавитьЗначение(СпрДогСтр.ИспорченныхТипа3);
Список.ДобавитьЗначение(СпрДогСтр.Квитанция);
Список.ДобавитьЗначение(СпрДогСтр.КвитанцияПор);
Список.ДобавитьЗначение(СпрДогСтр.КодАгента);
Список.ДобавитьЗначение(СпрДогСтр.КодУслуг);
Список.ДобавитьЗначение(СпрДогСтр.Кол_во);
Список.ДобавитьЗначение(СпрДогСтр.Кол_дог);
Список.ДобавитьЗначение(СпрДогСтр.КоличествоВагонов);
Список.ДобавитьЗначение(СпрДогСтр.Комиссия);
Список.ДобавитьЗначение(СпрДогСтр.КомиссияБрокВал);
Список.ДобавитьЗначение(СпрДогСтр.КомиссияБрокер);
Список.ДобавитьЗначение(СпрДогСтр.КомиссияВал);
Список.ДобавитьЗначение(СпрДогСтр.Комментарий);
Список.ДобавитьЗначение(СпрДогСтр.Контейнер);
Список.ДобавитьЗначение(СпрДогСтр.Кредитор);
Список.ДобавитьЗначение(СпрДогСтр.КурсВалюты);
Список.ДобавитьЗначение(СпрДогСтр.ЛС);
Список.ДобавитьЗначение(СпрДогСтр.ЛС_Вклад);
Список.ДобавитьЗначение(СпрДогСтр.Марка);
Список.ДобавитьЗначение(СпрДогСтр.Мес_Вклад);
Список.ДобавитьЗначение(СпрДогСтр.Месячник);
Список.ДобавитьЗначение(СпрДогСтр.Метка);
Список.ДобавитьЗначение(СпрДогСтр.Модель);
Список.ДобавитьЗначение(СпрДогСтр.Недостача);
Список.ДобавитьЗначение(СпрДогСтр.НеПодлежитПерестрахованию);
Список.ДобавитьЗначение(СпрДогСтр.НеПоказыватьПолисы);
Список.ДобавитьЗначение(СпрДогСтр.НеТерриторияРФ );
Список.ДобавитьЗначение(СпрДогСтр.НеУчаствуетВКУБ );
Список.ДобавитьЗначение(СпрДогСтр.Номер);
Список.ДобавитьЗначение(СпрДогСтр.НомерЗаявки);
Список.ДобавитьЗначение(СпрДогСтр.НомерНакладной);
Список.ДобавитьЗначение(СпрДогСтр.НомерНакопКарточки);
Список.ДобавитьЗначение(СпрДогСтр.НормаДох );
Список.ДобавитьЗначение(СпрДогСтр.ОграничОтветств);
Список.ДобавитьЗначение(СпрДогСтр.Оплачено );
Список.ДобавитьЗначение(СпрДогСтр.Организация1);
Список.ДобавитьЗначение(СпрДогСтр.ОснДоговорАГ);
Список.ДобавитьЗначение(СпрДогСтр.ПлПоручение );
Список.ДобавитьЗначение(СпрДогСтр.Повреждение);
Список.ДобавитьЗначение(СпрДогСтр.ПодлежитВПерестрахование );
Список.ДобавитьЗначение(СпрДогСтр.ПоискПред );
Список.ДобавитьЗначение(СпрДогСтр.ПоискСтрах );
Список.ДобавитьЗначение(СпрДогСтр.ПризнакВалюты);
Список.ДобавитьЗначение(СпрДогСтр.ПринятВПерестрахование);
Список.ДобавитьЗначение(СпрДогСтр.Регион);
Список.ДобавитьЗначение(СпрДогСтр.РПМ );
Список.ДобавитьЗначение(СпрДогСтр.Серия );
Список.ДобавитьЗначение(СпрДогСтр.СрокДоговора);
Список.ДобавитьЗначение(СпрДогСтр.СтанцияНазначения);
Список.ДобавитьЗначение(СпрДогСтр.СтанцияОтправления);
Список.ДобавитьЗначение(СпрДогСтр.Страхователь );
Список.ДобавитьЗначение(СпрДогСтр.СтраховательДС );
Список.ДобавитьЗначение(СпрДогСтр.СтраховательДСАдрес );
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяПремия );
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяПремияДО);
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяПремияИП );
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяПремияКВ );
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяПремияРиск );
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяПремияТС);
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяСтоимостьДО);
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяСтоимостьТС);
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяСуммаДО );
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяСуммаИП);
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяСуммаИТОГО);
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяСуммаКВ);
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяСуммаРиск);
Список.ДобавитьЗначение(СпрДогСтр.СтраховаяСуммаТС);
Список.ДобавитьЗначение(СпрДогСтр.СубСчет77);
Список.ДобавитьЗначение(СпрДогСтр.Сумма);
Список.ДобавитьЗначение(СпрДогСтр.Тариф );
Список.ДобавитьЗначение(СпрДогСтр.ТарифДО);
Список.ДобавитьЗначение(СпрДогСтр.ТарифТС);
Список.ДобавитьЗначение(СпрДогСтр.ТипОплаты );
Список.ДобавитьЗначение(СпрДогСтр.Утрата);
Список.ДобавитьЗначение(СпрДогСтр.УчетБланковВедется);
Список.ДобавитьЗначение(СпрДогСтр.Филиал);
Список.ДобавитьЗначение(СпрДогСтр.Франшиза);
Список.ДобавитьЗначение(СпрДогСтр.Хищение);
Список.ДобавитьЗначение(СпрДогСтр.ТипыНС);
Текст.ДобавитьСтроку(Список.ВСтрокуСРазделителями());
Список.УдалитьВсе();
КонецЕсли;
КонецЦикла;
Текст.Записать("D:\123.txt");

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
62 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
36 Сообщений
KOI8-R
35 Сообщений
Анюта17
32 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 783
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal