Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 12:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не заполняется поле ТЧ формы.  (Прочитано 1225 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sv_Graal

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-10
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!
Пожалуйста, помогите найти ошибку. Сейчас пытаюсь разобраться с использованием точек останова и тому подобными штукенциями, без них, похоже сама ошибку не найду.

Вот такой код:

******************************************************************

&НаКлиенте
Процедура ПолучитьОстатки(Команда)
   
   // !!!! Записать документ перед этим !!!!
   Результат = ПолучитьОстаткиНаСервере(Объект.Ссылка);
   
   ТаблицаТовары = Объект.Товары;
   
   Для Каждого ТекСтрока Из ТаблицаТовары Цикл
      
      Отбор = Новый Структура();
      Отбор.Вставить("Номенклатура", ТекСтрока.Номенклатура);
      СвободныйОстаток = Результат.НайтиСтроки(Отбор);
      ТекСтрока.СвободныйОстаток = СвободныйОстаток;
      
   КонецЦикла;

КонецПроцедуры

&НаСервере
Функция ПолучитьОстаткиНаСервере(Ссылка)
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   СвободныйОстатокТовараОстатки.Номенклатура КАК Номенклатура,
      |   СвободныйОстатокТовараОстатки.КоличествоСвободныйОстатокОстаток Как СвободныйОстаток
      |ИЗ
      |   Документ.ЗаказКлиента КАК ЗаказКлиента
      |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.СвободныйОстатокТовара.Остатки КАК СвободныйОстатокТовараОстатки
      |      ПО ЗаказКлиента.Товары.Номенклатура = СвободныйОстатокТовараОстатки.Номенклатура
      |ГДЕ
      |   ЗаказКлиента.Ссылка = &Ссылка";

   Запрос.УстановитьПараметр("Ссылка", Ссылка);
   Результат = Запрос.Выполнить().Выгрузить();
   
   Возврат Результат;
   
КонецФункции

******************************************************************

Его целью является получение данных из регистра СвободныеОстатки в табличную часть документа ЗаказКлиента.

Кнопку жму, никаких ошибок нет, но и никакого эффекта тоже  :angry:
Запрос работает сам по себе (проверяла в консоли), результаты выдает корректные.
А вот с обработкой запроса я, похоже, перемудрила (или же недодумала  :lol:)

Please, help!!! (Вспоминать Милу Йовович из фильма Пятый элемент, минута 35, смотреть в английском варианте!)

Заранее спасибо)


Оффлайн Sv_Graal

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-10
  • Сайт: 
  • Профессия: Ученик 1С
Подправила цикл в процедуре ПолучитьОстатки и кнопочка заработала! Ура :zebzdr:

***************************************************************************
   Для Каждого ТекСтрока Из ТаблицаТовары Цикл
      
      Отбор = Новый Структура();
      Отбор.Вставить("Номенклатура", ТекСтрока.Номенклатура);
      СтрокаПоНоменклатуре = Результат.НайтиСтроки(Отбор);
      ТекСтрока.СвободныйОстаток = СтрокаПоНоменклатуре[0].СвободныйОстаток;
      
   КонецЦикла;
***************************************************************************

Все равно всем спасибо!


Теги:
 

Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 7829
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 632
Последний ответ 21 Сен 2017, 10:33
от Insider
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 155
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5257
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3798
Последний ответ 12 Июл 2013, 15:35
от mikel10

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
62 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
36 Сообщений
KOI8-R
35 Сообщений
Анюта17
32 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 788
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal