Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как вывести результаты запроса в макет печатной формы документа?  (Прочитано 11259 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sapravka

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-09-27
  • Сайт: волгалаб.рф
  • Профессия: Ученик 1С
 Здравствуйте!
Собственно все по порядку:
Есть документ (ОтчетПроизводстваЗаСмену, бух 2.0), в него я добавил дополнительную печатную форму – по кнопке Печать она выходит на печать, но вот правда на ней не отображается данные из запроса, который написан в модуле документа:
 Функция ПечатьКарта()



            Запрос = Новый Запрос;

            Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);

            Запрос.Текст =

            "ВЫБРАТЬ

            |           ОтчетПроизводстваЗаСмену.Номер КАК НомерДокумента,

            |           ОтчетПроизводстваЗаСмену.Дата КАК ДатаДокумента,

            |           ОтчетПроизводстваЗаСмену.Склад КАК СкладДокумента

            |ИЗ

            |           Документ.ОтчетПроизводстваЗаСмену КАК ОтчетПроизводстваЗаСмену";

            ЗапросШапка = Запрос.Выполнить().Выбрать();





            Запрос = Новый Запрос;

            Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);

            Запрос.Текст =

            "ВЫБРАТЬ

            |           ОтчетПроизводстваЗаСменуПродукция.Количество,

            |            ОтчетПроизводстваЗаСменуПродукция.Номенклатура.ОсновнаяСпецификацияНоменклатуры.Владелец.Ссылка,

            |           СпецификацииНоменклатурыИсходныеКомплектующие.Номенклатура,

            |           СпецификацииНоменклатурыИсходныеКомплектующие.Количество КАК КоличествоСостав,

            |           ОтчетПроизводстваЗаСменуПродукция.Количество * СпецификацииНоменклатурыИсходныеКомплектующие.Количество КАК КоличествоСоставаПоНоменклатуре

            |ИЗ

            |           Документ.ОтчетПроизводстваЗаСмену.Продукция КАК ОтчетПроизводстваЗаСменуПродукция

            |                       ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК СпецификацииНоменклатурыИсходныеКомплектующие

            |                       ПО ОтчетПроизводстваЗаСменуПродукция.Номенклатура = СпецификацииНоменклатурыИсходныеКомплектующие.Ссылка.Владелец";



            ЗапросСтрока = Запрос.Выполнить().Выгрузить();

            Макет = ПолучитьМакет("Карта");

            // Получаем области макета для вывода в табличный документ.

            ШапкаДокумента   = Макет.ПолучитьОбласть("Шапка");

            ЗаголовокТаблицы = Макет.ПолучитьОбласть("Строка");

            ПодвалДокумента  = Макет.ПолучитьОбласть("Подвал");



            ТабДокумент = Новый ТабличныйДокумент;



            // Зададим параметры макета по умолчанию.

            ТабДокумент.ПолеСверху              = 10;

            ТабДокумент.ПолеСлева               = 0;

            ТабДокумент.ПолеСнизу               = 0;

            ТабДокумент.ПолеСправа              = 0;

            ТабДокумент.РазмерКолонтитулаСверху = 10;



            // Загрузим настройки пользователя.

            ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Карта";



            Область = Макет.ПолучитьОбласть("Шапка");

            ТабДокумент.Вывести(Область);



            Область = Макет.ПолучитьОбласть("Строка");

            ТабДокумент.Вывести(Область);



            Область = Макет.ПолучитьОбласть("Подвал");

            ТабДокумент.Вывести(Область);



            Возврат ТабДокумент;

КонецФункции // ПечатьКарта()
Подскажите, как поступить – в макете я добавил параметры и прописал там необходимые области, например:

В шапке написал следующие параметры:
НомерДокумента,
ДатаДокумента,
СкладДокумента

А при печати все равно выходит пустое поле...
Подскажите, пожалуйста, что еще необходимо прописать в модуле, что бы печатной форме выводились данные поля?
И насчет области строка – тут как я понимаю необходимо циклом выбрать все строки – если я правильно догадываюсь – дайте, пожалуйста пример данного цикла...
Заранее благодарен...



Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
Простой дружеский совет: полезно ковыряться в типовых конфигах.
А вот простейший пример вывода в табличный документ:
ТабДок.Вывести(ОбластьШапка);
Результат = Запрос.Выполнить();   
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
    ОбластьСтрока.Параметры.МойПараметрВМакете = Выборка.МойПараметрИзЗапроса;
    ТабДок.Вывести(ОбластьСтрока);   
КонецЦикла;   
ТабДок.Вывести(ОбластьИтого);
ТабДок.Вывести(ОбластьПодвал);
Параметры можно задавать и немного иначе, но... результат титанической работы разработчиков типовых конфиг вам в помощь.
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед

Оффлайн sapravka

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-09-27
  • Сайт: волгалаб.рф
  • Профессия: Ученик 1С
Простой дружеский совет: полезно ковыряться в типовых конфигах.
А вот простейший пример вывода в табличный документ:
ТабДок.Вывести(ОбластьШапка);
Результат = Запрос.Выполнить();   
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
    ОбластьСтрока.Параметры.МойПараметрВМакете = Выборка.МойПараметрИзЗапроса;
    ТабДок.Вывести(ОбластьСтрока);   
КонецЦикла;   
ТабДок.Вывести(ОбластьИтого);
ТабДок.Вывести(ОбластьПодвал);
Параметры можно задавать и немного иначе, но... результат титанической работы разработчиков типовых конфиг вам в помощь.

Спасибо!
Сейчас попробую!
А вот еще вопрос: в цикле можно тогда указать необходимо количество параметров - у меня их несколько?
И еще если параметр один - (например ДатаДокумента) то цикл можно не использовать?

Оффлайн sertak

  • ****
  • Сообщений: 274
  • РЕПУТАЦИЯ: 74
  • КПД: 27%
  • Регистрация: 2013-01-16
    • Skype: vitaly_sertakov
  • Сайт: www.sertakov.ru
  • Профессия: Программист 1С
Цикл необходим для перебора СТРОК выборки, к числу параметров макета (которым соответствуют КОЛОНКИ выборки) отношения не имеет, т.е. можно задавать любое число параметров.
Пока Выборка.Следующий() Цикл
    ОбластьСтрока.Параметры.МойПараметрВМакете1 = Выборка.Колонка1;
    ОбластьСтрока.Параметры.МойПараметрВМакете2 = Выборка.Колонка2;
    ОбластьСтрока.Параметры.МойПараметрВМакете3 = Выборка.Колонка3;
    ТабДок.Вывести(ОбластьСтрока);   
КонецЦикла;   
Если ты знаешь свой путь, то удачи и неудачи равно продвигают тебя вперед


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4481
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15949
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4203
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 639
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7752
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 144
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal