Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Май 2018, 08:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отбор в ФормеСписка Справочника  (Прочитано 1494 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ходакова Светлана

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-18
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток. У меня вот такая ситуация.

1 Справочник.Автомобили.ФормаСписка. Список формируется при помощи запроса. Часть данных запрашивается из РегистраСведений. Сведения, соответственно, про Автомобиль. Автомобиль может быть оплачен (в регистре есть запись об оплате), от него могли отказаться (запись об оплате была ранее, но сейчас уже пустая запись), и может быть совсем новый (в регистре сведений про него вообще ничего нет)
 
2. На форме есть много отборов, в том числе и по данному статусу
 
3. В реквизите на форме написана процедура
&НаКлиенте
Процедура Статус1ПриИзменении(Элемент)
УстановитьОтбор();
КонецПроцедуры
Далее процедуры из БСП (только с моими значениями)

& НаСервере
Процедура УстановитьОтбор()
     


СписокОтбора = Новый СписокЗначений;
СписокОтбора.Добавить(Справочники.СтатусАвтомобиля.ПустаяСсылка());
СписокОтбора.Добавить(NULL);
СписокОтбора.Добавить(Неопределено);


     
ПараметрыОтбора = Новый Соответствие();
ПараметрыОтбора.Вставить("Выдан", СписокОтбора);


УстановитьОтборСписка(Список, ПараметрыОтбора);
КонецПроцедуры


&НаКлиентеНаСервереБезКонтекста


Процедура УстановитьОтборСписка(Список,ПараметрыОтбора)


ЭлементыОтбора = Список.Отбор.Элементы;
Статус1 = ПараметрыОтбора["Выдан"];


ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбора(Список.Отбор,
                        "Статус1",
                                 Статус1,
                                 ВидСравненияКомпоновкиДанных.ВСписке)
КонецПроцедуры

И все было хорошо и замечательно, пока мне не понадобилось совместить отбор по условиям "НеРавно" и "НеЗаполнено". Т.е. у меня есть в динамическом списке поле "Статус", которое может быть либо незаполнено, либо содержать разные значения. И мне нужны элементы списка с пустым полем + элементы списка с некоторыми значениями.


У меня получается, что в консоле запросов те самые пустые статусы имеют значение NULL. Когда я пишу
ВидСравненияКомпоновкиДанных.НеЗаполнено, то Элементы Списка, где статус1= NULL замечательно отбираются. А вот когда я создаю список параметров и включаю туда и Справочник.НужныйСправочник.ПустаяСсылка() и NULL и Неопределено, то эти элементы уже не отбираются. Вот и пытаюсь понять, где глюк.

Даже на разных платформах попробовала (8.2.16 и 8.3.2). Результат одинаковый.


Всем заранее спасибо.

Последний раз редактировалось: MuI_I_Ika; 18 Янв 2013, 16:08


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6876
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4769
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1184
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2495
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 518
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
147 Сообщений
oleg-x
66 Сообщений
alex0402
63 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
26 Сообщений
BuhRust
20 Сообщений
trialex3
20 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal