Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 05:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: регистр сведений штрихкод  (Прочитано 6302 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sevak

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-18
  • Сайт: 
  • Профессия: Разработчик 1С
привет всем ....

подскажите пожалуйста как в регистре сведений по штрих коду найти владельца (1c 8.2, розница 1.0).

Я написал функцию `

Функция НаименованиеПоШтрихкоду(Штрихкод)

Запрос = Новый Запрос;
Запрос.Текст =  "ВЫБРАТЬ
| Штрихкоды.Владелец,
| Штрихкоды.Штрихкод
|ИЗ
| РегистрСведений.Штрихкоды КАК Штрихкоды
|ГДЕ
| Штрихкоды.Штрихкод = &ШК; ";
Запрос.УстановитьПараметр("ШК", Штрихкод);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Возврат Выборка.Владелец;
   
КонецФункции

я вызываю функцию вот так` A = НаименованиеПоШтрихкоду("4850089000479");
при установке параметра выдает ошибку ` "переменная не определена (ШК)"????


Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Приложение какое? обычное? или управляемое?
Покажите процедуру где вызываете данную функцию
Тазовод)

Оффлайн Sevak

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-18
  • Сайт: 
  • Профессия: Разработчик 1С
вот и задача ...

у меня есть форма,кнопка и поле ввода...

мне надо нажать кнопку и в другом поле вводе увидит владельца этого штрих кода

Процедура Кнопка1Нажатие()
Запрос = Новый Запрос;

Запрос.Текст =  "ВЫБРАТЬ
 | Штрихкоды.Владелец,
 | Штрихкоды.Штрихкод
 |ИЗ
 | РегистрСведений.Штрихкоды КАК Штрихкоды
 |ГДЕ
 | Штрихкоды.Штрихкод ПОДОБНО &ШК ";
 
   

Запрос.УстановитьПараметр("ШК", ПолеВвода1);

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
    Выборка.Следующий();
ПолеВвода2 = Выборка.Владелец();   

КонецПроцедуры


Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
может быть такое, что штрихкоды у товаров одинаковые? если да - то для вывода владельца лучше использовать таб поле...
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Процедура КнопкаСформироватьНажатие(Кнопка)
// Вставить содержимое обработчика.
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Штрихкоды.Владелец
|ИЗ
| РегистрСведений.Штрихкоды КАК Штрихкоды
|ГДЕ
| Штрихкоды.Штрихкод = &Штрихкод";
Запрос.УстановитьПараметр("Штрихкод",Штрихкод);
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
//если с таб полем - то довавляем всех, кого нашли с этим штрихкодом -
НовСтрока = ТабЧасть.Добавить();
НовСтрока.Владелец = Выборка.Владелец;
КонецЦикла;
КонецПроцедуры
Тазовод)


Теги:
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4837
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7729
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9321
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
В чем отличие регистра сведений от регистра накопления?

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 473
Последний ответ 11 Сен 2017, 10:50
от ilyay
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14294
Последний ответ 11 Янв 2011, 10:04
от nomer13

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 213
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal