Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 21:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проверка при создании документа  (Прочитано 1576 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sergqwert

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-09
  • Сайт: 
При оприходовании товара от поставщика (через заказ поставщику), те  товары по которым в базе 1С не было движения, выделяются другим шрифтом.  Как ввести дополнительную проверку при создании документа "Приход в  ячейки" на предмет наличия места постоянного хранения(тем самым исключив  по максимуму позиции которые были в наличии в базе, но закончились под  ноль, и в новой базе по ним нет движения).
 
Привожу код: 
 
Процедура ПроверитьЗаполнениеТабличнойЧастиТовары(СтруктураШапкиДокумента, Отказ, Заголовок)
 
 // Укажем, что надо проверить:
 СтруктураОбязательныхПолей = Новый Структура("Номенклатура, Ячейка, Количество");
 
 // Вызовем общую процедуру для проверки проверки.
 ЗаполнениеДокументов.ПроверитьЗаполнениеТабличнойЧасти(ЭтотОбъект, "Товары", СтруктураОбязательныхПолей, Отказ, Заголовок);
 
 // проверка на предмет наличия мест хранения       
 Для Каждого СтрокаДокумента Из Товары цикл
 Если СтрокаДокумента.Ячейка = Справочники.МестаХранения.ПустаяСсылка() Тогда
 Предупреждение("Строка " + СтрокаДокумента.НомерСтроки + ". " + "  не заполнено место постоянного хранения. Ячейка берется из мест  хранения: " + СтрокаДокумента.Ячейка);
 СтрокаДокумента.Ячейка = СтруктураОбязательныхПолей["Ячейка"];
 КонецЕсли;
 
 КонецЦикла;
 
КонецПроцедуры // ПроверитьЗаполнениеТабличнойЧастиТовары


Как проверить заполнение ячейки в ТЧ документа?




Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4481
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15948
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4203
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 639
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7751
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 241
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal