Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выпадающий список в табличной части документа  (Прочитано 7833 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gulnaz

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-06
  • Сайт: 
  • Профессия: Программист 8.1
Здраствуйте, знатоки 1С! В ТЧ документа есть поля с типом СправочникСсылка, для выбора элемента в этих полях стандартно открываем форму выбора соответствующих справочников и выбираем нужный элемент.  Как сделать так, чтобы в данных полях выбор элемента был из выпадающего списка?
На событие НачалоВыбораИзСписка написала процедуру:

 Процедура ТоварыДопХарактеристикиНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
ТекСписокВыбора = Элемент.СписокВыбора;
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ОИТ_ХарактеристикиГП.Наименование Как Наименование
|ИЗ
| Справочник.ОИТ_Характеристики КАК ОИТ_ХарактеристикиГП";
ТекСписокВыбора.ЗагрузитьЗначения(Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Наименование"));
КонецПроцедуры

Список выпадает, но значение не выбирается. У поля в свойствах стоят галочки КнопкаСпискаВыбора, КнопкаВыбора, РежимВыбораИзСписка. Что не так?


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте загружать в список выбора не наименования, а ссылки на элементы.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
По-моему, можно в конфигураторе справочнике на вкладке "Формы" внизу есть "Быстрый выбор" попробуйте поставить его...должно выбираться из списка
Тазовод)

Оффлайн Gulnaz

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-06
  • Сайт: 
  • Профессия: Программист 8.1
Наименование"));<BR>КонецПроцедуры<BR
Попробуйте загружать в список выбора не наименования, а ссылки на элементы.

Спасибо! Раз раз в этом и была ошибка. Если в свойствах поставить галочку БыстрыйВыбор, то выпадающий список тоже работает. Но мне еще нужна возможность открытия формы выбора справочника-ссылки для создания нового элемента. Поэтому процедура НачалоВыбораИзСписка и ручное прописание процедуры НачалоВыбора решают мою проблему.
   
   Процедура ТоварыЦветНачалоВыбора(Элемент, СтандартнаяОбработка)   
      СтандартнаяОбработка=Ложь;   
      ФормаВыбора = Справочники.ОИТ_ЦветаГП.ПолучитьФормуВыбора(,Элемент);
      ФормаВыбора.Открыть();
   КонецПроцедуры
 

Оффлайн Gonchaya

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-23
  • Сайт: 
  • Профессия: Разработчик 1С
Попробуйте загружать в список выбора не наименования, а ссылки на элементы.

Огромное спасибо! Мучилась с той же бедой, что у ТС, и все получилось! :zebzdr:


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7736
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4774
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8488
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7335
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 216
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal