Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ограничение доступа в табличной части документа  (Прочитано 5240 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlterMann

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-21
  • Сайт: 
  • Профессия: Ученик 1С
В табличную часть документа "заказ покупателя" во вкладке "услуги" программно (при выполнении условия) добавляю строку "доставка". Нужно, чтобы ЭТУ СТРОКУ мог редактировать только один пользователь (нач. отд. продаж), добавлять другие услуги в этой табличной части должны иметь возможность все пользователи. Подскажите, как это реализовать. У меня получилось только закрыть на редактирование всю тч.


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Можно отрабатывать процедуры изменения/добавления строк на самой форме, проверять - можно ли этому пользователю трогать эту строку или нет, если нет - идти в отказ
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн AlterMann

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-21
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за совет, попробую.
Добавлено: 15 Янв 2013, 17:29

В общем получилось следующим образом:
Процедура УслугиПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)

Пользователь = ИмяПользователя();
Если Пользователь="Иван Ф." Тогда
элемент.доступность = истина;
Иначе
Если НоваяСтрока = Истина тогда
элемент.доступность = истина;
иначе
Элемент.доступность = ложь;
предупреждение("Нарушение прав доступа");
КонецЕсли;
КонецЕсли;

КонецПроцедуры
Таким образом редактировать может только один пользователь, а добавлять новые строки - любой!

Последний раз редактировалось: AlterMann; 15 Янв 2013, 17:29

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Пользователя, которому можно, лучше конечно определять по доступности некоторой роли. То есть, создаете в конфигурации пустую роль "РедактированиеСпецУслуги", раздаете ее всем, кому нужно, а в коде проверяете ее доступность конкретному текущему пользователю.
Таким образом, Вы сможете не меняя код в дальнейшем, давать возможность редактирования этой услуги кому-то еще.

Плюс, по коду можно использовать сразу конструкцию "Если ... ИначеЕсли... Иначе... КонецЕсли"
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7736
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4774
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8488
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7335
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 221
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal