Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 08:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: как обратиться к перечислению?  (Прочитано 11565 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Akvalaris

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-14
  • Сайт: 
&НаКлиенте
Процедура ВидРаботыПриИзменении(Элемент)
   
   если объект.ВидРаботы=перечисления.Видработы.Изготовление тогда
      элементы.УслугиДругихЦехов.Доступность=Истина;
   конецесли;
   
КонецПроцедуры

на клиенте выдает ошибку
"{Документ.НакладнаяНаСдачуРаботы.Форма.ФормаДокумента.Форма(5,24)}: Переменная не определена (перечисления)
   если объект.ВидРаботы=<<?>>перечисления.Видработы.Изготовление тогда (Проверка: Тонкий клиент)"

на сервере просто не срабатывает.
 не понимаю что не так


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
На клиенте понятное дело отсутствует возможность обращаться к объектам конфигурации.

На сервере должно работать. Видимо, просто глючит.

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
А попробуйте:
Функция ПолучитьВидРаботы()
    Возврат перечисления.Видработы.Изготовление
КонецФункции

&НаКлиенте
Процедура ВидРаботыПриИзменении(Элемент)
   
   если объект.ВидРаботы = ПолучитьВидРаботы() тогда
      элементы.УслугиДругихЦехов.Доступность=Истина;
   конецесли;
   
КонецПроцедуры
Помогли, отблагодари!

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
А ещё можно так:
&НаКлиенте 
Процедура ВидРаботыПриИзменении(Элемент)
    Если Объект.ВидРаботы = ПредопределенноеЗначение("Перечисление.Видработы.Изготовление") Тогда
        Ллементы.УслугиДругихЦехов.Доступность=Истина;
    КонецКсли;
КонецПроцедуры
Обратите внимание "Перечисление." должно быть в единственном числе.

Оффлайн Akvalaris

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-14
  • Сайт: 
спасибо. Поменяла на "перечислениЕ" и все получилось.

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Да извините копировал не обращая внимание! :btbzdb:
Помогли, отблагодари!

Оффлайн Tashko

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 1
  • КПД: 50%
  • Регистрация: 2013-01-16
  • Сайт: 
  • Профессия: Программист 1С
Можно и на клиенте обратиться к перечислению с помощью:

ПредопределенноеЗначение(<ИмяПредопределенногоЗначения>)

Описание:
Возвращает ссылку на предопределенный элемент из предопределенных данных, прикладных перечислений и точек маршрута бизнес-процессов, а также значения системных перечислений.
Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Вам sadovod, написал часть кода для клиента! И сами выложили:
Цитировать
Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
Помогли, отблагодари!


Теги:
 

Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5010
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Как обратиться к "вложенным" реквизитам формы объекта?

Автор Jack_78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 835
Последний ответ 29 Янв 2016, 15:20
от Jack_78
как в цикле обратиться к значениям полей СхемаКомпоновкиДанных и где должна быть размещена обработка при отсутствии формы?

Автор sveta CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 2092
Последний ответ 01 Мар 2016, 21:42
от sveta C
За получением имущественного или социального вычета работник может обратиться по месту работы

Автор newsРаздел Новости

Ответов: 0
Просмотров: 370
Последний ответ 25 Фев 2016, 09:37
от news
Как во внешнем отчете обратиться к функции модуля формы этого отчета?

Автор Алексей2014Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 6375
Последний ответ 28 Фев 2016, 23:56
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
135 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 393
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal