Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Регистр накопления  (Прочитано 3333 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kseniya_

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-09
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Создала документ «ДоговорАкт», в котором содержится информация о заключенных договорах и документах по договорам (счета, акты выполненных работ). Затем создала регистр накопления «РегистрАкт». Сделала просмотр с формы этого регистра. Теперь необходимо, чтобы осуществлялся поиск записей регистра по датам выполненных работ. И вывод результата на форму. На форме создала два дополнительных поля с типами Дата для ввода периода для поиска и кнопку Поиск. Никак не получается это реализовать.
&НаКлиенте
Процедура Поиск(Команда) Экспорт
Дата1 = ДатаНачала;   
Дата2 = ДатаКонца;

ПоискСтрок(Дата1, Дата2);
КонецПроцедуры

&НаСервере
Процедура ПоискСтрок(Дата1, Дата2) Экспорт
   НачалоПериода = Дата1;
   КонецПериода = Дата2;
      
   ПоискЗапрос = Новый Запрос;
   ПоискЗапрос.Текст = "ВЫБРАТЬ
   |РегистрАктыОбороты.ПериодПроверка как Период,
   |РегистрАктыОбороты.РегистраторПроверка как Регистратор,
   |РегистрАктыОбороты.НомерДоговора,
   |РегистрАктыОбороты.ДатаДоговора,
   |РегистрАктыОбороты.НомерКонтрактаММ,
   |РегистрАктыОбороты.ВидЗатрат,
   |РегистрАктыОбороты.УсловияОплаты,
   |РегистрАктыОбороты.Контрагент,
   |РегистрАктыОбороты.Примечание,
   |РегистрАктыОбороты.НомерСчета,
   |РегистрАктыОбороты.ДатаСчета,
   |РегистрАктыОбороты.НомерСчетФактуры,
   |РегистрАктыОбороты.ДатаСчетФактуры,
   |РегистрАктыОбороты.КопияОригиналСчета,
   |РегистрАктыОбороты.НомерАкта,
   |РегистрАктыОбороты.ДатаАкта как ДатаАкта,
   |РегистрАктыОбороты.КопияОриганалАкта,
   |РегистрАктыОбороты.АктНаСогласовании,
   |РегистрАктыОбороты.ДатаПередачи,
   |РегистрАктыОбороты.НомерЗаказаНаОплату,
   |РегистрАктыОбороты.СуммаОборот как Сумма,
   |РегистрАктыОбороты.НомерЗаказаУслуги,
   |РегистрАктыОбороты.ПередачаВОтделБО,
   |РегистрАктыОбороты.ДатаПередачиБО,
   |РегистрАктыОбороты.ПередачаВНУ,
   |РегистрАктыОбороты.ДатаПедачиНУ
      |ИЗ
   |РегистрНакопления.РегистрАкты.Обороты КАК РегистрАктыОбороты
      |ГДЕ
   |РегистрАктыОбороты.ДатаАкта Между &НачалоПериода и &КонецПериода";
   ПоискЗапрос.УстановитьПараметр("НачалоПериода", НачалоПериода);
   ПоискЗапрос.УстановитьПараметр("КонецПериода", КонецПериода);
   

    НаборЗаписей = РегистрыНакопления.РегистрАкты.СоздатьНаборЗаписей();
    Выборка = ПоискЗапрос.Выполнить().Выбрать();
   
             Пока Выборка.Следующий() Цикл
      НаборЗаписей.Отбор.Регистратор.Установить(Выборка.Регистратор);
      ЗаполнитьЗначенияСвойств(НаборЗаписей.Добавить(), Выборка);
                            НаборЗаписей.Прочитать();
   КонецЦикла;
КонецПроцедуры

Может кто-то сталкивался с такой проблемой и подскажет, как решить такую задачку. Заранее СПАСИБО!


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
  Пока Выборка.Следующий() Цикл
      НаборЗаписей.Отбор.Регистратор.Установить(Выборка.Регистратор);
      ЗаполнитьЗначенияСвойств(НаборЗаписей.Добавить(), Выборка);
                            НаборЗаписей.Прочитать();
   КонецЦикла;

Если вы пошли таким путем, то у вас ошибка вот здесь. Непонятно где вы хотите произвести отбор если на форме то и делать это нужно для соответствующего списка, а не для произвольного набора записей. У вас должно быть поле с типом динамический список. Для него и нужно устанавливать отбор.

В данном случае запрос не потребуется. Просто нужно формировать динамический список и в нем устанавливать отбор.



Оффлайн Kseniya_

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-09
  • Сайт: 
  • Профессия: Ученик 1С
Регистр накопления
« Ответ #2: 09 Янв 2013, 10:33 »
Т.е. запрос вообще не нужен?

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Ну этот запрос можно использовать в динамическом списке.

Оффлайн Kseniya_

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-09
  • Сайт: 
  • Профессия: Ученик 1С
Получается динамический список - создается на форме списка автоматически? Подскажите где можно почитать про динамические списки (что это и как это работает)? Опять же правильно ли,что я использую регистр накопления? Можно так сделать?

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Я не знаю всей задачи. Возможно, и правильно. Вообще если работает и клиент доволен, то правильно.

Про динамические списки можно почитать в документации и на дисках ИТС. Создается он в полуавтоматическом режиме. Я же правильно понял, что у вас управляемые формы. Вы просто создаете реквизит формы, указываете для него источник - регистр, если надо меняете на произвольный запрос (причем он сам генерится), после чего выводите на форму.

Оффлайн Kseniya_

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-09
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо большое :-) Направили меня в нужную сторону.Все получилось через динамический список :-) и никакого запроса не надо


Теги:
 

Регистр сведений "Версии объектов"

Автор ЕвгенийЗерноРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 538
Последний ответ 20 Июл 2017, 17:00
от ЕвгенийЗерно
Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4850
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Не формируется регистр НУ "Расходы на оплату труда"

Автор DOKA@Раздел Пользователям "1С - Предприятие 8"

Ответов: 14
Просмотров: 10477
Последний ответ 23 Дек 2013, 17:22
от LordWizard
регистр "Данные о времени для расчета среднего"

Автор AlexRasmusРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2689
Последний ответ 15 Сен 2015, 19:14
от Дмитрий@
Регистр накоплений - себестоимость, не записываются движения документа "Реализация товаров"

Автор ekaterinka87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2831
Последний ответ 20 Июл 2015, 11:10
от ferrari314

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 254
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal