Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 13:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поиск сканером штрих-кодов в табличной части документа. Нужна помощь!  (Прочитано 5460 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dimi3o

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-05
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет! Возникла надобность ускорить ревизию на предприятии. Нужно подводить указатель к товарной позиции в табличной части сформированного документа "Инвентаризация по складу" простым считыванием штрих-кода для корректировки остатков. В документе "реализация" подбор товарных позиций по штрих-коду идёт. Подскажите, необходимо изменять обработку внешнего события или просто сменить драйвер сканера?
У меня стоит драйвер 2002 года АТОЛ 5.0 с библиотекой - scanopos.dll
Заранее спасибо!


Оффлайн start2000

  • **
  • Сообщений: 73
  • РЕПУТАЦИЯ: 29
  • КПД: 40%
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Программист 7.7
Если у Вас Торговля и склад, то смотрите как работает в документе Реализация Процедура ОбработкаВнешнегоСобытия. Добавьте такую же процедуру в Ваш документ Инвентаризация по складу. Чтения штрих-кода сканером это событие BarCodeValue. Далее можете использовать функцию глПолучитьТоварПоШтрихкоду для поиска товара с введенным штрих-кодом. Затем поиск номера строки табличной части с этим товаром в документе и если найдено, то использовать функцию АктивизироватьСтроку(<НомСтроки>) для перевода курсора на строку с найденным товаром.
если помог, то смело жми Спасибо!

Оффлайн dimi3o

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-05
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо! Всё сделал! Очень помогли!

Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
    // Процедура разбирает штрих-код, считанный сканером
    // и заполняет строки накладной
    Перем Упаковка,ТекКоличество, Спецификация;

    Перем ВремТовар, ВремЕдиница, ВремКоличество, ВремЦена;
   
    Перем СтрокаВозврЦена;

    Если Событие = "BarCodeValue" Тогда
        Если Форма.ТолькоПросмотр() = 0 Тогда
            //--------------------------------------------------------------------------------
            //Проверяем не карточка ли это
            ОбрШтрихкод = СокрЛП(Данные);
           
            // Определение типа штрих-кода
            ПрефиксШтрихкода = глПрефиксШтрихкода();
            Если ПустоеЗначение(ПрефиксШтрихкода) = 0 Тогда
                Если Найти(ПрефиксШтрихкода, Лев(ОбрШтрихкод, 1)) <> 0 Тогда
                    // Удаляем спец. символ из штрих-кода
                    ОбрШтрихкод = Сред(ОбрШтрихкод, 2);
                Иначе
                    Сообщить("Формат считанного штрих-кода не предназначен для товаров или карточек");
                    Возврат;
                КонецЕсли;
            КонецЕсли;
           
            Если глПолучитьТоварПоШтрихкоду(Данные, ВремТовар, ВремЕдиница, ВремКоличество) <> 0 Тогда
                ТЗ = СоздатьОбъект("ТаблицаЗначений");
                ВыгрузитьТабличнуюЧасть(ТЗ, "Номенклатура");
                НомСтр = 0;
                Если ТЗ.НайтиЗначение(ВремТовар, НомСтр, "Номенклатура") = 1 Тогда
                    АктивизироватьСтроку(НомСтр);
                    ПолучитьСтрокуПоНомеру(НомСтр);
                    Количество = Количество + 1;
                    ПриИзмененииКоличества();
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
       
        // Обработка закончена. Готовы к получению нового штрихкода.
        глСканерПосылкаДанных(1);
       
    Иначе
        глОбработкаВнешнегоСобытия(Источник, Событие, Данные);   
    КонецЕсли;

КонецПроцедуры // ОбработкаВнешнегоСобытия()


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
21 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
Artibon
13 Сообщений
LexaK
13 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal